Gledopto Zigbee RGB controller

Smartthings hub V3.
gledopto rgbw controller gl-c-007.
Probably 2ID. Using an inexpensive rgbw led strip (12mm) with WW leds.
Easily paired with Classic app. However…
can change color and saturation, but the WW are off. If I use the temperature slider,
The rgb changes to CW and the WW leds are brightest at 2700 and dim down as the
temperature increases.
I cannot get, for example, light red
(red rgb on and WW on). No control of both rgb and w.

This unfortunately is normal in the SmartThings device Handler. It’s treated like a RGBW bulb and not a RGBW controller (Gledopto Zigbee RGB controller). Because of this it also turns off the white when any color is used and vice versa.

The only way around this is a custom device handler.

1 Like

I see. Thanks @vseven!
Can you point me in the direction of obtaining the code for an existing rgbw handler, perhaps zll rgbw bulb and the hue version. I saw some posts by koenkk that address these problems. I can then possibly create a new device handler for a gledopto zigbee controller device handler (GL-C-007 then maybe -008). I found it hard to determine if someone has done this already, either on smartthings or on github.
Best regards, Bruce

Here is the RGBGenie Z-Wave DTH I made that has a “correct” white level slider: https://github.com/vseven/SmartThings_VSeven/blob/master/devicetypes/vseven/rgbgenie-zw-1002.src/rgbgenie-zw-1002.groovy In it when I do a “setColor” (line 174 and 177) you will see I set the white channels to 0 then when I set the white level (line 197) I set the colors to 0. You could easily just resend the white level and color levels instead of making them 0 to maintain both color and white on at the same time.

Best bet is to take the existing zll-rgbw-bulb DTH and make the changes above to it and see how you like it. Technically it doesn’t use color temperature so if you want you can remove color temperature and replace it with a white slider like in my DTH above. Or if you don’t want to mess with the tile settings and don’t care that it says color temperature just invert the color slider values being sent so at the “bottom”(2700k) white is off and at the “top” (6500k) white is full on.

I have brought this up with the developers on multiple occasions that Bulbs and Controllers are two different beasts and that most RGBW controllers don’t do temperature but its fallen on deaf ears. There should be a generic “ZigBee RGBW Controller” and “Z-Wave RGBW Controller” in addition to the bulbs that has these types of changes but there isn’t. (@tpmanley - revisit maybe?). In fact one could get fancy and have a device option that says “Allow both color and white channels on at the same time”. That would make it a lot more usable…actually might make that change in my Z-Wave handler as I’m using that for some Kitchen cabinet lights.

1 Like

That is really a good idea. Because there are times when I don’t want any white channel and times I do. A user selection would be slick.

So I just received my 1ID RBG+CCT controller ( GL-C-008) and a 5-1 LED strip (RGB+CCT). I paired it to ST v2 with no issues and changed the DTH to ZLL RGBW Bulb. Everything works great, including the red color. I can control the RGB and WW/CW from one light, but either the RGB or WW/CW LED are on at a time (as expected). That’s fine, as I don’t need all 3 on at the same time - the lights are really bright as is.

The one thing I want to see about changing is the min of the White color slider because at 2700 both the CW and WW lights are on. I’ve never modified a DTH and I’m hoping someone can walk me through copying the standard DTH and customizing it. Will I lose local control if I do this?

Thanks!

At 2700k you’re cool white should be full on and warm white should be completely off so something doesn’t sound right. Also, yes, any change you make will make it run in the cloud and not locally.

I changed the DTH so the WW was from 2700k to 2000k because of the WW and the CW leds were both on. With 2000k the WW is on only.

The DTH becomes online iso local when modified.

Grtn Ben

Try this one. Bad part is user preferences currently only work in Classic. But I added a “Allow both color and white channels at the same time” option so it should allow it.

Yeah, all “custom” DTH’s are cloud/online even if you tweak a single character. Also funny you should say that you modified it from 2700 to 2000. There is a meta data change about that but nothing else in it I can see: https://github.com/SmartThingsCommunity/SmartThingsPublic/commit/ef595c090ace329118a39e5b9d1e81f5120f12b9 Maybe that controller is actually 2000 - 6500 and not 2700 - 6500?

Here some (3) of my modifications:

runLocally: false

definition (name: "ZLL RGBW remote", namespace: "smartthings", author: "SmartThings/ben", ocfDeviceType: "oic.d.light", runLocally: false, minHubCoreVersion: '000.021.00001', executeCommandsLocally: true) {

Added my Gledopto RGBWW controller

    fingerprint profileId: "C05E", inClusters: "0000,0003,0004,0005,0006,0008,0300", outClusters: "0019", manufacturer: "GLEDOPTO", model: "GLEDOPTO", deviceJoinName: "GLEDOPTO"

Changed the color range from 2700-6500K to 2000-6500K

    controlTile("colorTempSliderControl", "device.colorTemperature", "slider", width: 4, height: 2, inactiveLabel: false, range:"(2000..6500)") {
        state "colorTemperature", action:"color temperature.setColorTemperature"

This is what I can remember. It is a Samsung Smartthings genuine DTH a found somewhere I modified.

Long time ago I had an Osram RGBW bulb, but it wasn’t warm white enough, so I returned it.

Later on, with a Philips Hue RGBW bulb, I had the same problem.

With the Gledopto RGB-CTT/RGBWW I found out what happened: I saw the CW and WW leds in the strip both illuminating. That was the reason the result was not so WW.

This modification solved my problem.

Grtn Ben…

I recently swapped a Hue controller with a GLEDOPTO RGBCCT cotnroller. While it mostly works, I have a couple quirks that stopped me cold from swapping the remaining 3 Hue controller (trying to get away from Hue ecosystem).

  1. Yellow is pretty much non existent being extremely dim
  2. Selecting any whites using the RGB control results in a very dim light. The only way to get decent light output is to use the color temperature slider

While I want to decommission my Hue system (moved to LiFX for all colored bulb needs), I am not happy with the control options offered by the GLEDOPTO controller.

Any solutions to this issue?

  • I have the same problem, not all the colors are available. Don’t know if it’s the controller, the ledstrip or the combination of both.

  • You have to choose, dim with by the RGB (all together make white) or use the Coolwhite and the Warmwhite leds to obtain bright white.

Grtn Ben

1 Like

Stumped here. I picked up the Gledopto zigbee controller because they were on sale for Prime Day last week. I had a set of dumb RGB tape LEDs laying around and this was perfect. Getting things connects was extremely straightforward and I had no questions on what to do.

But I simply can not get these things to light up. I’m using the 12V 5A power source that came with the LEDs and confirmed beforehand that the LEDS all worked correctly with this power source. I’m quite sure this power source is correct for the Gledopto. The green LED on the controller even lights up. I’ve confirmed I have the correct DTH and the correct firmware on the ST Hub.

Are the LEDs supposed to light up when you plug the power into the Gledopto? Unless I’m missing something, I think the Gledopto is just a lemon…

Remove the white wire that’s connected to the W on the controller and connect it to V+ on the controller. The W and C connections are for RGBW & RGBCCT led strips.

1 Like

That worked! Thank you!

GL-C-008 vs GL-C-007?

I bought a new 2ID RGB+CCT controller (Zigbee).

The box says model no. GL-C-008, on the controller is printed FCC ID 2AR8F-GL-C-008.

The SmartThings hub reports :

Data
*application: 01
*endpointId: 0B
*manufacturer: GLEDOPTO
*model: GL-C-007
*zigbeeNodeType: ROUTER

What is right, what is wrong? Only have 1 Zigbee “Thing” after pairing this controller to my SmartThings hub v2.

Was the correct controller shipped in the box?

Grtn Ben

As far as I know, directly pairing that controller to Smartthings will do as you said, 1 thing and you can assign that 1 thing an rgbw light. The only way I was able to get it to work correctly was to buy a cheap used Hue hub from eBay and pair the controller to that which will show you two proper lights in Smartthings. Perhaps it has changed but that was what I found earlier in the year when no one answered my questions on directly paring it to Smarrthings

I find it strange that the new controller shows ident GL-C-007 in SmartThings while the box and the placard show -008.

Grtn Ben

I was considering purchasing a used Hue bridge for the gledopto. Did you gain other benefits in addition to being able to control the 2 light channels separately? I am trying to decide if it’s worth the effort.

I received the controller 2 days ago. Tried it to pair, that gives 1 ID.

Wondering if there is a mistake in the controller, due to the difference in model number.

Is it a -7 or -8 and is that a problem/mistake?

Wait for a reply from Gledopto in Reddit.

Tnx for the idea to add a second hand Hue Bridge v2. I’m looking for one.

Grtn Ben

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.