GH "Looks like those lights haven't been setup yet" after I've linked ST


(Justin Melick) #1

For the past few weeks my GH hasn’t been working correctly with ST even though in the apps it appears that everything is connected correctly. To make things even weirder one of my lights that are connected to ST do work through GH but all of the rest give me the same error. Anyone else have this issue?


#2

I haven’t been having a problem lately. Have you disconnected and re-authorized your SmartThings account since the recent GH update? If not this may be the source of your issues.


(Justin Melick) #3

I’ve done this a few times to no avail unfortunately


#4

Wow, i’m sorry but i haven’t experienced that problem.


(Bill) #5

I had that problem several weeks ago but it seems to have been resolved. If I recall, I disconnected and re-authorized the ST account as @PhilB mentioned. It seemed to work properly after that but it could have been a coincidental update to GH just prior.


(Justin Melick) #6

When you say disconnect and re-authorize do you mean disconnect through GH and then re-link?


(Jeff H) #7

If you set nicknames, make sure to call them exactly by the nickname set. If no nickname set, use the name exactly as it reads in ST. If the ST name is not what you want to call it, change it.

If you want to say Hey Google, turn on the table light, then it needs to be labeled exactly as table light , nothing else.

If I have a switch control one light name it for example table light, if that switch controls two lights I would have lt labeled table lights with the s on the end. Then I found it does make a difference if you say light or lights to GH so say it like its labeled.


(Bill) #8

Yes, unlink thru the GH App and re-link.


(Justin Melick) #9

I tried that before and the nicknames didn’t make a difference. Would it be beneficial to take all of my devices off of ST and then re-link GH?


(Bill) #10

Read through this short thread and see if anything there helps. Be sure to see what it is GH thinks it heard.