Gentle Wakeup Help Needed with Ikea Tradfri bulb (Colours aren’t right)

I’m new in the home automation scene and figured that it would be good to start with a smart bulb so I bought a multicoloured one from my local Ikea. When I tried to use the SmartApp Gentle Wakeup the light turns to a purple colour.

My question is: is it supposed to do that and is it possible to make it a warm yellow or something more similar to a real sunrise.

Sorry for a dumb question if it is supposed to do that :confused:

Not a dumb question. I ran into the same problem. For some reason when color is enabled on that one when it goes to dim up it gets a “blue hue” and when it dims down it gets a “red hue” both of which are a list of hard coded values by level of brightness. I never did find out why it was written that way.

I’ve been running this fork of that smartapp at my home:

It adds support of changing the hue of color temp bulbs along with the brightness going from 2200K at the dimmest to 6500K at the brightest.

My changes are super hacky, so no promises that it’ll work for you, but if you already know how to publish a custom smartapp, might be worth a try.

I really should try to make those changes less hacky and see if I can get the changes upstreamed. I just haven’t had the time.


Thanks for the fast answer. I tried to Google how to install a smartapp but didn’t find any simple guide, only developer integration, can you recommend any forum post or video of some sort that shows how to do it?

Thanks again.

I know I’ve seen a tutorial on the community somewhere, but I can’t seem to find it now, hopefully someone else around knows how to find it and can link to it.

1 Like

I get an error when I try and use your forked app… Its is looking for azdle device handler Device type ‘Gentle Wake Up Controller’ in namespace ‘azdle’ not found. @line 306 (initialize)

D’oh. I forgot there were two pieces to that.

I added the associated device handler that you also need:

1 Like

Here’s the community FAQ: ( The topic title is a clickable link)


1 Like

Now I get this error… Not sure what is missing in the code

Java.lang.NullPointerException: Cannot get property ‘groovy’ on null object

I figured it out you added the new code to the top…