GE Zwave add on switch for 3 way not being detected


(Christopher Karsanac) #1

I just installed a “GE Z-Wave Wireless Lighting Control On/Off Switch, In-Wall, Z-Wave Plus, 1429” and a “GE Add-On Switch for Z-Wave, ZigBee and GE Bluetooth Wireless Lighting Controls, 12723” for a bedroom light. The switches work manually. (i.e I can turn on/off the light with either switch by touching them physically.) The smart switch is in the bedroom while the add on switch is right at the bedroom door, closer to the hub.

The hub can detect the smart switch in the bedroom. BUT, it does not detect the add on switch. Is it suppose to? The reason being, is that if the bedroom light is turned on or off with the add on switch, smarttings does NOT register the light as being on or off. It only detects the last command from the bedroom switch.

E.g. I walk into the bedroom and turn on the light physically with the add on switch. I check the app and it says the light is still off. I can then turn off the light with the smart switch, and the app still says off. I can switch the light on with the smart switch, and the app says the light is “on”. But, if I then turn it off physically with the add on switch, it still says “on” in the app.

The issue with this is that I have to tap the app smartswitch on and off to make sure it is off.

Does this all make sense? Thanks for any help!!


#2

The add-on switch will not register as a SmartThings Thing. It has no radio in it and is just a remote for the master switch. The fact SmartThings is not showing the state of the switch when you press the add-on is probably just a delay thing as these switches do not have instant status reporting. Eventually the app will catch up.


(Christopher Karsanac) #3

Waited 30 minutes. Surely not that laggy…


(Don) #4

Is it wired correctly? I know silly question just asking.

Also is the main switch changing state when you toggle the light with the remote switch? IE…Does the led on the front change? Can you hear it turning on?

The remote switch is just supposed to signal the main switch via traveller wire to turn on or off. The main switch does all the load control.


(Christopher Karsanac) #5

Not a silly question. I think it’s wired correctly. The switches work like any other 3 way. Smartthings recognizes the main switch.

When I switch from off to on, on the app, the state changes on the app, the main switch clicks and the light comes on. The LED turns on as well (i have it set this way so it doesn’t bother my daughter at night).


(Don) #6

Does it do the same thing when you only use the remote switch? Or is that when you use the remote switch.


(Christopher Karsanac) #7

By remote switch, do you mean the add on switch? If I physically manipulate the main switch, the app registers all changes. If I physically turn the lights on with the add on switch, the main switch clicks and the lights come on, but the app doesn’t register the change.

What part of TN? We lived in Nashville for a long time…


(JBrown) #9

I had a similar problem with a switch I installed but I was not using a add-on switch, when I used the app the switch turned on/off and indicated on/off in the app, but at the switch I could turn on/off the light but the app did not change. My switch had a air gap “if you don’t have a air gap try turning breaker off then back on” so I pulled it out and put it back and the switch started to work correctly.


(Don) #10

About 1 hour and 30 minutes south.

If you can hear the master switch changing when using the remote switch then it’s possibly wired right.

Just trying to do quick checks for possible wiring issues.

Try @Jason_Brown suggestion and cycle air gap switch.


(Ray) #11

Can’t remember which post but we did have this problem before. I think some of my add on switches do still have this lag problem. It’s a smart thing and GE problem. Try switching to another DH. Nothing is wrong with your wiring.

Edit: I think I solved some of my problem is to remove and add the switch again.


(Cody Farmer) #12

I recently have been installing these same ge switches including the ceiling fan switch. I’ve had success with all my single pole and two way switches. I just checked my two way add on switch and it reacts to ST the same as the master switch. I plan on doing my living room 3 way next with one main light and light connected to ceiling fan I hope I don’t run into this problem. I’m no electrician but if my 2 way install works shouldn’t my 3 way be similar.


(Christopher Karsanac) #13

Well… tried:

  1. Turning off breaker
  2. Pulling out “Air switch”
  3. Removing switch from smartthings app and then re-discovering it.
  4. All combinations of 1-3

No luck.

So, two final thoughts…

I installed the add on switch first, so I’m going to cut the power, disconnect the add on switch, turn on/off breaker and rewire the add on switch. (Should that have made a difference?)

If no luck, can I use another master switch at the add on switch position?

Last resort, HUE bulbs and replace the old switches.


#14

Did you ever get this to work?

I’m actually not a SmartThings user yet but I have these GE z-wave switches setup through my security system (Abode). I’m also experiencing this issue but the Abode devs are saying that when you toggle the add-on switch on/off (which we know is simply telling the master switch to turn on/off), the master switch doesn’t actually send a z-wave signal to update the status of that switch, hence the app being out of sync. This would mean the issue is with the GE master switch itself.


(Daniel Hamel) #15

The GE Add-On switches will never register with Smartthings as they directly control the master switch though the neutral and traveller, they do not have a radio.


#16

Yeah I understand that part. My point is when you toggle the add on switch, it’s sending a signal to the master switch. The question is does that master switch send a Z-wave signal to the hub saying I’ve been switched “on” or “off”?


(Daniel Hamel) #17

Same as if you pressed the master switch


#18

That’s how I figured it should work, but based on the original posters issue and what the Abode system devs are saying, it sounds like this is not the case.

I’m assuming you have GE Z-wave switches and add-on switches and it works as you’re describing? If so, which version of the GE switch are you using? 12722? I’m wondering if there’s a specific line of the GE Z-wave switches that doesn’t work this way.


(Allan) #19

I have multiple GE 3-way add-ons, just tested a couple different circuits and the app updates at the same rate as clicking the actual master switch, anywhere from 6 - 10 seconds later. The fact that clicking the add-on is turning the lights on and off should tell you its wired correctly.

Not sure where the problem lies. I’m using the stock “Dimmer Switch” DTH that gets installed by default for all of mine so if you are using another I’d switch back and retest. Or reboot your app (kill it and restart or reboot your phone).


(Daniel Hamel) #20

Same, i have 3 sets of 12724 Load-Bearing dimmers and 12723 Add-on switches

There is no difference between me using 1 or the other.


(Ray) #21

I think @Tyler or one of the staff explained about this before. Can’t seem to find the post.
I think it’s a GE firmware issue.