GE z-wave switches indicator status light multiple status check in ST app

I see all my GE Z-wave switches doing a status check 6 times a minute. Is this normal? I have quite a few GE switches and they are flooding my event logger. I don’t need to know it every minute. Before I am reporting to support. Anyone else?

Short answer: Not Normal. Just checked my logs and I am not seeing that.

Before contacting support you may want to consider a hub reboot. Commands could be stuck in loop and keep on sending it out.

1 Like

I have seen this before in spurts when working on something else. Along with fan switches repeatedly saying med, then high, then med. Fan not changing at all.

I’ve yet to resolve or REALLY look into it.

Support did have me remove and reinstall one of my fan switches before thinking that would fix it. It came back later after hours with support removing a working switch and fighting to get it back up.

I look forward to seeing what you find?

Just solved it. A hard power off (no batteries and AC power off) did not work. A soft reboot in IDE stopped the flood.
I did have the on/off issue last year and I was told to remove/add as well. Don’t want to do that again. Too many switches.

1 Like

I seem to get this sporadically, too. But it seems to clear itself up.

1 Like

Darn it. The flood is back. I guess support is the next step.

1 Like

I am seeing multiple updates in the logs. Not 6 a minute but getting them when I wouldn’t expect them.

I also have some that turn off at night via the Indicator on Schedule SmartApp and for the last few days the LEDs have not been conforming consistently to the rules on some of the switches. For example, I have several that should come back on at 7:45am. The app appears to run, the LED option for the Thing is set as expected but the LEDs do not turn on until I toggle the option.

I think all mine that are not included in the Indicator on Schedule app are okay LED-wise but I am seeing the multiple log entries for all of them.

It could just be a coincidence and nothing to do with the Ind on Sched - I have no idea.

There are weird things going on with the GE switch device handlers recently. Members report different switches using different device type handlers even though they should all be using the same one.

I think it was @SBDOBRESCU Who determined that some of his were running locally and some were not even though he had not made any changes.

1 Like

Just looked at mine and ALL of them are doing it. GE and Linear. And they all do it at the same time. Weird!

So all the switches with “z-wave switch” DTH are doing this. I changed to " Genetic z-wave switch" and they are not causing the indicator light anymore but by doing so. I no longer have local processing with the Genetic z-wave switch DTH.

1 Like

Let support know, there’s definitely something weird going on on the backend.


i went ahead and created a ticket with them.#305067


Yeah, ticket #304980. Just waiting for them to reply so I can give them more info.


I got a response to my ticket

"Thanks for reaching out! These events are actually stemming from the standard update calls that these devices will see on the network, but they actually don’t translate to anything other than the events you see on the device page. This is actually being addressed in an upcoming update, so this should go away soon.

In the meantime, these events aren’t anything to worry about, especially if the devices in question are functioning as they should. If there was anything more that I can assist with, please feel free to let me know!"


Strange on how I get my response compare to your email.

" Thanks for reaching out to us.

I took a look at things on my end, and it looks like you may have changed the device type back to the default device type and with the default device type you do not appear to be getting those indicator status updates anymore.

Let me know if there is anything else I can help you with."

I changed 2 devices to the z-wave switch genetic DTH but I have 10+ of these devices flooding my event log every minute so you can imagine how hard it is to check my log. Hope it does mess up my z-wave mesh. Hopefully I will get a better response to my other email. One of the device with the new DTH missed the sunrise/sunset smart lighting trigger.


Finally I solved this. It was caused by my flaky internet switch. The switch caused the ST hub internet connection to go offline but not long enough to show up in the ST app. When the ST Hub came back online. The ST hub requested all the z-wave switches for the indicator light status hence the flood on my event logger. It was a nightmare at my house the last 2 days due to ST delay lights and routine caused by my switch. So far so good and I can actually be able to look at the activity feed.

1 Like