GE Z-Wave On/OFF Switch settings for Indicator LED? (Asked Before)

I have asked this before, just hope there is new info.

I have a GE Z-Wave On/Off switch and have the LED’s set to turn on when the switch is in the off position but the light never comes on no matter what setting I have. Anyone know how to fix this?

It depends on the exact device type handler that you are using, but typically when you open the devices details page there will be a gear that lets you change the initial parameters, including indicator LED behavior.

A number of people have reported in the last month that their switch behavior mysteriously changed, sometimes just for one or two switches, and it appears that the device type handlers being used were different even though they themselves have not made any changes. Which is weird, but has been reported by multiple people.

So the first thing I would do is review which device type handler is being used and make sure the settings are still the way you want them.

I am using Z-Wave Switch, there are two both the same. I have the settings set as they should be. I haven’t played with Z-Wave delay etc as that shouldn’t have anything to do with LED. I tried both On when switch is On and On when switch is Off, both don’t work. Is there another device handler?

Sorry to question the obvious, but if the light never comes on regardless of what you do, are you sure the light isn’t just gone ?

1 Like

Might be since I never had it on.

Try z-wave switch genetic. You can check this post about my problem with the indicator light.

Tried Z-Wave Generic Switch, same response. Hopefully ST comes up with a fix. But if not I will have to live with it.

This will do what you want

It has an on screen button to toggle the indicator light

1 Like

Do you mean in the config, if so they all have that button. I will try it just to test but it like it to run local…

Not in the config. On screen as go to you’re “Thing” in the mobile app. You’ll see.
Also, it will not run local, but through the cloud.
Only some smartthings devices run local, not custom.

When you first install the generic device handler, light defaults to always OFF. You can modify behavior in IDE.
Smartthings has been having issues lately and changes from mobile app do not always propagate.

I have a good portion of my devices running local, but one switch won’t matter if it is in the cloud. I will try that Device Type. Thanks.

You might try excluding, resetting and then adding the switch again to your ST. And never change network node for any device.

Tried that.

This works really well. Do you have a similar DTH for the dimmer?


Is this what you need?

I hope this is a good place to ask this, since it is sort of related. I have the ZWave switches and the default is to have the LED on when the load is off. A mistake in my opinion, but it’s programmable, or so I’ve read. Jasco states that parameter 3 can be set to 0, 1, or 2, depending on the characteristic desired. Since I am not a coder, my question is, What combination of controller and application has the capability to modify parameter 3? I have a Wink hub 2 but that doesn’t appear to be sophisticated enough for this task.

@joelw135 it’s possible the LED got accidentally disabled completely. Have you tried the procedure to re-enable it at the physically switch itself?

Press ON three times in quick succession (unfortunately I’ve not found just how quick)
Press OFF once.

Unfortunately the ‘never lit’ LED setting is broken on the 12730 fan controller but that’s another story.


Is that on the switch, or in the DTH?

THANK YOU!!! I’ve had one out of over two dozen of these switches that the LED NEVER worked! Drove me crazy for the past year. The “press on 3 times real quick then off” trick worked! When nothing else would. Not sure how it got disabled on the first place!