GE Z-wave plus switch - direct association

I’m having a little bit of trouble with direct association between several GE z-wave plus switches (14291) and one GE z-wave plus outdoor outlet. I have 5 different lighting circuits for the backyard, and I want them all to come on together when one of the main switches is turned on/off. I have been using the classic Smartthings Smart Lighting app for the past several months with mixed results. I had it set to turn the other switches on or off based on one main switch (did not try the Mirror feature). Typically, when the switch is toggled, the other lights start coming on at slightly different times, from 1-5 seconds. Occasionally one or more of the circuits just doesn’t respond at all, until it’s turned off and back on. A few times, it’s gotten itself into a loop where they switches don’t seem to know which state they are in and start cycling on and off without end. Definitely not consistent, and does not quite meet the wife approval factor.

The main switch I’m trying to use is located inside, in the center of the house. There are two more inside, one at the front of the house one at the back. The other two are outside at a patio/kitchen area.

So in order to try and make it more consistent and quicker, I set them all up under a direct association to the main switch. Using the Z-Wave tweaker, I set them all up under group 2 to be associated to the central switch. Now, when I turn that switch on…all the lights come on together - perfect! Except…it’s on a very repeatable 5 second delay. From reading the FAQ, it looks like the direct association ignores the mesh network (There are many other items on my z-wave network), and only does 1 hop. Is that my problem? Is the distance between rooms possibly too great? Is there anything I can do about the 5 second delay? I suppose this is better than what I had with the smart lighting app, but it sure isn’t very quick about it.



I’m not sure the answer to your problem. I will say that I have a fair number of direct associations set up at my house. I do not see a 5 second delay. It is a fraction of a second delay. Something seems not quite right.

  1. Do you have the Smartlighting routine turned off? (just don’t want that causing confusion)
  2. Are there any delay parameters in your GE devices that could be causing the issue? If so you should be able to adjust with Tweaker.

You may try powering down all the switches and bring them back up. (just a shot).

Good luck

1 Like

In my experience zwave association either works instantly or it does not go.

1 Like

Another suggestion. Run a zwave repair command from the hub using the app. That may help cure your delay.


Thanks for the suggestions. I did run a zwave repair right after setting up the direct association. Maybe I should do another one. I also did delete the Smart Lighting routines I had set up for these switches. There are no delay parameters for the GE devices (that I could find). I did find a mistake in my group setup - I had included the trigger switch in the group. Last night I removed it, and it did seem like the behavior was quicker, but not always. Occasionally it would be almost instant, but some times it would take 5 seconds again.

I set up another direct association between a different switch and a couple of z-wave plugs, all in the same room very close to each other. Saw pretty much the same behavior. Some times would be near instant, some times a few seconds. A couple of times the plugs never triggered. As with the backyard lights, when they do trigger - all circuits come on at the exact same time.

Ramp rate.

This is the manufacturer site for the GE zwave Devices:

Dim Rate Adjustments
Both the number of steps (or levels) that the dimmer will change and the timing of the steps can be modified to suit personal preferences. The timing of the steps can be adjusted in 10 millisecond intervals. As an example, the default setting for parameter 8 is “3”. This means that the lighting level will change every 30 milliseconds when the Dim Command is received. A value of 255 would mean that the level would change every 2.55 seconds. Combined, the two parameters allow dim rate adjustments from 10 milliseconds to 4.2 minutes to go from maximum-to-minimum or minimum-to-maximum brightness levels.

The particular switches I use are not dimmable, just on/off toggle. GE/Jasco shows it to have 2 parameters (3 & 4) which control the LED and allow you to invert the switch if it’s installed upside down.

1 Like

Then something’s definitely wrong, association should be nearly instant.

I know it’s a lot of work, so I understand if you don’t want to do it, but it would help us if we could see what tweaker says the associations are set to. Also need the exact model numbers of both devices.

Not a lot of work at all…I appreciate the help. For my backyard circuit, 4 switches are GE 14291, and 1 outlet is GE 14284. The main trigger switch is one of the 4. They are on nodes 13,14,15,16,17 (trigger switch is 14).

And those node IDs are in hex? So “15” is 21 in decimal?

I assume so. I’m going by the IDE listed Device Network ID. The group association syncs correctly, and the devices do turn on.

Well, I don’t know how or why - but the problem seems to have fixed itself. It’s now finally acting like it should, and pretty much instantaneously turning on the other lights.

Thanks for the help!


1 Like

I am having the same problem right now. I have a GE 46201 in the wall. It only takes mains power to run the switch and does not have a load line on it. In my ceiling fan I have an Enerwave Dual Relay. Using ZWaveTweaker I add the id for the enerwave dual relay (which will control relay 1 ) to the GE association group 2. The first 4 or 5 times it was just about instant but then the 4-5 second delay started.

I have repaired the network a couple times and tried a different device in association group 2. Still the same behavior.

I have also reset the GE Switch to factory settings and still doing the same thing.