GE Dimmer Switches: Default to full brightness?


(Ash Raj) #1

I have 14 GE dimmer switches (12724) and it’s very annoying that they always remember the last dim level. Although my LEDs can be dimmed all the way down to 1% after they have been turned on, they cannot turn on without at least 10% power. Every night my parents keep the dimmers at the lowest level for a couple hours before sleeping. The next day, they get irritated when they press the switch and the lights don’t come on.

How do I make these dimmers turn on at full brightness when someone presses the physical switch? I’ve tried a SmartApp solution that sends a 100% brightness command when a switch is pressed, but I’ve found it to be too slow and inconsistent. Instead I’d like to program the switch itself, perhaps using a more sophisticated secondary controller. Does anyone know how to do this?

If this turns out to be impossible, I may have to switch to different dimmers. Do you have any recommendations?

Thanks!


Reset dimmers to 100%
(Ray) #2

This is the app you are looking for Dimmer on bright


(Eric R) #3

I appreciate you linking to my app, but it is the one he is referring to as slow and inconsistent. It is definitely a problem with the hardware.


(Ray) #4

Ah, didn’t know that was the app he tried. Not sure how slow is slow but it works quite well for me with linear dimmers.


(Eric R) #5

With the GE dimmers, it’s hit and miss. Maybe I need to get a linear dimmer…


(Ash Raj) #6

This is a great short-term solution, but it adds an extra 5-10 second delay and sometimes it doesn’t work at all. I also keep having this problem:

  1. The last person who used the dimmer had it at 100%
  2. I press the switch and the lights (obviously) go to 100%
  3. I dim the lights to 70%.
  4. The app kicks in late and changes the lights back to 100%

I think the only long-term solution is to change the settings of the GE dimmer itself, or find a different dimmer.


(Ash Raj) #7

@baldeagle072 I appreciate you for writing this app! I’m sorry if it seemed like I was ragging on it. I’m sure my issues have to do with the hardware, not your code. I was wondering… Is there any way to change the dim level without turning the lights on? If so, maybe you could set the brightness to 100% every time the switch is turned off. Then the delay wouldn’t matter.

If you’re planning on changing dimmers, try the Leviton DZMX1. It always turns on to the (user selectable) default brightness, instead of the previous brightness level. This is the dimmer I would have installed, but my parents don’t like the feel of the “dim bar.”


(Eric R) #8

I tried that, but it would actually turn on the light


(Ash Raj) #9

Another idea:

Compared to incandescents, my LEDs take an extra second to turn on. If you change the brightness to 100% and then immediately turn the dimmer off, maybe it would happen so fast that the LEDs won’t have a chance to light up. Clearly this won’t work for everyone, but it might work for some.


(Ash Raj) #10

@baldeagle072 IT WORKS! The commands are so close together that the LEDs don’t turn on. (Incandescents do exactly what you’d expect.)

Now, how can I select all of my dimmers instead of just one?


(Ray) #11

talking about saving all the works and cash on replacing the switches!
change line 29 to input “dimmer”, “capability.switchLevel”, title: “Which dimmer?”, required: false, multiple: true
and you get all the light selection.


(Ash Raj) #12

Just tried it. Indeed I am able to select multiple lights, but then turning the lights off in one room turns off all of the lights in the whole house.


(Ash Raj) #13

This SmartApp still isn’t a great long-term solution :-/.

  • LED technology keeps getting better. If my next bulbs respond faster, I won’t be able to set the brightness without turning them on.
  • Occasionally Z-Wave polling will lag 20-30 seconds, so this app will drive someone crazy if they decide to turn the lights back on after turning them off.
  • While it’s nice to automate stuff, I don’t think I should depend on a SmartApp for basic functionality like this. If the Hub goes offline or I switch platforms, the lights will stop working as expected.

The only perfect solution is to program the switch itself to ignore the last brightness level. There’s probably an undocumented configuration parameter for this, I just don’t know what it is.

It may still come to that. Of course I would like to avoid the work of replacing these switches, but I can return them until the end of the month, so cash isn’t an issue.


(Bruce) #14

I use an app that does this at mode change only, and only adjusts lights that are not turned on by some other app that uses setLevel, and that aren’t already on. I’m doing it for z-wave lights, and the z-wave polling is not an issue (it becomes an issue when using the physical switch). What this accomplishes is that the next time one of these lights is turned on with the switch, it comes on at the correct dim level for that mode. At mode change, when this runs, sometimes you can see the light flicker on momentarily, sometimes not at all.


(LJ) #15

Hello Bruce,

First, I’m looking into your really nice smart app, Rule Machine, and I’m trying to do what you described here. I would like to change the level on mode change without opening the lights. I use the GE dimmers and when I set the brightness with rule machine, it open the light at the same time. Any idea how can I do this with your smartapp without opening the light?

Thank you for your help!

LJ


(Bruce) #16

This is a bit complicated, but doable.

First you need a custom device type called “Dimmer switch with reset”. You can get this from my Github, here: https://github.com/bravenel/SmartThings/blob/master/Dimmer%20Switch%20with%20Reset. In your IDE, go to My Device Types, and create a new device type, select From Code, and paste that in, Save and Publish for me.

Next, for each dimmer you want to be able to change the level on at mode change, in My Devices, edit each device, and change the Type from “Dimmer switch” to “Dimmer switch with reset”. The new Device Type will be near the bottom of the list of available device types. Click Update after changing the type.

Next, in Rule Machine Expert Features (bottom of main page of Rule Machine, below Create New Rule), select one of these devices and it will look up the available commands. One of the commands is “resetLevel”. That’s the command you want. You will need a parameter for it, which should be the level you want to set the dimmer to. You will need one such command for each level you want, and each one must be Saved in the Expert Features section.

Once those are created and saved, they become available as commands in Rule Machine actions, “Run custom commands”. From this point you can just create a trigger, with the mode becoming one you want, the the action being the appropriate command you created and saved. Select the dimmers you want to set, each of which should be one that you changed the device type for. Then select the appropriate custom command for the mode change you are setting up.

That’s it.


(LJ) #17

Bruce, you are a genius! It’s working very good! Thank you so much.

LJ


(Bruce) #18

The lights will blink when they are reset. Noticeable for higher dimmer levels, almost impossible to see for lower dimmer levels.


#19

Thanks Bruce. This is exactly what I was struggling with!


#20

Can this be done also in CORE?