GE light bulb would blink as if it has been paired but would not appear on app (Help)

I bought a GE smart light bulb starter kit. Everything great and working, Then I bought 3 more GE separate bulbs only, 1 of them was paired working successfully but the other 2 would blink as if they have gotten paired but it wouldn’t show the success screen on wink app and no bulb would appear. Anyone knows how to fix this? I have rested the bulbs many times and tried multiple times different outlets and etc.

If you are using the Wink app and hub, perhaps you should check the Wink forums?

1 Like

I’m sure that’s very frustrating! These forums are for people using the SmartThings hub, so we may not be able to help you if you are using a different system as each system has its own peculiarities.

That said, if you bought the starter kit you probably have the GE “link hub.” It’s a small cube that plugs directly into the outlet. ( that’s not the “wink hub” which is a much larger flatter device which has a cord that plugs in.)

If that’s the one you have, it has a problem because GE put out some new bulbs this year called “daylight” bulbs and they don’t work with the “link hub.”

They will work with the SmartThings hub, but you have to change the device type handler.

More information on using the bulbs with the SmartThings hub in the following thread (this is a clickable link)

Wink Support can probably give you the best help regarding the GE link hub:

Oh, my apologies. Here are a few links that might help you with troubleshooting GE Link Bulbs. Unfortunately GE Link bulbs can be somewhat flakey and there is a known bug in the firmware that can cause them to drop off the network sometimes. For that reason, it’s not officially supported by SmartThings. That being said, many, including myself use them and they work most of the time. Try bringing the SmartThings hub within a few feet from the bulbs that you are trying to pair. Reset the bulb by turning it off and on 5 times pausing about 3 seconds each time. After the fifth time on, it should blink. Go to the marketplace icon in the SmartThings app (bottom righthand corner) and click on the + Connect a New Device link. This will put the SmartThings hub into search and pairing mode. Hopefully, your bulb will be found successfully.

After probably 45min, What worked for me was:
-Reset the Light(on 3sec/off 3sec x 4-5).
-Unplug the Link Hub for a few seconds.
-Plug the Link Hub back in.
-THEN Go through the pairing process.

Another way is after the light blinks. Kill the ST app and reopening it. That usually work for me.

Not sure if I tried that. Link Bulbs can be very glitchy at times. One Tip I would recommend is that over time moisture can build up inside the plastic dome of the bulb. So to prevent this I drilled several holes with a 5/32" bit. I just did this the other day so I’ll see how it does over time.

The only issue I keep getting is GE bulbs independently turning on and off with no record of action in the notification tool to see what triggered it.