GE/Jasco toggle switch disconnects

I’ve seen various posts on how to deal with ‘offline’ Z-wave switches, but nothing definitive on problem resolution.

I’ve just installed a GE/Jasco toggle switch to control a bathroom fan. Switch added fine, toggles fan off/on fine. I added a timer (power allowance) to have it shut off after 10min of running, and paired with a humidity sensor to have it come on if the humidity is over 60%. Worked great! Except… switch keeps going offline. Physical switch works but after a few uses/tests, the switch will show ‘on’ when it is really off, and at that point the run timer, humidity trigger, and remote control doesn’t work, and the switch is offline again. I’ve removed/re-added 5 times now. Will work for a few minutes (5 or 6 test cycles) then goes offline. It’s ~7feet from the hub. I’ve repaired the zwave network a couple times, doesn’t help. Disconnecting the switch neutral wire and reconnecting resets the switch and helps for a few minutes. Just a bad switch? Is there something about controlling a fan that’s a problem? I’m out of ideas, thus my post.

GE/Jasco makes a switch that’s specific to controlling fans.

Not sure about their general purpose Z-wave switches but other brands typically warn against using them for fans.

Thanks. The box says ‘other devices’ but doesn’t specifically say ‘fans’. Do you think that controlling the fan is causing the zwave disconnects? Why would that happen? I’m trying to educate myself… I’ve read a couple places there is a problem with ‘inductive load’ on variable speed fans. This is just a small single-speed bathroom exhaust fan however.

I’m not finding one with a ‘toggle’ behavior, which I think is the right switch behavior for humans to understand how the switch works (vs a switch which may be off in an on position, or on in an off position…). I did find this switch which specifically mentions ‘fan’:

I’d really be interested in others who have either solved this problem or had success with a particular switch.

There’s a big difference between a typical single speed relatively low power draw extractor fan such as normally used in bathrooms and a multi speed ceiling fan.

While you shouldn’t use a dimmer switch to control any motor device, including any type of fan, a regular binary on/off switch is often fine for controlling a 110v extractor fan.

In fact, Jasco specifically lists fans of this type for most of their Z wave on/off switches. :sunglasses:


So as always, the first rule of home automation applies: “the model number matters.”

If it’s a dimmer switch, it should not be used for a fan. If the fan is multi speed, it should not be used except with a switch specifically designed for multi speed fans. If it’s just an on/off not very powerful fan, such as commonly used for bathrooms or kitchens, then it’s probably OK with most on/off switch is, but read the Specifications for the specific model.

1 Like

It’s not likely because it’s a fan of the type you mention Unless it’s a dimmer switch.

Sometimes strengthening the mesh will help. How far is it to your next mains powered zwave device? Sometimes bathrooms have a lot of tile, mirrors, water pipes, even just having a person in the room or having the door shut can degrade the signal enough that it can’t get through. I usually try to make sure there’s another repeater (like just another light switch) On one of the next walls, like in the hallway just before you go into the bathroom, to make sure you can get signal in and out.

More likely you’ve just run into the “off-line bug” which unfortunately affects a lot of customers with a lot of different types of devices. :disappointed_relieved: This is where a device works fine, you can control it from the app, but the system has it marked as off-line.

This is a known issue, it drives everybody crazy, there doesn’t seem to be a good fix for it right now. Long term, smartthings intends to move their “device health“ feature out of the cloud and onto the local hub, and that should help a lot. Because it looks like a lot of times this problem is just caused by cloud latency and a message taking a little too long to get there, and a device getting marked off line.

Or it could be a defective device, but I’m willing to bet it’s location rather than device. If you have another switch you can swap with that one to see if the problem goes away, that might be worth trying. But my expectations would be pretty low on that one.

1 Like

Thanks JD.
The switch is just a regular toggle switch. I also have a similar dimmer switch available (both switches have been sitting unopened/uninstalled for a year) but thought it would be a waste of a dimmer switch so went with the plain switch, model ZW4003 I think. And you are right, there’s a fan symbol on the side of the box, which I totally missed!

The hub is in the closet next to the bathroom, so the hub is only ~8ft away from the switch with one wall and NO pipes/electrical to penetrate.

The device WAS working fine (but offline/no smartthings control), but last night the device stopped physically switching on/off. I solved this by disconnecting/reconnecting the neutral wire, which (for now!) has restored both the physical function and the Smartthings control. That was my 5th ‘reinstall’… I haven’t pushed the switch back into the wall because it keeps failing. :frowning_face: which makes it easy for me to unplug/replug, but makes me unpopular with the wife.

I’m okay replacing the switch or even the fan (it’s old), as long as I’m confident I’m solving the problem and not just wasting money.

Ah, there’s the thing. We’d all like that when these things misbehave.

JD is incredibly knowledgeable on this stuff, we trust him implicitly.

Don’t, as he said, put a dimmer on a fan.

Bad switches happen fairly rarely. A mismatch between what the switch can support and what you’ve connected it with are more common.

I’ve got close to 30 smart switches installed and have had three instances I can recall of a switch not working correctly with the particular thing I wanted to control.