GE Jasco Fan Switch - Can’t Control Speed via Alexa/Google Anymore

Basically I have a few of the Fan switches that have been installed for a while. Recently, and I would say within the last week, maybe two, Alexa and Google Home can no longer control the speed. I was always able to say, set the fan to 100% for high, 50% for medium, and anything below 33% for low. That always worked. In addition there was a slider in the Google home app and the Alexa app that I could use to control the speed, basically like a dimmer.

That has changed and I do not see how to get it back. It appears the Edge driver or whatever it is has changed this. I do have a fan switch that has not been connected for a while, but is still in my device list. That one still has the dimming option in Alexa and Google, apparently because it isn’t connected so it hasn’t been updated.

Just another frustrating change here it seems.

Anyway to get the fan switch to show up on Google and/or Alexa with the option to say…set the fan to high or 50%? I can no longer adjust my bedroom fan by voice. (I know… big problem, but I have been doing it for years and is a bummer I can’t anymore)

1 Like

Look here. This driver will work with Alexa, etc.


Thanks. That worked. Super simple too.

Now if I could just figure out why one of my ge zwave light switches keeps going offline I would be good. It comes back online If I manually use it, but eventually goes back offline.


Are you using the same driver for the light switch? Is it a Z-Wave Plus device that supports S2 security? I had a lock exhibiting similar behavior when I paired it without Z-Wave security enabled.

1 Like

It is a Wave Plus device that supports S2 security. I recall that was one I had to scan to enter it…I think.

I can actually toggle it on/off in the ST app to wake it up, even though it shows offline. It just doesn’t stay online.

It still shows as placeholder. I did not update the driver like I did the fan this morning. I was going to try that and see…unless I shouldn’t.

  • manufacturer: Jasco Products
  • networkSecurityLevel:ZWAVE_S2_AUTHENTICATED

The IDE is getting to the point where it’s not of much use anymore. However, I see two things that stick out. First, it looks like it is using S2 security. Second, there are a LOT of transmit failures.

Take a look in the ST app (or the API Browser+) to see which driver you are using. If the stock, try switching to the community GE Edge driver you used for the fan. After that, use the ST CLI to do logging from the driver to see if that yields any additional info (smartthings edge:drivers:logcat --hub-address=x.x.x.x). If it’s still not working after that, I’d suggest exclude/including the device to see if that clears it up. If none of that works and the device is less than 5 years old, contact Jasco support and ask for a warranty replacement.

1 Like

Thanks. A lot has changed over the past year or two, so I am a bit behind, and it feels difficult to catch up.

IDE was the thing….these new ways are foreign to me.

Yes, the replacement of the Groovy cloud based architecture for device drivers and SmartApps is a big change and not everyone has kept up with all the ins and outs of what is changing and the resulting effects. We’re all here to help though :slight_smile:

Same issue here. I tried enrolling my hub with the custom philh30 drivers, and they seem to have enrolled properly. However, it will not show up when I try to change the drivers for any of my Jasco devices with edge drivers. Any suggestions?

Check the API Browser+ and look under Locations->Hubs->Installed Drivers and verify the driver is installed. Next, looks in Devices, click on your device and then details. Check the fingerprint for your device and verify it’s included in the fingerprints here.

It does not show up under installed drivers. However, if I go in the app and go to hub>driver, it does show “GE/Jasco Devices - philh30” under “Channels your hub is registered to”

I did confirm that one of the devices I’m trying to change does match a fingerprint in the driver.

After you enrolled in the channel, did you then select drivers to install to your hub?

It seemed to go easy for me. I installed the driver, by following the prompt. Then I went into the ST app, picked my device, hit the 3 dots, selected driver, and picked the new one.

Nope, I totally missed that step. I figured it out right before I read your reply. Thanks!

1 Like

Yes this worked great. Noticed that my goodnight routine had stopped controlling the fan. Looked at fan and it was only on and off, no speed controll. Added this driver to samsung hub, changed the driver for the fan and selected new driver. Went back to alexa and now speed controll is back were it was before. Thanks a bunch.