SmartThings Community

GE/JASCO Dimmer - Blue Light


(Daniel) #19

Drilled into the settings for one of my light switches today and saw that there is now an option for the blue light to be on when switch is on, on when switch is off, and always off. It’s even got a little blue light graphic!

Just wanted to say, it’s pretty awesome that changes can be made like this without having to update the app.


(Brady Emmett) #20

My two dimmer switches don’t seem to take the Never Lit command. If I set it to Never Lit, the blue LED still lights up when I have the lights on. Is this a known issue, or have I done something very wrong?


(Michelle) #21

@bradyemmett - Many switches don’t accept the setting for Never Lit- I have three different brands of switches, and none of mine allow “never lit” as a setting, they only allow “lit when on” or “lit when off”. Actually most of mine have the parameter set the opposite of the programming in the SmartThings device, and I have to select “lit when off” in the app on order to get my preference which is “lit when on”.

My guess is that SmartThings put the “Never Lit” option in there to allow compatibility with those brands of switches that do support it.


(Swpyatt) #22

Would it be possible to add an option to invert the switch for those of us that had to install them upside down?

Thanks,
Steve


(Brian Roskamp) #23

I realize this is an old topic, but is this option still available? I recently purchased a SmartThings hub (v2) and one of these JASCO dimmers and would like to disable the blue indicator light, but I’m not seeing it in my device settings in the SmartThings app.


(Ben W) #24

Yes.

In the Device Handler of the switch it is under the Gear Icon on top.


(Brian Roskamp) #25

I dug into this some more and found that the indicator light is included in the “Z-Wave Switch” handler, but it’s missing from the “Z-Wave Dimmer Switch Generic” handler, which is how SmartThings (correctly) detected the device. I’ve switched to using the Z-Wave Switch type for now and will tinker with merging the indicator controls with the dimmer switch controls.


(Ben W) #26

If it is the GE/Jasco Dimmer you should be using the Device Handler “Dimmer Switch”

Here is the code, but it is a default handler.


(Brian Roskamp) #27

Thanks for the help! SmartThings used “Z-Wave Dimmer Switch Generic” for the default for some reason. I was able to change it in the IDE though.


(Bob Florian) #28

We recently made a change so that only devices that actually had the indicator included controls for it because some users were confused by those controls being present for devices that don’t have the indicator. Looks like we missed a device that does have the indicator. Was this an in-wall switch or a plug-in dimmer module @mbroskamp?


Weird GE Smart Switch Issue
(Brian Roskamp) #29

This was an in-wall switch. It’s the JASCO 45712, which should be equivalent to the GE 12724.


#30

I just installed several of these dimmer switches and would like to control the LED indicator behaviour. Any idea on a time frame for this fix?


(Benji) #31

@bflorian There is still an issue for the GE 12730 fan controller where the indicator light option doesn’t work properly in that selecting ‘never lit’ is still actually lit when the switch is off.

The rest of the switches seem to work fine but the fan one has always had this issue.


(Bruce Robertson) #32

The LED on an on/off GE/Jasco switch was not working. Non-dimmer. Just found this thread, and dug into the app’s device, and it was set to be on “when off”. I toggled the setting a few times, hoping it is fixed. We will see when I get home.


(Dan) #33

I do not see any such option. Which setting are you using? Through the app or the ide? I tried both and do not see any options for controlling the indicator light.


(Ben W) #34

Its in the App. Go into the device handler of the dimmer and click the gear icon.

If it does not show up you will need to change you device handler in the IDE. There are a couple of GE/Jasco switches that defaulted to the wrong device type, one without the blue lights.


#35

I have one of this kind of dimmer that currently works (on/off/dim) but the blue light never comes on when off. In the device settings I have LED Indicator When Off but it doesn’t light up. IDE has Dimmer Switch for device type.

My mild OCD kicks in every time I walk by it or see it… would changing device type help?


(Mark Barlet) #36

I have done everything that this thread talks about. I changed the handler to “Dimmer Switch” and I get the option… the issue is the light FAILS to work with smartthings at all at that point. The handler “Dimmer Switch” just does not work… I changed it to “Z-Wave Dimmer Switch Generic” and it works again.

What am I doing wrong?

Thanks in advance for guidance.


(Logan Marshall) #37

Anyone know how to have the indicator light on if the light is on, with the zigbee model? Tapping the top 3 times and the bottom once only toggles the led to be on when light is off, which is the reverse of what I’m looking for.

Any ideas?


#38

Unfortunately as far as I’ve heard LED on when the light is off or completely off are the only options on the ZigBee versions.