GE 40A Switch unstable despite very close to hub


my GE Switch was running great for some days after installation, but then it stopped:

in graph.api.smartthings it’s listed as:
in the log I see:
[4a6f5ee0-fc27-4299-90cc-b17612671ea1]([LINK DELETED DUE TO FORUM SETUP) 9:05:13 AM: debug no encapsulation supported for command: MeterGet(scale: 2, reserved202: 0, reserved00: 0)
[4a6f5ee0-fc27-4299-90cc-b17612671ea1](LINK DELETED) 9:05:13 AM: debug no encapsulation supported for command: SwitchBinaryGet()
[4a6f5ee0-fc27-4299-90cc-b17612671ea1](LINK DELETED) 9:05:13 AM: debug no encapsulation supported for command: BasicSet(value: 255)

Distance to the Hub is 7 m. I ran ZWave Network repair several times…

That’s the device

I was going to buy one so that is not good to hear.

Looks like it’s lost the security key for encoding secure messages. Could just be a bad switch, it happens. But first try removing the switch from the network and re-adding it. That should reset the key.

I’d also report it to support, they may be able to see something from their side.

but it worked for a while!

I experienced this for multiple ZWAVE devices - like my AEON energy meter so I start suspecting the problems are coming from the smarttthings (V2) hub.
So far these were all just metering devices, so it’s no big damage when they fail for some weeks. But this switch is to control my pool pump during my absence and this is critical.

They are changing the way they handle zwave security (that’s the “encapsulation” part) in order to support the newest S2 standard. So maybe they’ve recently introduced a glitch. That’s why I would definitely contact support and let them look at it.

I personally wouldn’t put anything “critical” on SmartThings, but the company tells you that themselves:

yeah, I guess it’s only an expensive toy. But what are the alternatives? - thinking about the AEON stick with HEM on my Linux server…

The biggest issue is that they can and do make cloud changes which affect everyone without notice. There are several alternatives If you only run zwave devices. Including the zstick.

If you’re willing to go with much simpler logic, then there are a number of more reliable alternatives.

If you want to look for something totally local except for third-party integrations like echo or IFTTT, Hubitat is a very new, very small company That can run code Which is very similar to smartthings. Some of the new stuff they put out is glitchy, but you don’t have to update until you want to and you can roll back to the previous version anytime. So even if the company went out of business, your setup would continue to run since it doesn’t rely on a cloud. Quite a few people are using it in addition to smartthings to get that local operation for some specific use cases.

And for things like critical pumps, there are always manual timers. :wink:

There are lots of existing threads in the forum about reliability and hub alternatives if you’re interested in that.

1 Like

concerning pumps: I loved the idea that I could just have it run 2 hours a day while absent, have it run one day or more without stop before I return, have it connected to a motion sensor so it does never run during the minutes someone is in the pool and so on…
home automatization makes sense. But it has to be at least 98% reliable.

1 Like

is a zwave repair showing errors with this device? have you tried restarting the hub?