GE 12730 Z-Wave Fan Control Indicator Light incorrect behavior

I just tried this and it doesn’t seem to work. It did not affect the indicator light on my wall switch at all. It is always on when off no matter what I do.

This works great, thank you for publishing it.

I have the same problem as Ryan780, but with the GE 14287 Fan Control. No matter what I set it to, the indicator light is always on when the fan switch is off … I just want it off as I don’t care for the night light effect. Going to try a replacement switch just to see if the switch itself is defective. I haven’t yet tried this smart app.

This is a known issue with these switches. The LED toggle has never worked with both the regular and the plus models. Don’t replace them as it is not a defective. There is no device handler that fixes it and there is no smartapp that seems to work. Some people have claimed to have luck but majority do not have them working… Place a piece of white tape over the LED.

1 Like

On this page, under the 12730 section it basically only seems to have a parameter for inverting the switch, nothing about changing the LED setting, nor even being able to disable the LED completely using the same trick as the other switches/dimmers (3xON then 1xOFF at the physical switch).

Actually, if you have the switch on, then do the on x3 off x 1 it inverts the light so that it is on when the fan is on and off when it’s off.

1 Like

Good stuff, however, there still doesn’t seem to be a way of setting the LED to ‘never lit’ on the fan switches :frowning:

No. At least I havent found one. The switch blinks to show speed also, which you can’t turn off either.

Ugh… why do they do this?! It’s just the fan switch and it’s the same on all three generations. It doesn’t make any sense. I wonder if we can get Jasco to comment on it.

It sucks that Jasco cannot be consistent. The good news is this can be solved by a simple smart app or Webcore that inverts the indicator state based switch state events.

1 Like

I guess I could run that separate and not worry about it affecting local control since the rest of how it works won’t be affected by the WebCore automation…

I don’t think that will work either. The problem is that (for whatever reason - bug in firmware, etc) you can’t externally write to Parameter 3 in the device. I also don’t think the device uses their standard 0,1,2 value for this parameter. If you change the setting at the switch to be ON when switch is ON (what would normally be value of 1) then read it back manually, you see it stores ‘-1’.

Every attempt I’ve made to write a change to P3 locks up.

1 Like

Perhaps you have a bad device? I have three of these and use a custom SmartApp to invert indicator status at night so the one in the bedroom is always off.

The fan controller? I’ve had a handful of these that all act the same. The dimmers, I have no problem adjusting.

I would grab a copy of the stock DTH and find out how it’s setting it because it does technically “work”, just not ‘never lit’.

If someone has a resource at Jasco or finds away, I will love you forever.

I’m having the same issue with my Z-Wave plus GE fan switch. The P3 parameter is not changeable. The only way to change the setting is manually by the on, on, on, off method. Unfortunately that method does not allow the never option. Extremely annoying.

Some white nail polish activates the Never Lit option pretty well. :slight_smile:

Lol. Good suggestion. Trying first with electrical tape.

Coincidently I sent a message to Jasco support last night asking about this. Seemingly it does have a parameter 3 even though it’s not listed under the ‘advanced operation’ for the device:

Or at least I’m assuming that it has a parameter there because values 0 and 1 work but it’s just value 2 (never lit) under parameter 3 that doesn’t work.

We’ll see if Jasco responds.

When I change via the control and read back, I see a value of -1.