GE 12730 Z-Wave Fan Control Indicator Light incorrect behavior

switch

#1

I have several of the GE 12730 In-Wall Fan Control switches. All of them have the same problem: the “Indicator Light” doesn’t work right. When I set it to “Lit When Off” or “Lit When On” in the ST app, it works as expected. However; when I set it to “Never Lit” it works exactly opposite of how I would expect: it actually stays on all the time (except when it’s blinking to show the currently-set fan speed, again, as expected.)

Anyone else have this issue? Any proposed fixes that don’t involve a piece of tape over the LED? :smile:


(Scott G) #2

Try this SmartApp. The ‘Never Lit’ option doesn’t seem to be implemented properly on the hardware of this or any Zwave switches I’ve tried. This app subscribes to on/off changes of the switch and then changes the indicator option so it’s always off.


#3

I’ll give this a shot - thanks for posting.

I’ve had nothing but perfect results with my GE 12722 switches and 12724 dimmers - all of the indicator light modes work like a champ.


#4

Hrm. Seems your links aren’t coming through…


(Scott G) #5

I have older Linear dimmers and GE switches, so the new ones might work better. The Linear ones are even stranger because they seem to work in reverse. I only use this SmartApp on my fan switch, since it’s the only thing that could be on or off while we sleep.

Here you go…

https://github.com/sticks18/SmartThings-SmartApps/blob/master/Zwave_Indicator_Never_Lit_Manager.groovy


(Paul) #6

The app does not seem to do anything at all for me. Is there any sort of trick I’m trying to use this for a linear dimmer.


(Benji) #7

Exactly the same as me, 12722 works exactly as expected 12730 has the same problem behavior with regards to the indicator light setting.


(Scott G) #8

Most of my Linear dimmers reverse what the app says, so when I set the indicator to be lit ‘when on’, it will actually be on when the light is turned off. For this case the second preferences section of the SmartApp should work for those lights.

Note two things: 1) When physically using the switch, it may take some time for ST to recognize the state change and trigger this SmartApp. 2) If you’re using a custom devicetype for your switch, it may not have the necessary commands. This SmartApp was based on the generic zwave switch types that have commands indicatorWhenOn() and indicatorWhenOff().


(Paul) #9

I’m using a linear dimme as well. It is using the standard dimmer device type. It’s exactly as you described. It’s backwards. I’ve tried using the 1st and second options. Neither have any effect. Do I need to do something to get it to “sync”


(Scott G) #10

I just tested this with a Linear Dimmer in my bedroom and it was working fine using the 2nd option. When you first install the SmartApp, nothing will happen until you start turning that light on or off either from the app or physically.

If you turn the light on from the app you should see the indicator light come on for a couple seconds that go off.

Make sure you didn’t make it Mode specific. Also, are you on hub v2?


(Paul) #11

I am using v2. I did a bit of testing and here is what seems to be happening. I am using the option for reverse "“linear”. I set it to never on. And when I turn on the light it changes back to light when switch is off. I set it back to always off. Turn off ththe light and it sets back to light when off. Basically just resets the setting of the led after it turns off or on.


(Paul) #12

Maybe I should add that I’m trying to get the light to be always off. I have mostly GE switches and the color on the linear is different so I’d rather just keep it off all the time.


(Scott G) #13

The problem this SmartApp is intended to solve is that the “never on” option doesn’t work. For Linear switches the setting “lit when on” results in the indicator being on when the switch is off, so when the switch is turned ‘on’ this will change the setting to “lit when on” and when the switch is turned off it will change the setting to “lit when off”. There will be a couple of seconds where the indicator is on until it can make the change.

Test your switch and I can make the adjustments if necessary. When the switch is ‘on’ what indicator settings result in it being off? How about when the switch is ‘off’?


(Paul) #14

OK, I finally got it and understand. I have the setting set to let when off and the switch is off and the LED is off. When I turn on the switch the LED lights up for a few seconds, then then setting changes to lit when on, but the LED turns off. So as long as I ignore what the setting says, it does stay off. Which is what I wanted. Thanks again!!


(Craig) #15

The link to Github above is invalid. Does anywhere know if this is still available anywhere? Need to use on GE Smart Fan Switch…

Thanks.


(Scott G) #16

Here you go. I did some cleanup on Github and that app got lost.


(Craig) #17

Thank you @Sticks18 - works like a charm!!


(Derek Aagaard) #18

I’m new to the home automation game. I bought the GE 12730 fan control switches and I have the Samsung smartthings hub, v2.

I’m having the same indicator light issue. My light turns on when the fan is running and off when the fan is not running (which is opposite the way it should be). I can not for the life of me figure out how to fix it. I see the link for the smart app, but can’t figure out how to implement it. Any help would be appreciated. Thanks!!

Oh, and when someone says “ST” are they referring to smartthings? Or does it stand for something else.

THANKS!!


(Scott G) #19

ST is SmartThings.

The indicator light behavior can be controlled directly in the tile for the fan. Go to your devices and press on the fan. You should see a button with a little circle that says “Indicator Light” and will denote “Lit when Off”, “Lit when On”. Sometimes that text is opposite of what really happens due to how he manufacturer programmed their line.

Sounds like you want the light to be on when the fan is off, so turn the fan off and then press that tile until the light comes on. Turn the fan on and make sure the light goes off.

This SmartApp above was intended to automatically toggle that setting, so the indicator light is always off.


(Derek Aagaard) #20

Thanks a lot Scott!! I can’t believe I didn’t notice that setting before. It works great now! Thank you thank you.