Frustrated with Harmony Hub


#1

Is it just me that gets very frustrated with the Harmony Hub integration ?

I have had the hub for a while but have never used it for much. Just turning on / off the TV and turning on / off the projector. For this it seems to work, but when I try and add more activities I seem to end up with problems.

I have just added a new device for my amp / speakers and wanted to be able to turn up and down the speakers via Smartthings and Echo.

The first problem is when I send the volume up command from SmartThings the swicth stays on, so I can’t issue another volume up as the switch is already on. Then if I set the switch to off my TV or Projector switch off ! Yet they are both set to stay on when switching activities and only turn off when I press the off button. The Harmony software seems to be very awkward to use and is far from intuitive.

Can anyone tell me if what I want to do is possible and how I should do it ?
Why do other devices go off when they are set to stay on ?
Is there any other solution apart from Harmony ?


#2

When you turn off a harmony activity its like pressing the Off button on your remote, so the behavior sounds to be expected. Sounds like you may need CoRE to switch back to the actual entertainment activity so you can continue to raise the volume. In all honesty though, this isn’t practical. If you want to make the volume louder I suggest trying to send 5-10 volume steps in 1 activity so you only send the command once or twice.

Only one harmony activity can be on at a time which is why when you turn one on it stays on until the next activity turns on.

I think Anymote works directly with Alexa but I have no experience with it. I do know that you can send commands for each button on your remote.


#3

I understand that only one harmony activity can be on at a time although I don’t understand why they do this, but I thought that if I set the power options for each device within the Harmony software to stay on when switching activities and only turn off when I press the off button this would work.
I can’t understand why the devices switch off when I have set them to stay on !


(Ron Talley) #4

Sounds like you have something wrong in the activity. However, did you know that you can actually use Harmony to control Smartthings?

I find that the UI is just better. But Harmony and Echo is not an ideal marriage. I typically have to turn-off the activity first then back on with Echo because my family still uses “buttons” so the activity listed in Harmony is typically not whats really on in the real world.

Still happy for the most part because I am hardly ever without my phone and the Harmony App still works…


#5

Ok I have managed to get it working, by deleting all the activities and making sure the devices were set to stay on when changing activities. I then added the activities again within the Harmony app.

After adding the activities to SmartThings, I setup a Core Piston to turn off the switch as soon as it was turned on. This enables me to send multiple volume up or down commands.

Finally I added the up and down switches into Sharptools so i can control the volume from my phone.

Not sure if i will add them to Echo or not.