Firmware updates cause frozen devices

poll
release

(Tino Race) #1

I have full confidence that when a firmware update is release it is because it is an important update and it will make the overall experience better. But I’m not confident in how my system behaves immediately after a release. I had a perfectly working system yesterday and have had for at least a month while the US have been suffering. Then the release happened. For the last two releases, including the one one 21st April, my automation breaks because >50% of my Things stop polling with the hub. Unplugging the hub for 10 minutes has not effect on the response of devices.

I experienced the following issues (well after the 8pm release window shut)
Power outlets not responding
Motion and Door sensors frozen at open or close and not responding to movement
The solutions were to manually turn on and off the outlets a few times, remove batteries from sensors, spam the Refresh button on sensors multiple times, or simply just wait a few hours for the niggles to resolve themselves.

As far as I can tell most if not all of the issues are now resolved.

I can’t find these issues reported by US users for this release. Have any other UK users experienced this during updates? It seems to need 2 hours+ of babysitting to get things back on track.

Any ST comment would be gratefully received @slagle


(Aaron S) #2

I havent seen any reports of this in the UK yet. Have you sent a note over to support@smartthings.co.uk? They can check out your account and confirm the firmware took correctly


(Tino Race) #3

As ST choose to release firmware updates Thursday night, the first opportunity I have to properly test the system post-upgrade is Friday night after your support team have gone home for the weekend. An email has been sent nevertheless.

I have tried everything I can think of get the sensors communicating effectively with the hub: removing batteries, restarting the hub, moving the hub’s to another room, removing and re-adding a device to the hub. The sensors communicate successfully for a minute or two then get frozen.

I am so angry with ST right now. It worked and they ruined it. I have wasted the vast majority of the weekend trying to sort this mess-up. The whole firmware release process needs urgently reviewing before you force another botch job on my hub. Two release, and twice my system has completely frozen up. There needs to be a way for users to manually check the software is correctly installed and refresh the installation if necessary.


(Aaron S) #4

Sorry for the headache. We have staff on shift today. If you send me a ticket number, I can check on its status


(Tino Race) #5

Good to hear. Got a swift response awaiting an investigation on my firmware. I don’t really see deleting and re adding every device a good option when you have the number of Things I do


(Stuart Buchanan) #6

I have had the same thing happen in the past afte the last hub update, I just pulled my breakers to power off all mains devices, then reset he breaker again. Then flew around the house putting all my battery devices into inclusion mode. After this all was Woking again


(Wayne) #7

Another reason why we should be able to control the updates like for nearly every other system consumers own, windows, macs, ios, android etc…
It lets us choose a suitable time to run the update and be there to fix any issues. I had my family complaining they were walking around in darkness until I returned home late from work. Not cool.


(Tino Race) #8

Wow. I am so glad that ST Support were working Saturday so that they could copy and paste support articles from their website rather than actually fix my system.

Followed their suggest of removing every device and readding but decided just to WIPE EVERYTHING off the hub to be extra sure. Readded every device. Worked fine for a bit. Now the sensors are completely useless again. I’m opening and closing the hell out of my kitchen door and not a single acceleration or open/close is being picked up.

Since I’ve now wasted 3 days following extremely poor generic support advice, how out ST support look into Thursday’s firmware screw up.