Fibaro Smoke Sensor FGSD-002 EU - Not reporting temperature

It is interesting that one of the most popular smoke detectors does not work (temp) with SmartThings even if it is on the supported devices list. I have five of those and is experiencing the same problem. SmartThings firmware is 17.13
Waiting for a solution that is working.

Moving from Domoticz because i wanted something that works out of the box - so far it is not going well.

I agree, they clearly say it works with ST then support tells you it doesn’t after you’ve paid out for them, that’s not on guys. Maybe everyone who is experiencing this issue should raise a support ticket then they might give it more priority to get it fixed.

Yeah same problem here - bought it as i didnt need the carbon monoxide checker which comes with the nest, and this was supported. This should be fixed as its fairly crucial to ensuring the safety of ones family!

Wow, was just about to buy these - I think it best if I put that one on hold.

I can’t understand how they claim they don’t support these anymore:

Well dang it if isn’t working now. I had almost given up. If it stays working I will get some more. They are a nice piece of kit.

I can confirm mine is now reporting temperature sensor - will keep an eye out and post back with testing - Last issue besides the temp reporting was the turning the alert off one you have tested - anyone else have this issue - ill test and report back

Great to see this finally working!
Thanks for posting it in this thread and reminding me to check the reporting interval, had set it to 5 mins when testing this bug and dont want the battery to go dead in a few days :slight_smile:

Hi, this is really not working yet. I tried everything and none of my six Fibaro Smoke alarms are not reporting anything automatically to hub.
First of all it is recognized as Flood sensor at the beginning. Then I change device from IDE to Fibaro Smoke Alarm. When trying to adjust settings it seems like everything goes like planned but instead it’s not working at all. Information of temperature and battery is only updated to hub when pressing button one time in smoke alarm.

Log says:
[2018-08-27 5:42:08.626 ip. EEST
*hetki sitten-> means just a moment ago.

Notice that name in log file is “flood sensor” like ST hub thinks it is. I didn’t change the name but device that I use “Fibaro smoke alarm”.
Any ideas. I’m getting mad…

I have 2 of these working as expected. When I originally installed them I had to add a DTH. A month of so after, the ST team updated the embedded driver so I deleted mine and switches to that. I have been using it for over a year now with no issues. It’s the “Fibaro Smoke Sensor”.

Did the smoke detector include in secure mode? You should see something like “zw:Ss type:0701 mfr:010F prod:0C02 model:1002 ver:3.03 zwv:4.05 lib:03 cc:5E,86,72,59,73,80,22,31,56,98,7A sec:20,5A,85,84,71,70,8E,9C role:06 ff:8C01 ui:8C01” as the raw description on the device page of the IDE.

Now I removed all six sensors. Took one and tried to pair it. This time hub found Z wave door/Window sensor… (?) I checked secure mode thing you asked and yep there’s long pattern of stuff. Didn’t past it all cause don’t know if it’s something that shouldn’t be shared public, but beginning is like this:

zw:Ss type:0701 mfr:010F prod:0C02 model:1003 ver:3.03 zwv:4.24 lib:03

EDIT:

I tried to change correct device handler: Fibaro Smoke Sensor
Result of it is:

Aaarghtt… …"#¤%&¤"/("#(**¤%)(%()#)=… u know…

Tried again and behaviour was “normal”.

If looking events it show very good when it’s flood sensor…

There has to be something wrong between device handler and these sensors. Are my sensors somehow newer version or something and that could be the reason for not showing as smoke sensor.

The zw:Ss is secure mode, so that’s OK. You do need to use the smoke sensor DTH. Just make sure you don’t have any custom DTH for the smoke detect in your IDE. Then go into the device on your phone and set all the settings. I have mine as Medium, disabled, disabled, disabled, 15 minutes, 10, 55, 5 minutes, 30 minutes. Save these and you should see two lines appear in the log. You then need to get the config updated on the device. To do this just hit the button on the front once. You should then see a bunch of stuff appear in the log, including several lines that have “Sending secured command” in them. After this it should update OK. As you see above, I have my temp report every 15 mins as this has an impact on battery life. You may want to reduce this initially .

At night sensor was able To do 2 successful reports with ST. At 3am and 4.17am…nothing To do with 5min reports settings I configured.
I tried now your settings and event log says again Entity_update DeviceUpdated -> false.
In IDE it shows that there id right settings but for some reason configuration is not correctly done.
So devices seems To send information To hub but not how settings are supposed To be. I do not undestand what is the temperature report interval if traffic was 23pm then 3am and then 4.17am. Time is now 7.15am and nothing has been automatically send From sensor To hub.

Can you post a section of the live log for when you save the settings the app and then press the button on the smoke sensor?

I got them working.
Default Smartthings Fibaro Smoke Sensor device handler in IDE is not correct and should not be used with FGSD-002 EU sensors.

Found this link:
https://manuals.fibaro.com/knowledge-base-browse/st-handlers/

There was link to official Github:

Which includes “Fibaro Smoke Sensor” (updated 6months ago)
Went and checked device handlers code and it was quite easy to notice that it’s different than the default “Fibaro Smoke Sensor” in IDE.

Copied new code and created new device handler. Then one more time full reset all sensors by pressing sensors middle button 3 seconds, when yellow light -> pushed shortly again. Red flash and sensor is reset.
Then normal way added new device from mobile phone and pressed sensors middle button three times to achieve pairing mode.
Shortly sensor was found and it was recognized as “Fibaro Smoke Sensor ZW5”. Now this is different information than earlier when sensor was just found to be as "Fibaro Flood Sensor(?).

Gave device a suitable name and then saved it. Went to device information from mobile app and pressed sensors middle button one time. Sync started and soon temperature and battery level was shown.
It’s important to do that button press before changing settings. I you do not press button one time before configuring settings sync will never success.

So finally I went and configured sensor settings and pressed save. After that middle button has to be pressed once again so that new configuration is synced to sensor.

Made a ticket to ST and just sent them email if they should update default device handler for Fibaro Smoke Sensor. Thanks Simon for you help too!!

Glad you got it working. This is interesting though as mine are working with the standard DTH. When I originally installed them I was using another DTH and I recall issues getting the temp working.

I recall seeing the standard one had been fixed so I switched to that. Maybe the fact I had installed under another DTH is what allowed the standardise to work. Who knows.

I use this DTH for the sensor and it appears to be working well. It allows some other settings compared to the one you linked below. Have been using it for about 6 months.

Tested that too and didn’t work. There might be some issues between the sensor models. I have 0003 and your DTH is marked for 0002.
I think my handler is missing led settings which can be adjusted in Fibaro Smoke Sensor DH.