Fibaro Smart Implant

Just to say, tried, tested and works great.

Now to figure out why I need occasional, random power cycles.

Thanks again. =)

-=edit=-

Seems that the temp probes “randomly failing to send updates” (on both the FUBS and the FSI) is a problem that’s been reported elsewhere on the fibaro support forums. The only ‘solution’ was to power cycle.

Maybe the product just isn’t that great…?

Thanks so much for the added functionality. I’ve incorporated the tests into my system.

Basically, every time one of the sensors attached to a fibaro registers a change in temperature, it sends a toggle command to a virtual switch (eg. “top floor test”). Each time a change to that switch is detected, it waits for x amount of minutes (currently set at 15) and then flicks another virtual switch (eg. “top floor fault”) ON. Obviously, this switch will only be permitted to switch on if there are no temp changes during those 15 mins.

The fault switch can be used to disable heating to that floor etc. But for now, my ‘solution’ to this random disconnects is to use a smart plug to power cycle the FSI/FUBS). As soon as a temp change is detected again (i.e. following the inevitable power cycle), the fault switch is flicked back OFF and everything runs as normal.

image

Super impressed by your work!

I have a water tank with an analogue gauge outputting the water level in the tank as an output between 0v-10v (0% - 100% full).

How would I go about connecting this to read out this as a percentage in ST?

Hi guys,

I’m have a few issues with the Smart Implants, randomly dropping offline & reporting an incorrect input state. I also have an issue currently whereby Switch1 is unavailable but the main device and button1 are both available. I’ve tried power cycling, changing the DTH to tweaker and back, refreshing, restarting hub, Z-wave repair, etc…no joy. Any ideas ?

Cheers

Hi. Not sure if this is the kind of response anyone is looking for, so bear this in mind.

Some people seem to have had some success with these and the UBS. Some people claiming they’ve ran them for years, no issues.

Honest opinion - I think they’re crap. Really, really poor. If I did the whole thing again I’d have a crack with the arduino instead for temp measurements using DS18b20’s as I’ve found ALL of my fibaro’s (3xUBS & 1 x SI) to randomly fail to report temps after a random period of time. Sometimes after a few hours, sometimes after nearly a week. Maybe once every other day.

My solution was to ask the guys who wrote the DTH’s for both devices to add a tweak which can be used to highlight when a fault occurs, at which point the device can have the power disconnected, and rebooted.

This takes some webcore logic and a smart plug. More details avail if needed.

I find this a difficult answer, because I can’t recommend these at all BUT because I’ve already bought them (and have managed to use them as described), they finally fulfill my needs.

Others may not agree. I think the devices are utterly unreliable. I can’t see how I can have a ‘dud’, when I’ve spent so much time and effort with 4 of them.

The arduino looks amazing, but I haven’t personally tried it. I’ll eventually try it out and hope that it would fill the gap without this ‘clever trickery’ I’ve had to employ.

Checking the logs, 17 hours ago a power cycle was needed.

Working back, ditto for 2 days ago:

And 3 days back, it happened 4 times. Here’s two of them.


Note that I have a single smartplug with a 4 way extension lead containing the 4 x 12v/2A PSUs for each of the fibaros. When a fault is detected on on one of the fib’s, the powercycle kicks in. So I’m not saying that one fails as often as illustrated above, but ONE of them does.

From this thread:

I have a FGBS-001 that I have been using (or attempting to…) for 1.5 years.

The unit has 3 temp probes connected, and source is a 200W switch mode power supply (which also supplies the RGBW dimmer with 40W of lights and capacity to add more RGBW’s…)

I am seeing the temperature flat-line from the sensor after a few hours, or days, or weeks, depending on luck. The only way to reset the temp feed is to power cycle the UBS. I can still communicate with the UBS via the HC2, changing config and the like, so it seems to be the digital controller in the UBS its freaking out seperate to the zwave controller. (this is an assumption, and I have no idea how the internals of the UBS works…)

I have gone from a connection screw block from device to probes, to soldered connections (thinking dirty data from the connection block) and saw no improvement. I have done the factory resets etc…

Anyone else had these issues? Any resolutions? Any ideas?

I have reached out to Fibaro email support and they proved to be consistent with my previous experience of their ability to support their products…

Posted May 29, 2017

Second this…

I’m running a VeraEdge and have several universal sensors that I try to use.

I have the exact same experience as you, or actually worse…

One or more temp sensors will stop working after a random time. The binary sensor itself seems to work fine, but not even powercycle will recover the lost temp sensor.

Posted June 9, 2017

A short update here:

So I replaced the power supply on may 30th, and since then it has really been running fairly well.

I did not reconfigure them at that point, so one sensor was already dead, but the remaining six has worked flawlessly for roughly one and a half week.

(average mtbf before this was half a week or so I’d estimate…)

Yesterday however I had an electrician in, and he had to take down the main power for a minute or so.

This then killed three sensors… two on one UBS, and one on the other…

So all in all I’d say that I find it beyond all doubt that it is related to the power, but ofc it’s incredibly annoying that even a decent power supply is unable to take the UBS’s through a powerloss without errors…

It does also seem like the behavior varies from controller to controller, like I said initially I have to reconfigure the UBS’s, basically an exclude-include process, to get the dead sensors back up.

According to @kelvincoffey, with the HC2, you “only” need to powercycle them…?

Posted December 13, 2018

I have the same issue with 3 different universal sensors. The time to failure varies between ~1 week and 15 months. Sometimes only one temp sensor freezes, sometimes all at once. The only way to get them back is to exclude and include them in my z-wave network (with all the related hassle regarding IDs etc.).

I already started replacing some of those sensors with more reliable ones from another company, at least in some critical applications.

My guess for the reason: Electromagnetic pulses, either over the power supply or “over the air” through the sensor wires.

Posted April 24

Guys,

I have been having the same problem for a couple of years already. I tried every advice I could find online (shorter wires, better power supply, I even go more UBS devices to have my temperature sensors connected as single probe per device)

Nothing works, every now and then I have a problem with “hanging” temperature on one of the sensors.

My configuration is:

  • UBS with a single temp probe for a water container
  • UBS with a single temp probe for a heating boiler
  • 4 x UBS with two temp probes each for room temperatures
  • all controlled by VeraLite controller

Every now and then a probe fails and stops reporting a temperature - could be even just a single one from the pair of two connected to the same UBS.

Your call.

Since I have 2 separate setups working fine for over a year and over 2 years, I can only assume it’s something with the specific setup or specific modules. In both case I have the PSU very close to the module. One is a plug-in transformer and the other is an in line buck module. The length of the leads to my sensors is also 2M-3M max.

One thing you could try is to reduce the frequency of the reports. I have heard that Z-wave is not optimised for chatty devices so maybe this is causing an issue. FWIW my settings are parameter 10: 0, parameter 11: 255, parameter 13: 8. Both my modules have 3 probes each.

Another thing is to look at your Z-wave mesh and the router from the modules to the hub. Maybe this is an issue. Do Amy of the UBS modules router through another UBS?

For me since replacing the temperature probes with these https://www.amazon.co.uk/UTRONIX-LIMITED-DS18B20-waterproof-probes/dp/B07QGLSRYK my set up has been rock solid.

You might want to buy a pack of probes to see if it makes a difference?

Thanks, but my gut it telling me to not to spend any more cash on these.

I suspect that if the reporting frequency is kept long and the lengths are kept short, then there’s a good chance they won’t suffer any problems.

I am curious as to how you produced your graphs though ? = )

The graphs: do a search for InfluxDB + grafana. I have SmartThings feeding a server on a RaspberryPi.

1 Like

I have bought a couple of Smart Implants. I want to be able to use my ST Classic app on the phone to activate OutPut 1 and/or Output 2. (I activates with click or double click on the unit, but I want the Implant to be hided, and with no switches, just the Classic App.
Cant find any way to do that with the Device Handlers I have found so far.
Any suggestions here?

Did you install all of the device handlers? This is what you see in the classic app for the FSI and you switch on the switches and map INP1->OUT1:

Yes I did install the Device handlers and get the optionIcons shown in your picture.
But nothing happens when I push Switch 1 or Switch 2.
Is there any parameters I have to set?
I want it normally open, and a push button.

Med vennlig hilsen
Svein Arild Johnsgård

I would play about with the options under parameter 60 - the last parameter under set up.

Did anyone get to the bottom of using an alarm input directly into the sensor ? My alarm outputs are:

Outputs
O/P 1 - 4 Open collector transistor,
+12VDC when inactive, 0V
when active. 500mA max.

Or, do I need a relay module in between ?

Thanks,
Roy.

@ovidiu.pruteanu I’ve added all 6 handlers into my web GUI for smartthings and pushed the button to add it to my app ( the new SMartThings app ), but all I get is the temperature and nothing else, no buttons.

Any advice on what I am doing ?