SmartThings Community

Fibaro fgr-223 DH needed!

Hello @philh30 and thanks for your great work! Just a question… today my roller shutter was programmed to open at sunrise, but the power was off before it. When I turn it on, the roller shutter stood closed until I gave a manual order. Shouldn’t it assume than since that hour has passed and it was still closed, to open by itself once it has power? sorry for my poor english.

In the IDE, on the page for this device, what does it say under Current States?

Are you trying to use this DH as a virtual switch or with a real roller shutter? The DH relies on zwave responses from a physical device to update its state, so it won’t function well as a virtual device.

The calibration is completely done within the Fibaro. I’m pretty sure it’s all based on how long it takes for the motor to fully open or close, so it won’t be exact, and 50% may be a different level depending on whether you start at the top, bottom or somewhere in between. The offset setting works the same as it does in the v2 DH, so you can certainly play with that to see if you can get it set how you want.

Hi @philh30
No im using it physical device not virtual.
It looks like this:


When did you download the DH? I added contact sensor and switch as capabilities in early March, and neither is showing up in the Current States of your device. Could you try doing a fresh copy/paste from the GitHub repo?

That’s typical behavior for any device with SmartThings. ST only takes a scheduled action at the time it’s triggered. It doesn’t do any follow up to make sure it happened, doesn’t try again, doesn’t check later if the device state matches the schedule. Any smart device connected to ST needs constant power to stay on schedule, and if the device or schedule need cloud processing then you also need a constant internet connection. If power or internet are down when a scheduled task is triggered, the device just misses it and will be out of sync with intended behavior until the next schedule.

There may be smartapps or ways to schedule in WebCore that will provide a failsafe if the schedule isn’t run on time. A simple example might be to schedule the shade to open at sunrise, as well as at a few intervals after sunrise to ensure that it opens at some point during the morning. You’ll need to consider the unintended consequences though. Like, if you manually close the blinds one morning, will your schedule pop them back open an hour later?

If you’re wanting to explore options, I’d suggest you open up a new topic that’s more generally about monitoring whether a scheduled action failed to run. You’ll probably get more people with experience on the subject chiming in if the topic isn’t tied to this particular device.

Just updated and its working fine! Many thanks!!
If you insert a version or a date in the DH so we can compare version better it would be perfect.

Good idea. Will do next time there’s a change.

After the firmware update, I can not add new device. Firmware hub now at 25.27.
The device I instal prior to update works grate .
After adding in DH , the ST app is not detecting the device, is just spinning .
Cannot pas this step.

There’s a workaround for inclusion above around post 50. ST support is aware of the issue and will be pushing out a fix, though no estimate of when they’ll do that:

I recently bought some motorised curtains that feature a light touch feature I.e when you manually move the curtains with your hand, the motor is meant to kick in and finish off closing them but it’s not working and I think it maybe to do with the fibaro. Do I need to change parameter 151 to roller blind with built in driver?

Hello everyone,
I was very glad to see this thread as I am having the same issue:
I have a Smartthings hub, and recently bought a Roller Shutter 3. After connecting the hardware, only one button works for opening and closing the roller (as was mentioned in previous posts).
I follow @philh30 first post for the installation of the device, but I got stuck on the 8th point (device is not pairing or found, hub continuously blinks green even when put very close to the device).

Did anyone had the same problem adding the device or know what I might have done wrong?

There’s a problem with inclusion that was introduced with the latest ST firmware update. Hopefully they’ll push a fix out soon, but for now follow the workaround in this post

1 Like

Thank you for your quick response.

Everything is working! I did the workaround, then there was the problem with the switch but you also answered that question in a previous post.
Thank you very much!

I am rewriting the post 50 by @hgozilla
ST v3 Firmware 25.27 Classic App
The following steps work for me:
1. Exclude it following this steps:
11. Classic App , click 3 lines, then Hub, then Z-wave utilities, then General Device Exclusion, then Remove
12. Power ON Fibaro, wait for the green light and then press 3 quick times on the button
13. Wait for Fibaro to give you a RED light
14. Your App will say your device was excluded
15. Turn OFF power
2. Then include it again:
21. Power ON Fibaro, press quickly 3 times on the button
22. Wait for the green light to stop (it means it was add it to the Hub)
23. Log into the IDE and check your Hub events
24. Look for the event that will look like (zw device: 03, command: …)
25. Write down the number (03) in this case, this is the ID
26. Create a new device manually in the IDE, using the ID and select your Fibaro DH
3. Look in the App, you should have the new device installed

HEllo, I do it but dosnt pair, and dosnt show on event log any zwave … I linked a week ago but now its impossible, some idea?


this are the steps that I took and I confirm that it’s working.

Hello, thanks, I were looking the worng screen of logs…

Just a question, in fgr-222 there was the up icon and the down icon, now i can’t find it after inserting dh in ide… i’ve changed the parameter 20 but seems sync for a while.
Every button that i press on real button nothing happens on DH on smartthings old app.
I’ve inserted the fgr-223 reading the network ID on hub event’s list. After plugged it out/it the app say that the device is partially opened.
At the moment i’m on a test bench without rollers, i have to install it before?

It’s definitely not going to work properly until you’re able to run the calibration sequence. The 255 in the bottom right of the main tile indicates that the Fibaro isn’t able to tell whether the shade is open/closed since it hasn’t run calibration.

Hi there,

My Fibaro v3 stop refreshing the info, it works well, even with Webcore but never refresh the data, is says is always open and consuming energy. Solutions? Thanks