Fibaro fgr-223 DH needed!

Do you also have some roller shutters 3 which do work from before (the firmware update to the smartthings hub)?

No, this is my first one, as a test.

Well then, it’s a good chance that the firmware update messed up the device handler, if you are doing the pairing process correctly

I really think I am doing it correctly. The Fibaro’s LED turns solid green as if the pairing was succesful. And then nothing, but I can exclude it easily after trying to include it. And I just saw this, so I hope it is firmware update related and that it will be fixed soon.

https://status.smartthings.com/

Yes, that is my case as well, the Fibaro’s LED say the pairing is successful, however the device does not appear in the smartthings search. Okay then, we will wait for a few days…I might get a fibaro hub lite in the meantime though xD

Ok, I succeeded in including my Fibaro Roller 3. Here are the steps I performed :

  • Exclude it before anything
  • Then try including it again like the usual
  • Just after the Fibaro Roller Shutter 3 shows a green light meaning it is sucessfully paired, log into the IDE and check your Hub events
  • Look for the event that will look like "zw device: 15, command: 3202, payload: 21 32… "
  • You need to write down the number or combination of letters/numbers just after the "zw device: ". In my example, it is simply “15”.
  • Create a new device manually in the IDE, using the ID you found out at the previous step (again, for me it was “15”). Put it in “Device Network Id”.

And then in the app, add th manually created device, it should work with your Fibaro module !

3 Likes

Brilliant, thank you so much! I did exactly as you said and I managed to pair the shutters with my hub :smiley:

How can I disable the automatic open\close on first clicks.

Tried this and could not see a clear connection that you described looking for zw… i have the same symptoms that the fibaro green light confirms its added but does not show in ide or either apps. Though i could exclude device sucessfully multiple times. What is it that i am missing. Thanks

Just to clarify, after the roller shutter confirms the connection with the green light, you look up it’s number in ide under ‘my hubs’ and then click ‘list events’ (down on the right), there cloud be plenty of other devices above it in spite of you pairing it just now, for instance I had a few Belkin wemo switches showing above the roller shutter even though I haven’t touched any of them. You are looking for a 2 digit number after zw device, eg. ‘zw device: 18’

had same problems. thanx guys!

Hey @philh30 thanks for the update on the v3!
Can you fix somehow the icon of the RS v3 in the Actiontiles?
The v2 were fine with a simple button but the v3, works, but appear a “?” instead.
https://ibb.co/Rh5hdMk
Thanks

Hello, the control is mad, I have the motor and fibaro on ground.to calibrate must I install the motor on the window?


Thanks.

@akitamostodos I believe it needs to be installed in the shade for calibration (hopefully someone who has one can chime in if I’m wrong). When calibrating, the Fibaro is trying to find the top and bottom of the shade’s range, then using that to calculate how far open/closed the shade is in the future. If your motor is able to run continuously then it can’t find the end.

@mrpardal In ActionTiles, you can edit the tile’s appearance to be whatever you want it to show as when it’s open/closed. If you search for “blind” there are a couple of good icon options available.

@philh30 thanks for your answer. I work very well with actiontiles and i know the possibilities of appearance but the v3 only appear “?”. The v2 worked just fine…i suppose is the DH, i dont know.

Another question about the offset of the blinds, how can i manual calibrate them to the 50% match the real 50% open shade?

Thanks

EDIT: The ActionTiles support:
“Please check with the author of the Device Type Handler or SmartApp that is associated with the Virtual Switch. Perhaps a value hasn’t been initialized?”

From memory that roller shutter only has 2 wires plus Earth (the Fibaro requires 3 wires plus Earth), it comes with an RF remote, your best bet is a Broadlink Pro i think. Can’t see clearly your wiring on the Fibaro.

Hello @philh30 and thanks for your great work! Just a question… today my roller shutter was programmed to open at sunrise, but the power was off before it. When I turn it on, the roller shutter stood closed until I gave a manual order. Shouldn’t it assume than since that hour has passed and it was still closed, to open by itself once it has power? sorry for my poor english.

In the IDE, on the page for this device, what does it say under Current States?

Are you trying to use this DH as a virtual switch or with a real roller shutter? The DH relies on zwave responses from a physical device to update its state, so it won’t function well as a virtual device.

The calibration is completely done within the Fibaro. I’m pretty sure it’s all based on how long it takes for the motor to fully open or close, so it won’t be exact, and 50% may be a different level depending on whether you start at the top, bottom or somewhere in between. The offset setting works the same as it does in the v2 DH, so you can certainly play with that to see if you can get it set how you want.

Hi @philh30
No im using it physical device not virtual.
It looks like this:
https://ibb.co/tq59ZLm

Thanks

When did you download the DH? I added contact sensor and switch as capabilities in early March, and neither is showing up in the Current States of your device. Could you try doing a fresh copy/paste from the GitHub repo?