Fibaro Dimmer 2 - pairs but no function

Very new to the ST but have big plans once I get my head around the possibilities. So first device is a Fibaro Dimmer 2 which I have wired up according to the instructions (currently just using a toggle switch but will change this at some point). I put the device into pairing mode and ST finds it no problem. If I try and turn the light on or off from the ST app, it just says ‘turning off’ and nothing happens. Any suggestions? I’ve tried resetting the module / removing and re-adding it / tried it without the toggle switch connected - still the same result.


I’ve got a few of these dimmers working fine, using @rmbhatia’s device handler:

I read on another thread (below) that the standard device type isn’t working for some, so maybe try the one above. Don’t forget to go into the device handler and edit the parameters. Sorry - not sure your level of knowledge on the IDE so that may make no sense whatsoever!

1 Like

Thanks Aubers, I’ll try those useful links and see how that goes! Quite a steep initial learning curve but I’m sure it’ll start to make more sense…

That worked a treat, thanks very much!

Great, glad to hear it. :thumbsup:

One thing, dimmer function within the app still doesn’t seem to do anything until set to 0%

Any ideas what I need to do to enable dimming control? Thanks!

At around line 230 of the device handler are where you can change parameters. If you check the manual of the dimmer there’s a section that tells you what all the parameters do. IIRC you’ve got toggle switches, so you’ll need to check that the parameters for switch type, and dimmer function are set to the right number. parameters 20 & 32 i think from a quick glance.
If you have different types of switch in your house then you’ll need different versions of the handler for each. There’s probably a better way, but that’s how I’ve got it.

1 Like

Brilliant thanks! Love this forum!

You’re correct … I hadn’t seen this response but was able to fix mine by setting both 26 & 32 to “0”.
Prior to that it only went completely on/off and the scale did not work.

Some of the issue with the Fibaro is the many different ways it can be connected to the load and controlled(via switch or switches).

I think this is why some have issues and some do not.
My configuration is a wall outlet controlled by a single wall switch.
Very simple with a 2-wire setup.

Thanks again to all involved.