Fibaro Dimmer 2 - have to press switch twice to turn on/off


#1

Hi, just got my Fibaro dimmer 2 installed, in the ceiling rose.
Working ok, apart from 1 thing - flicking the switch (bog standard UK switch) doesn’t work as normal. I have to flick it twice, and it turns on, twice again, and it turns of.

Is there a way to set it to operate as per a “normal” UK light switch?

I tried changing the device parameters, as there is a setting for momentary/toggle. Tried both, but didn’t help.

Thanks


#2

Also, I’ve noticed if I use the wall switch to turn the light off, Smartthings App still has it showing as “ON”.
If I turn it on/off with the App, the light turns off, but the app shows it at “Turningoff”

And looks like the LED bulbs I have flicker when it’s OFF, but the normal energy saver ones I have don’t. I think that might be solved with a Fibaro bypass module, but that’s extra expense and I’m not sure there’s enough space to fit it.

Think might have to uninstall if I can’t solve these few problems, but apart from those is working just fine. Would be great to get it sorted though.


#3

Are you using the custom device handler? It sounds like your device is still in Momentary mode (i.e. turning the switch on/off quickly is the same as Momentary push). Turning parameter #20 to 1 definitely works for a standard on/off toggle light switch as I’ve got 4/5 Fibaro 212s configured this way.


(Robin) #4

Use the advanced handler by @zcapr17 and, as noted above, change parameter 20 to 1.

You’ll find it works much better with a momentary switch though, gives you dimming control at the switch.


(Robin) #5

#6

thank you both.

Yep, im already using that device handler.
I edited the parameters via the Samsung website, and changed #20 to 1, but it didn’t seem do change anything. Maybe it didn’t sync the changes somehow… I’ll try again :slight_smile:

I did try changing the parms through the android app, but it forces you to set ALL the parms to a value before you can save, even if you just want to change one. even when I set them all to default values, I still couldn’t get it to save.

I’ve got no dimming at the moment - changing the level via the app does nothing. perhaps it is the energy saving bulbs that’s causing that not to work.

EDIT: Letting me save via app now :slight_smile:


#7

Ok, excellent, switch working like a normal switch, now that I’ve saved the settings via the app :slight_smile:
This also appears to have fix reflecting the status of the light in the app, when using the switch.

So, basically, it’s working perfectly with the current bulbs.

Could anyone say what I’d need to do to get the LED bulbs working without flicker? Will this definitely require a Fibaro bypass module?


(Robin) #8

If you have the Dimmer 2 in the ceiling, do you could hook it to the neutral.

If that doesent loose the flicker then yes, you need a bypass module.


#9

yeah, it’s all wired into the neutral, as per a ceiling rose wiring diagram you supplied me a long time ago.

I’ll grab a bypass module whilst I’m ordering another dimmer module.

Do you have any cheaper recommendations for simple on/off modules going into the ceiling?


#10

that’s the diagram I used (only difference is I didn’t have the “loop to next light” wires to worry about.


(Robin) #11

Can’t remember exact numbers but I think you need over 50W load to use LED’s without a bypass.

Flickering won’t be related to your wiring.

For uk we have quibino as an alternative option but I know nothing about them and highly doubt the handler will be any where near as advanced.


#12

Thanks Robin - you’re information and advice is VERY much appreciated!! :slight_smile: