FAQ: why would I need another beaming repeater if my zwave lock is already close to my hub?

Almost all Zwave mains powered devices act as zwave repeaters, so for the U.K., you just get Devices on the U.K. zwave frequency. These are typically inwall micros like Aeotec or Fibaro or plug in pocket sockets.

If a device supports beaming, it will be noted on the official “conformance statement” on the Zwave Alliance site.


For example, here is the one for the Aeotec pocketsocket

And here is the Fibaro dimmer micro

So you will have lots of choices. :sunglasses:

1 Like

@JDRoberts I talked to Aeotec at CEDIA this year and asked them why they still make a repeater. They said their repeater is actually an amplifier and repeats further than other mains powered devices. Thoughts on that?

They can only amplify up to the maximum transmission power allowed by local laws. And most, although not all, zwave plus devices already do that.

They make it because it sells. :wink:


Kinda what I figured…

1 Like

Each of my two Schlage locks have several z-wave light switches (not z-wave plus) near them that are clustered within inches of each other or sharing the same gang box. I Recently replaced one of the switches near my front door lock with a z-wave plus switch (GE/Jasco brand) and I assume this will beam, etc. I’ve done many a z-wave repairs since but I still get missed events with this lock. Is it possible the lock communication is routing through one or more of the non-plus switches that are just as close to the lock and practically in the same location as the plus switch? If so, is there any way to ‘force’ the routing through the plus switch?

It’s possible but the only way to tell is to add a secondary controller stick which can read the routing tables. The tables are updated automatically. The best way to figure it out would be to start removing devices and do a Z-Wave repair to update the tables and see which one was causing the issue. It also helps to reboot the hub and internet router sometimes.

1 Like

Sorry to reply to this old thread, but it’s relevant I guess so I’d rather not clutter the forum with another similar post.

When I first installed it I read this thread, and even looked up my GE switch that was next to it to see if it supports beaming.

Fast forward two months and I’m suffering from bad battery life so I look again at my devices.

The switch is a GE 12722 (Non-Plus, but does support beaming). Would I be better served to replace it with a Zwave Plus 14291?

I think that’s going to be the case, but want to verify before throwing more money down the hole. :slight_smile:

You’ll get better range from a Z wave plus device, so it’s almost always a good idea to upgrade if you can afford it. :sunglasses:


I can. I just have a bad habit of throwing money at a problem. Lol

I do see RBoy says to avoid the older ge switches too.

1 Like

There are lots of good reasons to upgrade to Z-Wave plus from better coverage, to improved communications for certain types of transactions like pairing and broadcasts etc. Plus as you pointed out some of the older GE switches (non plus) start giving trouble and can impact the mesh response times. It may not solve your battery issues, a repeater gives a small boost to the long term battery life in our tests here. If you’re seeing a big drain (like in days/weeks) then it may be related to the a bad module/hardware. But never hurts to get the plus repeater as it’ll only do good things for your mesh.

1 Like

Thanks. I’m gonna replace it tomorrow.

Fwiw, a good set of batteries nets me about a month with 2-4 cycles a day. No binding of the mechanism. Schalge tech support told me to make sure I had a beaming repeater, so I revisited the discussion. :smiley:

1 Like

:grin: I have a feeling they’ve been reading this topic


Hey guys, I’ve been scouring these forums for a solution and haven’t quite figured things out. I bought a schlage camelot door lock about 3 years ago and have always had trouble with unresponsiveness to a point I gave up…until recently.

I bought the aeotec range extender 7 and it doesn’t seem to have helped. I’ve tried resetting my lock, have unpaired and repaired several times, repaired my Z-wave networks at least 10 times and gave it a full 48 hours. Not sure if this is accurate but the routing on IDE has always reported that my lock is routing through my upstairs thermostat. The lock never wants to route through my extender which is about 6 feet away that I was assume does a better job repeating than the thermostat which is closer to 25-30 feet away.

When I remove the lock and bring it right next to the hub, it updates beautiful but can never get it working well when I put it into position. Any suggestions would be helpful and if I get this working, would be forever in your debt.

UPDATE: Now there is a way to tell if it’s routing through a repeater. See my post above for details.

If you think the thermostat is causing an issue (it’s been known to happen depending on the model and how it was paired with ST, usually it’s best to keep a C-Wire connected to the thermostat and then pair it and continue to run it using a C-Wire). One way to make it change it’s routing, turn off your thermostat or better yet, exclude it. Then pair your lock with the hub, check the routing tables and the it’s going the way you like it, then pair your thermostat. If you don’t want your thermostat to act as a repeater, make sure the C-Wire is disconnected while pairing it.


I have a Yale Conexis L1 Smart Door and doesnt matter what I do my front door will not use a repeater. I have a aeotec range extender 6 next to the lock (like under 3 feet)

Is Supports Z-Wave AES-128 Security S0 important in this case?

Keep in mind that changes to routes after a repair can take hours/days to shows up if your hub firmware is using 0.30 or earlier.
Starting hub firmware 0.31.x, which should be out in the next few weeks, that time should be reduced to a minute or so for the changes to show up in the IDE.


If my lock (Kwikset 910) does not show a entry for Route in the IDE, does that mean it is connected directly to the hub? My lock seems to work fine, so this is more curiosity than anything else.

I’ll note I have a Monoprice 27481 midway between the lock ad the hub, as well as a few older-gen Z-wave wall switches.

Hi folks, I’m struggling with my z-wave network a bit. As documented pretty much everywhere, you require beaming repeaters on your network for it to function properly. I have two zooz light switches that have the most up-to-date device handlers published to them. I also have a Yale lock right next to one of the switches (all z-wave plus). I’ve reset and added the switches and the locked multiple times, repaired the z-wave network countless times, and they all continue to route straight back to the hub, based on IDE. There are no hops in between. I’m running the most current hub firmware. I’ve tried to do it one at a time, for example: excluded all the devices, ran the repair, added a device at a time, with a repair in-between, and still routes are directly with the hub. At one point the lock routed to one of the switches, but when I added another device (dome water valve), and did a repair, the lock re-routed back to the hub.

Help! What am I getting wrong here?

The route listed in the IDE is NOT the only route used by the device. It’s just the last LOGGED route. ZWave devices do not only have one available route they know about all routes they CAN take… That’s why Zwave routing tables are usually expressed as a grid of available connections. If you’re trying to force the route to one specific device and see it in the IDE - you will be very disappointed. If the lock is working and a beaming repeater exists - stop.

So does the lock work?


Thanks for the quick response, Nathan. Well that answers my question. I thought I had been doing something wrong since the route within IDE was always showing back to the hub. My lock is working fine. I just wanted to make sure the network was working optimally.