SmartThings Community

FAQ: Help with Logitech Harmony (Connect) and Triggers (SmartThings Classic)

Best thing is to contact support@smartthings.com then. They should be able to check things from their side. Good luck, I’m sure it’s frustrating. :confounded:

See the following ( this is a clickable link )

I am having the same issue only difference is I am using SmartThings V2. I set mine up using the logitech mobile app., setting up a new account. I have never owned another harmony hub, but I do have a harmony 659 remote that is setup on an old account that has a different email address. Anyone have ideas to help solve the problem?

Click on the link in the post above yours, that’s where the connection issues are discussed. Good luck!

Hi,

Thanks for all the info in these posts. I have been able to connect to my Harmony Hub in ST. However I do not see the Logitech Harmony Trigger smart app under Marketplace\More. I have the v2 ST hub. Any suggestions?

Cheers
Rohitash

Do you have a UK account? Harmony integration is one of those affected by the OAuth problems, and I believe the related smart apps will not appear in the marketplace for those accounts

No - I have a US account. At least I should since I live in the US and setup my account while here :). I am able to do steps one) and two) of your very well explained post #7 with no issues. Just don’t see the Logitech Harmony Trigger in Marketplace so cannot start on step three.

Looks like they are making some changes and there is a new SmartApp now called a Harmony control. This is different than the Harmony connect smartapp. If you can find that one it does the same thing as the trigger smartapp used to.

You can try starting from your harmony hub in the things list and look under its smart apps and see if control is there. I’m still figuring this one out it just appeared mysteriously

@JDRoberts, Thanks for the pointer - that worked. I can now trigger Harmony activities from ST. Using virtual switches I was able to control the Harmony activities from Amazon Echo - pretty cool! I find a lot of the navigation in ST somewhat non-intuitive. Still getting used to it I guess. But it is amazingly powerful and functional once you set it up. And these forums are just great!

1 Like

Update 21 November 2015

Yes, the official SmartThings/Harmony integration again changed without notice.

Yes, it crashes in the mobile app.


Yes, I opened a support ticket.

No, I don’t know what the changes were, how to use them, or how to get around the crash.

The harmony/echo integration that bypasses SmartThings and uses IFTTT works just fine.

I expect the first support suggestion will be to uninstall everything and reinstall it with the new smartapp, but I won’t have anybody who can do that until Tuesday so if somebody else has answers please post them.

Confirmed here as well. Although for me I get “An Unexpected error” Message.

@JDRoberts I wish I lived near you, I would come over to help. I am sorry that this is happening so often for you now.

1 Like

I was researching all of these steps only to find out I have the same Issue.

I was able to add a new Harmony Hub, and I was able to “grab” things for use by the remote rather easily. However it seems impossible to control the TV from Smarthings. I will be opening up a support ticket with Smarthings as I have the same screen as @JDRoberts.

Bummer! I was hoping this would be cool to integrate as I can’t get my lights to work off of any sort of time rule anymore… I will update if I hear anything.

I tried deleting all of the harmony triggers and the harmony (connect) smartapp. Reinstalled everything and it still didn’t work.

So it looks like they put back the previous version of the trigger app as a workaround, and as long as you know enough to not try to do the triggers in the hub connect app, the mobile app will not crash and you can then go and install the second triggers app and use that.

So just follow the instructions from the first post exactly, and do not select any of the activities when you are working with the connect step. Just connect the hub. Then continue with the FAQ instructions and go get the trigger app and use that for the triggers.

Sorry, should have been more clear. I meant that I still received the credential error message even after reinstalling the Harmony (Connect) app.

I never lost my trigger app. I simply deleted them all in order to delete the harmony (connect) app. Once I confirmed the activities still didn’t work in the connect app, I recreated all my triggers with the harmony trigger app. Everything worked as it once did at that point. So yeah, I did exactly what you suggested already.

So I assume, once harmony fixes the issue, the trigger app will be removed from the smartapp store?

If you’re in the UK, there’s an issue that harmony has to address.

If you’re in the US, I think it’s only smartthings that has to make a change. Not harmony.

I honestly don’t know what’s going to happen with the fix, whether they will keep the harmony triggers app in the marketplace or fold that into the harmony connect. We’ll just have to see.

Hi, i used to have the same issue up to yesterday, however i have just tried now and it worked. Worth giving it a go

I was also getting the credential message but that seems to be fixed within the last day or so. Time to reconfigure all of my triggers and virtual switches again :-/

I was able to us IFTTT to control my harmony remotes with Alexa but I can’t seem to figure out how to use the Harmony triggers smart app and bypass using IFTTT.

Is it even possible yet to do this?

I’m able to create multiple instances of the harmony trigger smartapp BUT I don’t see a way to rename the smartapp. Each one I add is named “Logitech Harmony Hub Control”. Can someone tell me how to rename these smartapps?

EDIT: I found it buried way down on the page