Error when autheticating from CLI

I get this when launching the first command from CLI and allowing authentication in the browser.

Any advice?

image

Hi!
Have you tried clearing the browser’s cache?
Also, when you enter the CLI command, are you already logged in or does it happen right after you enter your credentials?

Hi Nayelyz, It happens right after I enter my credentials. Yes I tried cleaning the cache in Chrome, but unfortunately no success.

I tried this morning again but same result.

I tried also with another browser.

ok, I think there’s an issue with your account. For now, please, check if using the “manual authorization” works correctly.
For this, follow these steps:

  1. You need to create a Personal Access Token (PAT)
  2. Set this token as the authentication, there are two ways to do it:
  • Use the --token flag at the end of the command and copy the token, for example:
smartthings devices --token=xxx-xxxx-xxx
  • Create the config.yaml with the corresponding PAT (the path of the file changes based on your SO). For example:
default:
  token: xxx-xxx-xxx

In the CLI repo, there’s more info about the authentication for your reference.

Please, send me over DM your email account so I can create a report for the team to check what could be causing the issue.