Enerwave ZWN-BPC Z-wave Ceiling Mounted, Battery Powered PIR Sensor

On my working ones, yes, either 50 or 75% work fine. I didn’t try 100 or 25.

On mine sensitivity had nothing to do with them working. They either work or they don’t. And by don’t, I mean they never report motion or no motion. They report wake and battery all day long, but no motion. I feel it has to do with association, but I’m not sure why.

Real time I just woke one of them from the dead!

I think it can’t take a lot of configuration/commands at once. If I can repeat my success I’ll publish or pull a change to the devicetype.

Yayyyyyy! :smile:

Edit: Near as I can tell, the device can take only one configuration command at a time, or per wakeup maybe. I’ll be publishing something that worked on my three “dead” devices easily.

1 Like

Curious if you’ve tried changing the sensitivity without pulling the battery. Does it have an impact?

I read that you should change sensitivity with batteries in (with no backing information) and I have always done so. I will not try it with batteries in for fear of busting something. I want them to work.

Do you think you’ve done that to yours, or do you pull them? Easy to pull batteries anyways because they are right there.

Yeah, I’ve always pulled the batteries when changing the DIP switches. And then I have the nightmare of the sensor no longer reporting motion.

If you have some success with the three “dead” ones, I’d be curious if you have problems again after pulling the batteries/changing the DIP switches.

Just did a quick test. Pulled batteries, changed dip, inserted batteries, motion reported in logs right away. Works.

Publishing a devicetype within minutes.

Here is a working devicetype that will rescue these “dead” devices. If the device does not start working immediately using normal installation procedures, try these simple steps after attempting installation.

  1. Optional: Open your logs in IDE just so you can see and report what is going on.
  2. Take out one battery.
  3. Press configure button in App and put in the batteries immediately.

You should see a battery report, and then a motion report in the logs. If you see the motion report, you are in business.

I tested this reviving three devices (and supporting two more already running). It may be that you can time the battery insertion differently, my procedure is just what my default process was to wake mine. I did test all motion scenarios and they are working for me, just not all installation scenarios.

Cons: This devicetype no longer supports configurable motion timeout and wake times. I’d rather have a working motion, than these configurations for the time being, as I love the form factor. I may add the config back later carefully or when I get more of these devices.

1 Like

Can I ask, how much difference are you seeing in the sensitivity settings (100%, 75%, 50%, 25%)? I’m running at 100%, but that setting picks up pets.

Honestly, I have not done enough testing on that to know. I have all motion ignore when I’m away, and all motion does when I am home is bump thermostats, so it can be sloppy. I am going to start putting more lights on these, because the IRIS and ST sensors drive me insane because the cats have learned they can make things happen with them. Grr.

I’ll try to report back if I can get some good data on them. My recommendation is to keep backing off until you get acceptable results.

I use my PIR to control bathroom lights, so a high sensitivity is key. It turns the lights on full during the day and turns just one light at 10% during the night. But the cats set it off a couple of times most nights, so I may bite the bullet and try changing the sensitivity along with your new device type. I’ll let you know if helps mine handle the battery resets better.

I make my motion rules not work while we are in sleep mode. Works a treat.

Are you using this DH full time or after initializing, switching back over to the Z Wave Motion Detector DH from ST?

These are ‘Officially Supported’ by ST… but COUGH… they don’t initialize worth a crap. So I have to use a custom DH to get them onboard, but I immediately put them on the Z Wave Motion ST DH, so that they run locally for SHM and SmartLighting, etc…

The custom DH will, from what I understand, keep Smart Lighting and SHM from running locally if you tie this DH to those apps.

1 Like

I probably should switch like you are in order to get local… But I’m not looking for these to be speedy yet.

So I’m kind of walking down a road, haven’t reached the end yet. Just solved one problem today, making me feel pretty good.

I like your thinking, will probably do that.

I bought one of these a while back and finally got around to mounting it and adding it to the network. I mounted mine in the garage.

Initial inclusion:
Pain in the butt. It is an officially supported device, but it connects as a z-wave door sensor. Even when excluded and then included under the actual device. I went into the app and changed it to a z-wave motion sensor and it works great.

Device type:
I am using @bridaus device type. Just because I can. It works great.

Summary:
The sensor is super sensitive and works perfect for the garage. I have my lights set to go on when the house door opens or when the garage door opens or when there is motion. With a 15 minute delay for off after the open events or when there is no longer motion. This one picks up the slightest movement meaning my lights do not go off until I leave the garage.

I’m going to buy more of them.

Edit:
@bridaus, will you do me a favor and add the ability to change the timeout on this thing back into your code? If not, that’s cool. Thanks.

I will, just give me a week or so if you don’t mind. Busy time. It will be a separate button in order to keep device inclusion reliable.

1 Like

I paired two of these last night, couldn’t get them to work properly until I installed the custom device type. They seem to work great once connected properly.

1 Like

Maybe I got lucky. I set mine to 25% sensitivity and connected it. At first it came up as an open/close sensor but when I went to remove it it then listed as a z-wave motion sensor. Works great. Even turned up the sensitivity to 50% without any issues so now it works well in my living room with vaulted ceiling.

I had all kinds of trouble, but it was all my fault… I managed to freeze muy hub and everything I was doing was useless until I rebooted it.

I have it set to 100% and picks up everything. It’s perfect for my garage.

Look great so far thank you bridaus!!!

i tried everything, i reboot the hub, exclude and pair again and my sensor always shows motion ON :frowning:
any solution T_T