[Edge drivers] Cannot use child devices

Hello, will be supported ChildDiveces for future again? In the past was everything fine, now I can´t use child devices. New Edge drivers can´t help. In permisions for Hub V2 I see that ChildDiveces are not supported. Thank you for help.

I moved your post to a new thread to discuss this further.
If you have a V2 or V3 Hub you should be able to get child devices. What do you mean you can’t use them?
By default, not every driver creates child devices for each endpoint of the physical device, so, in this case, it would be useful if you provided your device’s fingerprints and the driver you’re using.

If you have questions about how to get that info, please, let us know.

@nayelyz I wonder if they are talking about the Characteristics of a hub in the Advanced Web App

1 Like

Yeah, I saw that too, I have the same value for my Hub but I don’t seem to have issues creating child devices, I don’t know exactly why it is marked as “unsupported”. I’ll ask the team about that.


not related to thread topic but about another field in the Advanced Web App that is not reporting correctly …
the Last Executed field is incorrect for Scenes

I checked one of mine and the value saved in the API is presented correctly in the Advanced Users’ App.
What do you observe in your case?

Following up about the field of childDeviceAvailability, the engineering team mentioned it is not currently in use. This means that despite having a value, it doesn’t represent the actual behavior of the Hub, it seems it’s currently set to false for all the Hubs.
I’m already checking if it can be removed from this view to avoid confusion.

1 Like

I will report it to support… need to examine more. some scenes do get their Last Executed field update and a few do not (I should typed that above). probably related to a community developed Edge driver. I will contact support and report it if I figure it out.

ok, thank you!

Hello Nayelyz, thank you for you reply. I had got problems that child devices ( 4ch multiswitch) was without posibility to command there. But later I found that there is setting at master device and you can create alone devices and comand them. So now is everything ok. Thank you for your interest.