(Edge Driver) Changes in profile preferences no updated in new driver version

Hi @nayelyz

Changes in profile preferences, adding new options in enumerations, changes in the text description… when the new version of the driver is generated, they are not applied.

Yesterday added new option to preferences change icon and not appears in the new driver version

I don’t know what has changed, this worked perfectly, only you had to clear the app’s cache and now you have to create a new driver ID to show the changes in the profile.

Hi, @Mariano_Colmenarejo!
Thank you for reporting this. Just to have a better reference for the issue, the driver isn’t updating despite you installing it directly and not through a channel invitation, right?

Hi @nayelyz

Yes, i installed with the CLI.
I created a test version with different driver ID and the preferences modifications appears good

Hi, @Mariano_Colmenarejo
Sorry for the delay checking this issue, I’ve been making some tests with the preferences and the updates come in. I changed the description, added more enums (or preferences)
Is this keep happening with your driver? have you verified that the driver version shown in the app matches the last one you built?

Hi @nayelyz

Yes, fixed after install last version of CLI, remove driver from hub, pack, publish and install new driver version.

Thanks

1 Like

Sorry @nayelyz n , I made a mistake, I can’t fix it, I got the wrong driver.

With the original driver, just packed and installed, hub reboot, cache clear… the preference looks like this, the added irrigation option is missing

If I create a new driver ID called -test then the preference is updated perfectly


This is the preference modified

  - name: "changeProfile"
    title: "Select Profile Icon"
    description: "Select Profile Icon:"
    required: false
    preferenceType: enumeration
    definition:
      options:
        "Switch" : "Switch"
        "Plug": "Plug"
        "Light": "Light"
        "Vent": "Vent"
        "Camera": "Camera"
        "Humidifier": "Humidifier"
        "Oven" : "Oven"
        "Tv": "Tv"
        "Air": "Air"
        "Refrigerator": "Refrigerator"
        "Washer": "Washer"
        "Irrigation": "Irrigation"
      default: "Light"

If I changed to the previous driver it fails again
I don’t understand anything

Hi, @Mariano_Colmenarejo
Sorry, I didn’t tell you on Friday but I was able to replicate the issue. I used your config and also, in the one I was using, it started to happen when I tried to configure more than 4 enums. I don’t know if the quantity is related.
What I noticed is that it also gets updated if we add a new preference.
Either way, I already reported this issue because I queried the generated device profile and noticed that it isn’t updated there as well.

1 Like