Ecolink FireFighter - can't clear CO detected status

I am using an EcoLink Firefigher Z-wave device to listen to my whole house fire/CO alarms.

It works great, I tested the fire alarm to be sure, and was quickly notified via SmartThings.

But on my actiontiles panel, it now shows CO is detected permanently, I can’t find a way to clear this status from the SmartThings classic app, nor the IDE. Anyone else run into this, or have any ideas that don’t involve removing from all my automations and setting up all over again? Would pulling the batteries for a few minutes work?

Do you have Smart Home Monitor installed in the Classic app? If yes, open it and clear/dismiss the alert.

Also, in case you installed SmartThings Home Monitor in the SmartThings v3 app, you should check there as well.

I had the same issue and received the below from Ecolink. It worked for me so give it a try.

There is an issue in the device where the clear command for CO is not sent if the smoke is detected at the same time. Have the customer try the test again, but cover the device during smoke (usually the 1st sound, 3 long beeps). Then un-cover the device during the CO sound (3 short beeps). This way the device only sees the CO sound and will send the restore soon after.

I only use the classic app - there is nothing to clear in the SHM, it shows all clear - specifically “clear” for smoke with no options for CO detectors. (thanks for the tip, though, I will check there if this happens again…)

thanks, will give it a try!

This isn’t an SHM issue (nor ActionTiles…).

You can confirm the latest “Current States” of the Device’s Attributes by logging into the IDE and finding the Device listed under My Devices, and click the row for details.

Indeed, this is a known issue with various smoke detectors: They may not send a reset/clear Event to SmartThings (or it may take a long time…?). The linked post above may be the appropriate way to clear/reset the status for your particular model of detector. Ecolink FireFighter - can't clear CO detected status

it’s been this way (showing CO detected) for months, I just haven’t gotten around to figuring this out yet. :wink:

First thing I checked was the IDE, if there was a reset available, or if I could edit the value somehow… Looks like I will have to try to run the smoke alarm test again as stated above.

Thanks for all the helpful info and tips, everyone!

1 Like

I’ve tried the “covering method” ecolink suggests a million times, no worky. Any luck for anyone else?

Ok, so I tried this method… work first time, right after I posted my question.

Went outside my house, audibly away from all the other detectors inside.
Took the cover off my ecolink.
Pulled the mic out of the little cradle it sits in and pinched it in between my fingers to cover it.
Pressed in and held in the tamper switch located in the center of the ecolink.
Set off my smoke/co detector and kept the ecolink mic covered during the smoke alarm test, but uncovered the mic for the CO cycle.

It reset itself and now shows clear on smoke and CO. Put it all back together.

Hypothesis: I think while inside the house eventhough i kept the ecolink covered, it could hear all the other linked detectors going off and got confused, and did not pick up on the clear command.

Good luck.

I just got my Ecolink firefighter today and ran a test and had the same problem with CO detector not clearing.

The easiest way to reset it is to login to ST developer website, edit the sensor and hit update. No need to make any changes.

The DH code clears status when installed or updated.

Now I need to figure out how to clear the CO detected automatically by the DeviceHandler


Sorry to dig up an old thread. I struggled for a while with this tonight and landed on this solution… but it may require you to find/borrow/purchase a CO detector (~$20).

First, I applied a settings change to make this sensor more reliably detect carbon monoxide alerts (at the expense of some battery life). To do this, you pop the cover off and told the Tamper and Learn buttons for about 10 seconds until some LEDs blink. Then you pull the battery & replace it. If you see Red+Red+Green, it worked. No clue what the battery life impact is (just did it a few minutes ago). As far as I can tell from the manual, it would take a factory reset to undo.

Second… the situation that tripped the alert up was that I tested a hard-wired smoke+CO detector. It triggered both smoke + CO alerts on the z-wave device but never reset the CO alarm. I happened to have a FirstAlert CO400 from one of my kids bedrooms (purely a carbon monoxide detector, not a smoke detector). I put this a few inches away from the Ecolink sensor and tested it. It played 4 beeps. A few seconds later the z-wave alert went back to Clear.

I think the combined smoke+CO detectors confuse the device with the sequence of beeps (smoke then CO). I think the less reliable CO sound detection (factory default setting) made this more likely. The CO detector test sequence alone cleared it up.

I tried playing a youtube video with the 4 beeps really loudly but couldn’t the sensor to react to it. YMMV.

This. Resetting by hitting edit then save for the device in the groovy IDE website works great and by far easier