Echo won't discover new GE switches

In the past week, I’ve installed a standard GE Zwave toggle light switch, and today I installed a GE Outdoor switch. Both work fine in Smartthings…but Echo refuses to discover them. I’m puzzled. Any tips? I have a GE dimmer switch that works fine with Echo.

Make sure you authorize the echo to control them either in the Echo SmartApp within SmartThings or by unlinking and relinking SmartThings within the Alexa App.

1 Like

Echo Smartapp? Previously, that only shows up as a Smartapp on a device after I have Echo discover them. I don’t see any way to enter the Echo Smartapp.

Edit: nevermind. I went to a current device which has the Echo Smartapp tagged to it, opened it, and it gave me the whole list. I forgot about this. Is there a generic place to access the Echo Smartapp? I seem to have forgotten where it is. I do that alot with the Smartthings app.

Why would I want to unlink/relink? That should be unnecessary.

Unlinking and relinking is just the way you do it if you start from the echo app. It’s not a big deal. It’s going to ask you to sign into your smartthings account, show you the device list, and you pick the devices you want authorized to echo.

If instead you start from the Smartthings app, go to the rooms view (four little squares Icon at the bottom of the page) choose “smart apps” and you’ll see your echo integration there. Start it, and again you get the list of devices, and again you pick the ones you want to authorize to echo. So you get to skip the sign in step if you start on the SmartThings side, but if you want to put the new devices into echo groups, you have to go and open the echo app anyway after you’ve authorized the devices, so some people may find just using echo and a little smoother. It’s just a matter of taste.

Details in the echo set up FAQ. See step 10.


Thanks JDR…this helps. I have this type of problem alot when working with the Smartthings app: I don’t mess with it for a week or two, and then decide to change things or adjust, and I have to reeducate myself on how to navigate within the app. Many areas are still not completely intuitive.

1 Like

I had the same problem and it was easily resolved by 1) Open Alexa app on my phone, 2) under “connected home” disconnect Smartthings hub, 3) re-add Smartthings hub, and then 4) discover new devices. The key is in when adding in Smartthings hub, you need to authorize Alexa to have permissions to manage your newly added devices. Intuitive? No

@Tristan_Todd Keep in mind, You can authorize the new devices via the Alexa SmartApp in SmartThings without needing to disconnect/reconnect the SmartThings Hub from the Alexa app.

Thak you. This worked perfectly. Had to disable Vera skill, re-enable it and then authorize echo to access it. Was pulling my hairs earlier worrying why it’s not working. recently did recessed lighting of the entire house with 5 new dimmer switches and definitely use them with Alexa. Thank you

1 Like