SmartThings Community

Echo Speaks . . . . won't

I have a piston that says “Goodnight” and plays lullabies for 30 minutes when a specific light switch is turned off. Or, at least, that’s what it used to do. For some reason it stopped working and nothing I’ve done can get it to work again. What I have here is the latest version of the piston. I’ve made sure that Heruko has the current Amazon authorization cookie. I’ve made sure the Echo is available to webCoRE as every possible device type that it appears in. When I turn off the switch, I can see the commands executing in the piston. When I look at the device activity in the SmartThings app, I can see the commands have been sent to the device. When I look at the webCoRE trace log (full) everything is normal. So to all appearances, the commands are being sent but the Echo is simply ignoring them. I get the same results – or more precisely, lack of results – using other Echo devices. I’ve made sure all my device handlers and smartapps are current.

The fact that this used to work flawlessly, and then one day just stopped working, is especially exasperating.

HELP!

I have the exact same problem. I have a piston to announce vehicle presence on my driveway. The piston was working perfectly for about a month and then one day my echo quit speaking with webcore. All other piston functions still work. I tried some of the things you mentioned to fix the problem but they did not work for me either. I still haven’t found a solution.

What is showing in the live logging when the poison is fired?

Live logging shows this when I run the piston.

124fce36-481b-4ee4-afa8-ce811b60c41d 10:39:11 PM: warn Amazon Cookie State Values Missing: [cookie:session-id=146-9221967-3852849; session-id-time=2191990409l; ubid-main=133-8988525-3597541; x-main=“sSsLcdwXH508aeEhTOxmBth109HswxH3”; at-main=“Atza|IwEBIDpJKJo2BxOOpqEPVaXO9KfvvFxsphT5Y76EOphdkrPC9QzLrObkvyHwAALi9ZTqNjfvxBxuDWoiW5OxFKw3sFKc-lasZ-uZjZXR8UHQqE5ghJADiSmuY6_4uOg97LqsvGGEHAIAo7dVst-oKPHX18aYRShIsdhmjiK6B1mg0mXrIGsH_EvLVZdQGalwgsESIBaPTNKBVdHTGDvjsQk53v0Kh-hL7I1ePjpMt7D7Zvc7f1jM2OEZQ5COD3Rwdh_26M5mPqb9FsSKsa_WT2kE1XySDsAMOaSJ0HLOANlaJrGksuFnj6KhJksSEa5MTh40X9WDB7FvLrkIssNZx8ocSLahQCzi14zSM06Gcnjkrjjxco5oZrAAH15KKaFzX_T8cRFgOEDtAWSxLXaKt93QSR9Uqu6kVE-hOVezMBkFqQVtZtRZF4AkNdVZTLIpzYQMREpeJh-OAz3ngkzPglB8RxzhExs2xkFm7sm2x0tL9Vun7VhL5st7PuNLsFBWPpIATM47qx5UpX8P6kp-41cl37DR_tLAbTF2NHp9CvnSNJBVIQ”; sess-at-main=“fY50tVP6edh1eGqj4YYeZ7jmnpXU7md1I33euJXaUkg=”, csrf:null]

The Echo Speaks app works without an Amazon Cookie problem.
Also Live Logging shows this error when pistons are idle.

10:54:35 PM: error groovy.lang.MissingMethodException: No signature of method: script_app_822c4f93e6bf415cb4f676173c8d12b6a5e4835e7dd4df206fe5374afa7ca36b.getDndEnabled() is applicable for argument types: (java.lang.String) values

I delegated Core and reinstalled but that didn’t help.

You need to update the Heroku sever. That should fix your issue as it did for many others.

1 Like

I don’f Know what you mean by updating the Heroku server. I tried deleting the Echo Speaks app and reinstalled it. Wouldn’t that update the server? Do you mean updating to a paid account?

Follow these instructions:

https://tonesto7.github.io/echo-speaks-docs/#/docs/updates/serverUpdate

I updated the Heroku server exactly per instructions. Again the Echo Speaks app works fine but my Echo will not speak using Core pistons.

My Echo Dot is showing paused in the Smart Things app. Is there a problem with my settings or device handler? How do I activate the Echo Dot?