Echo failing on Harmony activities


#1

Anyone else having issues with Echo failing to activate Harmony activities? I have 3 Harmony activities set up to turn on Directv, Apple TV, and Cable. Been working fine for weeks when I say Alexa turn on Satellite, Apple, or Cable. Today when I tell Alexa to turn these on I get the failure ‘clunk’ response. If I go to these activities in the ST app I can turn them on/off with no issues. I have not made any changes on my end to cause this (I think). Anyone else?


(Bernie H) #2

Nope working fine here.


(Ralph) #3

Not working for me right now.


(Matt) #4

my fire voice works. It says “Smart Things is not responding” but it performs the action


#5

Several people using the official Harmony/SmartThings integration have reported problems recently. Look towards the end of the following thread. Make sure you report it to support@smartthings.com

And this:

It is possible that this is related to a known bug in which commands which are written to be executed in milliseconds instead are assigned to be executed in seconds (1000 times longer) which can then cause the code to timeout. There’s supposed to be a fix for this delay issue coming soon. But again I don’t know if that’s actually what’s affecting the harmony integration or not.

Echo to harmony via Ifttt or Yonomi appears to be working fine.


(Nosnhojm) #6

I have the issue where Echo says it failed (“Hmm…SmartThings isn’t responding”), but yet the Harmony activity does launch.


(Matt) #7

thats what I get


#8

I posted something yesterday in another thread, I got the activity to turn on but not off. Echo listened but no response of failure or anything.


(Marc Connors) #9

If you want to get rid of that you can create a virtual switch for that activity. That way when you tell Alexa to turn on or off the activity it is just hitting the virtual switch which will give the warm and fuzzy OK from Alexa and get the same result.


(Matt) #10

I’m trying to add a new hub and funny SmartThings isn’t listed in my harmony under home automation


(Darren) #11

Yes, same thing for me–I get the “clink” failure sound, but I can trigger the activity “switches” within SmartThings just fine. I just can’t do it with Alexa.

I’m seeing something about new smart home features in Alexa on their Developer blog, so perhaps an Alexa update broke it, rather than SmartThings not being, well, smart?


(Michael) #12

I’m having the exact same problem. Everything was working fine, then all of a sudden, I started getting the “clunk” response whenever I asked Alexa to execute a Harmony activity such as “Turn on watch TV.”. Everything works fine on the Harmony App and Smarthings app, and all my other Alexa-Smarthings links are working. It’s just the Harmony activities that don’t work, and I’ve tried everything, including deleting and reinstalling them.


(Darren) #13

Do other virtual switches do the same thing (do you have any other virtual switches besides the ones for your Harmony activities)?


(Michael) #14

No, only the Harmony activities get the dreaded Alexa “clunk.”


(Darren) #15

Ah. There’s another thread elsewhere where it’s “clunking” for any virtual switches after Monday/Tuesday.


#16

FWIW, my Echo/Harmony commands work just fine as long as SmartThings is not involved. I can use them through both IFTTT and Yonomi.

Since Yonomi is also a “Connected Home” option in the Alexa app, it looks like it’s just the SmartThings/Echo integration that’s broken.

Some people are reporting this morning that the SmartThings/IFTTT integration is also not working for other devices.

And several reporting that virtual switches are losing state.

So there are many possibilities, but it does appear that it’s a SmartThings issue, not just an echo issue.

You could try setting up just one IFTTT recipe Using the “Alexa, trigger…” format where Alexa is the if and harmony is the that and see if that works. If it does, at least you know SmartThings is involved in the problem even if it may be due to an Amazon change.