Alexa+ST+Harmony: Alexa says smartthings isn't responding, but the command fires

I have an activity in Harmony for “cable TV”. It turns on the TV. It is integrated as a command within ST and subsequently, within the echo smartapp.

The problem: when I tell alexa to “turn on cable tv”, she responds “smartthings isn’t responding” but it still turns on the TV. When I tell her “turn off cable tv”, it fires and gives me a confirmation tone (no problem). When I tell her to turn on any of my room lights, it works perfectly. It only gives me this error when turning ON any harmony activity.
As info, ST is connected to the same AP as Alexa.

Any thoughts? Thank you so much!


I have similar oddities with my harmony when running different activities. It will either complain about smart things not responding or will tell me that the command is not supported for that device.

This is a known problem and has been brought up before, but I’ve never seen an answer or even a reason posted. Sorry!

1 Like

I also have the same problem…

The most likely explanation is that Alexa is not receiving a confirmation of activity completed response “soon enough” (i.e., it times out; I get this with any random SmartThings device from time to time, especially LAN stuff like Hue Bridge), or the response is incorrectly formatted (i.e., a bug in the Harmony and/or Alexa SmartApps).

If you can get a consistent case, be sure to write Support.

1 Like

Thank you, I will write support since this is consistently happening every time with Harmony activities (through Echo & ST) and it never occurs with lights.

Joe, I also got the “command is not supported for that device”, but only when I used the name “TV”. I switched it to “cable” and started getting this other error. Both would still launch the activity, just return an error each time.

Per ST’s suggestion, I removed the activity labeled “cable” and reloaded it into ST, and still get the same result. Alexa gives me the same error with all harmony activities. Any other ideas from the community?
My network is run off a Netgear X6 AC Wifi which feeds the Echo and Harmony hub on a 5G frequency, and the ST hub is plugged into the same AP. The latency runs from from 3-5ms, so I know it is not a delay in the network.

I am having the exact same experience.

I have the same problem

I have the same issue when trying to use Harmony activities through smarthings and the amazon echo. :frowning:

Add another to the list. Happens to me as well. It’s rather annoying so I’m hesitant to set up any other activities through the Echo until this is resolved.

I have the same problem as well!

1 Like

I got this email from Smartthings support: “I did some checking, and this is actually a known issue on our end. I have tagged your account to get a notification once we have the root cause identified and fixed. Sorry for the trouble; and thanks for your patience while we work on this.”

Would everyone on this thread please send an email to smartthings support to get this issue elevated?

Same issue for me. Just sent email to support. Not too happy, I just bought the SmartThings Hub yesterday. :frowning:

Don’t worry, they have been good at resolving these issues quickly. I have had the ST hub for 5 months now and I am very happy with it (and the support).

Good to hear!

I’m also having issues. Additionally, my macro “Netflix” currently isn’t working but individual device commands do work

The SmartThings rep told me to please let you all know that you really should submit a ticket if you want the issue elevated!