DVM S Mini system not controllable via SmartThings on Android

Hi everyone. I have a DVM S Mini system (AM050KXMDEH/EU) with 4 indoor units and a WIFI kit which allows me to control each separate indoor unit (four of them) via SmartThings. I have successfully added the AC system to SmartThings and the router is veery close to the WIFI kit, so connection is good. Since the units are in ST, I can turn each of them on and off.

However, if you click on any single indoor unit in ST, a details screen with additional options (besides just on/off) should appear. However, on my Samsung Galaxy S10+, nothing happens. Just a blank screen appears. I tried everything - restarting, updating, changing fonts, changing display resolution, etc. My previous phone was a Samsung Galaxy S7+ - the same issue there. I even tried an online emulator with the SmartThings app and logging in to my account - same stuff (on Android 12).

Again, however, my girlfriend has an Iphone (12 or 13 or 14, I don’t know which one, but I guess it doesn’t matter) and she doesn’t have this problem. When she clicks on an AC in ST, the details screen opens up properly and she can set the mode, the temp, and has no issues.

I tried contacting samsung support, but they gave me the usual crap about being up to date, re-adding the device to ST (which I already did) and a bunch of other useless (at least in this case) tips. I’ve tried everything, and, at least to me, this seems like an UI issue (since the three dots icon, for options, appears and I can click it, but the menu opens and is blurred, which implies that the app is trying to open some kind of new view, but is unable and probably threw an exception which isn’t handled.

Has anyone had a problem like this? Is my only solution to upgrade to a new phone? This is the only device that I have a problem with. And I’m using hue lights, Samsung washer and dryer (although I have a separate issue where the dryer gets recognized as a washer - WTF?) and a Bosch dishwasher. Everything else can be controlled, only the AC system is problematic on my Android.

I’m in Bulgaria/Europe and I don’t have a Samsung/Aeotec hub, everything is connected to the wifi network (Besides the Hue stuff of course, but that’s beside the point).

EDIT: I also have a galaxy tab s6 tablet, and tapping on the AC in ST on it doesn’t work as well.

I went to a tech store today and tried it on the z fold 5. Same result - the smartthings app doesn’t show anything for the DVM-S system. My initial reaction was that, since the tech I have at home doesn’t run the latest latest android, the current version of the ST app might be using some new view or service that is unavailable on my phone/tablet. But that doesn’t seem to be the case as even on a cutting edge Samsung device - I still have the issue.

I ended up buying a new Galaxy S23 ultra. When I opened the ST app, the AC was showing properly. I thought that fixed the issue. However, when I went on my old S10+, the AC showed correctly as well. I thought the problem was supposed to be something with the Android version or some cached data or anything. I have the suspicion that there is an issue with the ST app communicating to the AC somehow. Although there was no issue with that on the iphone.

Hi Martin,

I have exactly the same problem with s21 and MIM-H04EN Wifi kit. Initially the details were showing but suddenly they stopped appearing. Actually another Bulgarian reported the same problem in another thread here from August 2023.

I’ve tried with the samsung support from the smartthings app, but that only got me to the typical “clear cache, clear data, reinstall, etc.”.

I guess this isn’t a very common case (DVM systems with WIFI kits) so they aren’t really putting much effort into it.

I guess there might be some issue with the data that you get from the wifi kit and ST can’t really process it. I don’t really have another explanation. I guess the devs have tried to bundle all air conditioners together in the app, but the DVM systems are quite different and only show properly under certain conditions. That would kind of explain why it works on ios (if the devs of the apps are different)

I suggest we coordinate to send error reports close to one another, perhaps seeing the same problem multiple times in a short span might trigger some alarms

Maybe one of the ST people that monitor this forum may be able to help you.

@nayelyz @AlejandroPadilla @Ivan_Luis_Falleau

1 Like

Thanks for tagging them. Guys, if you need debug/trace logs or even remote access to see how this doesn’t work, I’m open to it.

I’ll just add (if I haven’t already) that removing and re-adding the wifi kit doesn’t help and neither does resetting the wifi kit itself and connecting it to the network again.

I also really don’t have a clue what might have happened (it wasn’t something done by me or at least I don’t think so) that I was able to view the individiual AC units details screens for like 2 months and then they suddenly stopped showing (almost 2 months of that too now). As far as we have tested, the details have always showed on an Apple phone and this only seems to be a problem on any android.

@nomorewords We are from the developer support team, so we have some limitations regarding these types of cases (customer support). However, let me check what I can do.

This type of device works differently than other devices (C2C or Hub Connected devices), and for that reason, we need to investigate. Therefore, we will need the following information:

1- Evidence (Video or Screenshot)
2- Logs of the mobile
3- Support access

You can send me a direct message or send it to build@smartthings.com

Support access

  1. Confirm the email account registered in the forum is the same one you use for SmartThings. If not, please share it with me over DM.
  2. Enable support access to your account:
  1. Go to the SmartThings Web (my.smartthings.com)
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.

Mobile logs

If you are using a Samsung device

  1. On your mobile device, launch the Phone app (where you make calls) and enter the code *#9900#
  2. On the opened page, click on “Run Dumstate/Logcat”. Wait until it finishes and shows a message with the created file
  3. Then, select the option “Copy to SD card (Include cp Ramdump)”. When it finishes, it will show a success message.
  4. Share the file with us, please. There are two options:
    From your phone:
  5. Go to Files > internal storage
  6. Find a folder called “log” and search the created file there. Sample name: “dumpState_G950USQU8DUD3_202208162013”
    The last part helps you identify it better because it includes the date and time when it was generated.
    From a PC. Connect your device to a PC and look for the “log” directory and find the generated file.

For other Android devices:
1- https://www.youtube.com/watch?v=TLGcTtYUKBQ
2- https://www.youtube.com/watch?v=wUpIcCTI-1s
3- https://www.youtube.com/watch?v=4bo_QAl_VhQ

1 Like

@nomorewords Also what is the behavior of the devices in my.smartthings ?

Hi guys,

I’ve checked the application logs and it seems that there is a problem with the plugin that is being downloaded in addition from the app itself (DA_SystemAcV3_Plugin_OCF.SAC_V3.180100.17_011.047_signed.apk). The actual error from the log is:

01-16 14:56:05.351 7887 7887 E PluginPlatform[1.51.21][151021] : PluginDexClassLoader.loadClass - Class not found in Platform, Plugin: com.samsung.android.oneconnect.base.contactus.voc.Logger
01-16 14:56:05.351 7887 7887 E PluginSystem_Air_Conditioner_Plugin[1.0][1]: Failed to register log tag!
01-16 14:56:05.351 7887 7887 W System.err: java.lang.ClassNotFoundException: com.samsung.android.oneconnect.base.contactus.voc.Logger
01-16 14:56:05.351 7887 7887 W System.err: at java.lang.Class.classForName(Native Method)
01-16 14:56:05.351 7887 7887 W System.err: at java.lang.Class.forName(Class.java:536)
01-16 14:56:05.351 7887 7887 W System.err: at java.lang.Class.forName(Class.java:467)
01-16 14:56:05.351 7887 7887 W System.err: at com.samsung.android.plugins.util.c.a(Unknown Source:2)
01-16 14:56:05.351 7887 7887 W System.err: at com.samsung.android.plugins.util.e.m(Unknown Source:0)
01-16 14:56:05.351 7887 7887 W System.err: at com.samsung.android.plugins.util.e.r(Unknown Source:54)
01-16 14:56:05.351 7887 7887 W System.err: at com.samsung.android.plugin.cube.beverage.MainActivity.onCreate(Unknown Source:30)
01-16 14:56:05.351 7887 7887 W System.err: at android.app.Activity.performCreate(Activity.java:8944)
01-16 14:56:05.351 7887 7887 W System.err: at android.app.Activity.performCreate(Activity.java:8913)
01-16 14:56:05.351 7887 7887 W System.err: at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1456)
01-16 14:56:05.351 7887 7887 W System.err: at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:4146)
01-16 14:56:05.351 7887 7887 W System.err: at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:4322)
01-16 14:56:05.351 7887 7887 W System.err: at android.app.servertransaction.LaunchActivityItem.execute(LaunchActivityItem.java:103)
01-16 14:56:05.352 7887 7887 W System.err: at android.app.servertransaction.TransactionExecutor.executeCallbacks(TransactionExecutor.java:139)
01-16 14:56:05.352 7887 7887 W System.err: at android.app.servertransaction.TransactionExecutor.execute(TransactionExecutor.java:96)
01-16 14:56:05.352 7887 7887 W System.err: at android.app.ActivityThread$H.handleMessage(ActivityThread.java:2685)
01-16 14:56:05.352 7887 7887 W System.err: at android.os.Handler.dispatchMessage(Handler.java:106)
01-16 14:56:05.352 7887 7887 W System.err: at android.os.Looper.loopOnce(Looper.java:230)
01-16 14:56:05.352 7887 7887 W System.err: at android.os.Looper.loop(Looper.java:319)
01-16 14:56:05.352 7887 7887 W System.err: at android.app.ActivityThread.main(ActivityThread.java:8893)
01-16 14:56:05.352 7887 7887 W System.err: at java.lang.reflect.Method.invoke(Native Method)
01-16 14:56:05.352 7887 7887 W System.err: at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:608)
01-16 14:56:05.352 7887 7887 W System.err: at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:1103)
01-16 14:56:05.352 7887 7887 W System.err: Caused by: java.lang.ClassNotFoundException
01-16 14:56:05.352 7887 7887 W System.err: at bp0.c.loadClass(Unknown Source:56)
01-16 14:56:05.352 7887 7887 W System.err: … 23 more

BTW this is the other topic with the same problem and it also contains a video:

1 Like

Sorry I hadn’t checked the thread for a few days. @OLDcomer looking at your stack trace got me thinking that we might workaround this by ourselves (until a fix hopefully comes). I went to Advanced Settings > Developer Settings > Log Output Level set to NONE. I opened ST and the AC started showing the details view properly.

I have a vague memory of me setting the log level to trace some time ago but I didn’t think it could be causing the issue. When I get back home I will also try to get my logs to see if it really is the same thing, but I pretty much think it is

I checked also my.smartthings but for the devices that require add-on it returns zero valuable info/controls like for example Samsung AC or Samsung Oven which I also have. I think that the problem is in the add-on for AC as you can see from the logs I published earlier.

@nomorewords your workaround with changing the log level, doesn’t work for me. Still I’m getting the blank screen and the error appears in the application log.