Dryer Auto Cycle Link stopped working on iOS devices

Hi Community,

I need assistance as the support received via the Smartthings app keeps closing the cases stating they are not the right team (which is the same method I have been using since I have Smartthings) :-1:

It’s been a couple of months since I noticed the Auto Cycle Link between my washer and dryer stopped working on iOS devices. Below is the behavior I am experiencing:


Android phone can enable just fine the Auto Cycle link and stays ON. However, if I access the Smartthings app via an iOS device, the Auto Cycle Link turns off by itself when I access the Dryer. If I exist/close the Smartthings app on the iOS device go back to the Android Device open the ST app on the Android device and access the Dryer, I see the Auto Cycle Link OFF, I turned it back on, and works fine (stays on).

But if I go back to the iOS ST app and access the Dryer it turns off right away, and if I try to enable it turns off in a second by itself (It’s like pressing the ON on a light switch and the button gets pressed however it goes back to OFF (like a faulty light switch) that is what I experience with that Auto Cycle Link feature switch on iOS devices.

I have tried enabling the feature on my iPhone 12 pro, iPad 6th, and my old iPhone 6s (which has an old iOS version to discard any issue with the newest iOS versions) and neither can enable the feature (it turns off right away)

-Models and versions:

	·    Samsung Washer Model: WF22R6270AP
	·    Samsung Dryer Model: DV22R6270PP/AP
	·    Samsung Smartthings Hub v2 with firmware 000.050.00010
	.    Smartthings version:
	·    iPhone 12 Pro with iOS 17.1.2
	·    iPad 6th gen with iOS 17.1.2
	·    iPhone 6s with iOS 15.8	
	.    Huawei Android version: 9.1.0 (

2-There is not any error when trying to activate the “Auto Cycle Link” option under the Dryer, it just simply does NOT turn on, so I CANNOT send you any screenshots. I wanted to send a short video, but can’t do it this way. Is there any repository I can upload the video so you guys can understand better what is going on?

2-This is happening ONLY on iOS devices

Hope someone can guide me to resolve this as I use this feature every time I wash clothes and is very useful and less time-consuming



There was a new version of the iOS released today (version 1.7.10) so you may want to give it a try.

You may also want to post a review in the app store and post on the Samsung Community forum. Those two areas may bring more attention to the issue you are experiencing.


Yeah I saw that one and right away updated the app however the issue remains :frowning:

Thanks for the tip. I will post that on both places :smiley:

if you find a solution or it gets fixed in the app… you should post updates here to keep users informed :slight_smile:

1 Like


BTW, I also updated my Apple devices to the latest iOS version (17.2), and the issue is still the same. So definitely is something within the washer/dryer Edge drivers (firmware) or Smartthings app itself on iOS

1 Like

I did post the same on the Samsung Forum and they closed out the thread saying you should open a thread here :-/

Well, at least in the other community there was 2 people that reports experiencing the same and for one suddenly started working, however I am not that lucky :smiling_face_with_tear:

1 Like
1 Like

Yep, same issue here with out dryer, the Auto Cycle Link setting will not set. Current release of IOS on the latest iPhone Pro Max. I shave other issues with SmartThings for my new TV too, looks like Samsung’s dev team are a little slow on their software releases.

1 Like

Hi, thank you for replying. I have tried everything with not luck either

I opened a case via email and chatting with suppporh but they are asking me to send the logs which are not been created so I am stuck to provide what they need to look into the issue

I’m having the exact same issues here. Auto link stopped working and when trying to turn it on, the toggle jumps back to off. Nothing I do seems to resolve it. :sweat:

1 Like

Thank you for sharing the same frustration. :pensive:

I’m having the same issue as well.

iPhone 14 - iOS 17.1.2
Washer: WW85T554DAB/SA
Dryer: DV80T5420AB/SA

The following happens,

  1. Auto Cycle Link screen. Toggle is set to ‘Off’, so I toggle it to ‘On’
  2. Processing” screen
  3. Configuration Page” screen with the option to select “Cancel” or “Done”. This page also mentions “Your mobile device is requesting permission to control the device. This would allow your device to run the Auto cycle link. You’ll need to allow this permission each time you turn on Auto cycle link.”.
  4. Select “Done”
  5. Return to the Auto Cycle Link screen. Toggle is still set to ‘Off’.

I’ve checked my iPhone settings. I can’t see any additional permissions that I can grant to the Smart Things app, just in case this was a permissions issue.

I’m having the exact same issue. Auto link stopped working and when trying to turn it on, the toggle jumps back to off on the dryer

Ios 17.2.1
Smart things app 1.7.10
Washer WW90T986DSX
Dryer DV90T8240SX

Both washer and dryer on same wifi

I was chatting with Samsung service about this today.

They asked me to check the following

  • both washer and dryer are connected to the Smart Things app.
  • both washer and dryer are on the same network.
  • in the Smart Things app, enable Smart Connect on the dryer
  • in the Smart Things app, enable Smart Connect on the washer
    I didn’t have to change any of this as everything was already connected/enabled.

The rep then asked me to try enabling Auto Cycle Link again.
This time it worked!

I asked if they changed anything on their end, and they confirmed they hadn’t.
Maybe they’ve fixed something in the backend. I hope it now also works for all of you! :crossed_fingers:

1 Like


Thanks for the suggestion.

I have removed and re-added the washer and dryer from the network, removed and reinstalled the ST app, rebooted my entire network, and the same behavior to me. Nothing has changed

I always have to enable Smart Connect from both devices as I usually have both devices OFF when not in use, but if I want them to be controlled via ST, I must enable (press) the “Smart Connect” button on each device. so I can confirm both are always ON (enabled) when I try to enable the “Auto Cycle Link”

I have also tried enabling the “Smart Connect” section under each device by checking the “Stay Connect” checkbox and again tried enabling the “Auto Cycle Link” and it didn’t work :frowning:

So I am not that lucky :frowning:

BTW: The steps you described above are the same steps I have done for the last 2 months and before that to enable the “Auto cycle Link” and 3 months ago it was working fine. but nothing since 2 months ago or so.

Hi Everyone,

If someone still having the same issue as me. Could someone try the following steps to gather the logs from the ST app? I have been fighting with support as the steps don’t work for me, but wanted to make sure if not me or if there is something with my iPhone:

Please follow the below steps to send the logs. If you face any issue please send the screen recording of the steps taken to send the logs.

Open the SmartThings app [Menu->Contact Us->Error Reports*->*Tap on the “Error Reports” heading 10 times. When ‘Create a log?’ appears tap OK.] This will generate a log file which can be directly attached and sent via email.
The file is saved to your phone, so check for these logs in your phone files under /Downloads. They should appear as a .log or .zip file. You do not need to complete the report from the web page, just attach the logs in your reply here. The logs may take additional time to generate, so wait a minute or two before checking.

To clear up any confusion, please provide the time and date the error was reproduced along with the time the logs were sent.

If you guys can start attaching those logs files opening a case with them or sharing the info here, It can help us all to resolve this issue.

Oh :slightly_frowning_face: I’m sorry to hear this.

Is this still an issue with everyone or has a fix/workaround been shown? My auto cycle hasn’t worked in a couple months. iPhone user.

1 Like

Hi Chris,

At leas for me still an issue, even after recent iPhone iOS updates or ST app update.

I would suggest the following as the support team suggest to investigate:

1-Reproduce the issue
2-Open a case via the “Contac us” via the app.
3-Share the logs

I haven’t been unable to provide the logs because I am NOT in US and the case is routed to useless local support team, so I decided to open q caes via email with US support but I am stuck with US support because they need the logs and the app doesn’t allow to gather the logs out of the “contact us” section

If you are in US or Canada, you could be more lucky if you open a case via the app and share the logs containing the issue

Nobody from support is going to help us over here. So the best option is every single of us having the issue, open a case via the app and provide the logs after reproducing the issue

I have shared this thread with the US support team so they can understand I am not the only one having the issue, but it hasn’t make any difference though :frowning: