"Double Tap" SmartApp


(Daniel) #1

Has anyone used this SmartApp succesfully? It’s supposed to turn on/off a number of specified switches whenever a designated switch is double-tapped. Seems very useful for turning out all the lights before you go to bed, for instance. Has anyone gotten it to work? I double tap the specified siwtch and get nothing.


(Cory S) #2

I have only gotten it to work on a few switches. You gotta give it a good 1-2 second delay before you tap again. For some reason though it won’t work at all on the majority of mine.


(Gray) #3

If I learned anything from Zombieland, it’s that you should always double tap.


(Daniel) #4

I tried hard to get this to work last night on my GE/Jasco 3-way switches, to no avail.
Bummer, because it would be very useful. Maybe I’ll try to write my own when I can find some time.

Continuing on the topic of wonky SmartApps, has anyone had issues with the Sunrise/Sunset one in Mode Magic? It seems to only work whenever it feels like it.


(Cory S) #5

Most of the modes give me extreme issues. The Bon Voyage app use to work fine and now won’t do anything for me. The Goodnight app will trigger, but override every other app which tries to change the mode for the next day. My entire system gets less and less reliable by the day, and I can’t figure out if on my end, or the cloud.


(Douglas) #6

Hi All,

I know this is an old post, but before I go to the trouble of installing a new hard-wired switch just to test the Double Tap behavior (my plan is same as Cory S – I’d like to have a switch near my bed which can issue an All Off) I thought I’d post and see if anyone is successfully using it?

> system gets less and less reliable by the day…

I’m trying to replace an X10 system I’ve cobbled together over the years, and though I’m finding I can do a lot more - in theory - with STs, I can only reliably do those things maybe 80% of the time. Getting a little disheartened. :frowning:

Doug


(Chrisb) #7

@dcampacm-org,

Double tap works, but… you have to have the right rhythm to it. Don’t “Tap-Tap”. Instead, you need to “Tap-pause-Tap”. You want about a 1/2 to a 1 second pause between taps.

Also, the switch involved probably needs to have direct communication with the Hub rather than through the mesh network.


#8

Double-tap app installs fine, but doesn’t work. I have a ge on/off switch for my back porch light. I have another ge on/off switch for my pool light. I installed double-tap to execute on the back porch light, to turn on/off the back porch light and pool light, but nothing happens.


(JimMay3) #9

DoubleTap worked great for me up till August 2017 when ST’s decided to disable the architecture that allowed it to run in a firmware update, thus is there any replacement for it? Are we not supposed to be gaining capabilities as the system develops? Always liked it as a useful utility, guess they’d rather you buy more hardware to do the job that software was doing just fine…