Doubletap dead?


(Tasmin) #1

I was using Double Tap on two of my GE Dimmer switches with no issue until last week. I had it linked to a momentary tile for a HHA that did “goodnight” and shut down and locked everything.
Now whenever I push the physical switch off once, it activates the double tap. Which is a problem because instead of just turning off the dining table light, the whole house shuts down. Kind of a dinner party killer.

I messaged support now that its a listed app and they said it was currently broken with the last update, didn’t give the impression they were working very hard on fixing it.

Suggestions for a standin or fix? I want to physically touch my switch in a way that allows other things to happen.


Emulate Hue Tap with SmartThings
(The fish is still dead.) #2

Broken here, too. The list of platform update casualties grows…


(sidjohn1) #3

looks like double tap is dead for me as well… IDK what is going on cause i can see the double tap apps firing, but they aren’t doing anything.


(sidjohn1) #4

http://status.smartthings.com/incidents/d0wzvm73l7wd


(Ben Edwards) #5

We’ll look into this once the platform sluggishness resolves.


(sidjohn1) #6

i gave it a shot this morning and it works fine for me


(Brian Schwartz) #7

Doesn’t work for me. Not sure why it would work for some people and not others.


(sidjohn1) #8

Not all switches will send an on when they are already on or off when they are already off. GE switches seam to work well, but I can’t speak for others.


(Brian Schwartz) #9

I have a GE switch and it stopped working. Support just said this was not supported anymore.


(sidjohn1) #10

The doubletap app was last updated in June 2015, and still works for me with various GE light switches. Plus 2 weeks ago a founder jumped in to say it will be looked into when we started to report that doubletap was dead. So i find this highly unlikely. If doubletap is still not working for you you may want to open live logging and watch the logs for the doubletap smartapp when you turn on/off and doubletap on/off (.5-1 sec pause between taps) if you see 1 STATES FOUND thats a single tap, 2 STATES FOUND is a doubletap. You can also check your device logs, if you see more than 1 on or off command in a row (changed will = false) then doubletap should work.

Double Tap should work:

Double Tap should not work:


(John Lord) #11

here’s a solution:


(Ben Edwards) #12

How does this fix it? (sorry haven’t read it)


(Brian Schwartz) #13

I’ve taken it a step further and created a smart app to just update a counter every time you hit the “on” paddle. I get the state to update to 1 when I turn it on, but no matter what, I can’t get it to get to 2. So double tap won’t work for me. I’ve been watching the logs and using the debug in the dev tool, still nothing.

I also have been going back and forth with SmartThings support since at least March of this year on this problem - even getting to a developer. And the answer I got back from them (re: double tap) is:
“I’ve spoken with Tim and confirmed that the issue isn’t the switches but is a platform problem. In the early days of SmartThings we did many things as proof of concept that weren’t sustainable. This is an example of where we tried to do something through a hack which worked with inconsistencies but is no longer supported. I’ve spoken with our VP of Engineering and confirmed this the case.”

I’m just confused why a platform problem would be very reliable for so many people and not work consistently for others. The support rep I’m working with even referenced this thread showing how it is not working for more and more people.


(sidjohn1) #14

Hmm… i guess support and i interpret the same thing differently. I don’t see how a device not sending two or more on commands is a platform issue. To me that is up to the device. I could totally be wrong, and i love being wrong and learning new things. I know this is kinda like beating a dead horse but what model# ge switch are you using?

Also i have had a change to look over @lordorwell “doubletap for the rest of us” code, it should work for you. The only difference is that the double tap is on/off, instead of on/on or off/off


(Brian Schwartz) #15

I’ll check out that code to see if it works.

I’m using this:


(sidjohn1) #16

So i just realized i have both generations of ge switches the 45609 aka zw4001 and the 12722 aka zw4005. I had never setup double tap on my 12722’s cause it never made since for my setup. So i just finished futzing with both of them with some live logging action and i can safely say these 2 switches do not respond the same way to button presses. No wonder this is so confusing!

This is what i have found:
GE 45609 aka zw4001: rapid fire double tap (milliseconds between taps) on/off works flawlessly. Light turns on and double tap app fires and turns on secondary switch. This is the expected behavior.

GE 12722 aka zw4005: rapid fire double tap (milliseconds between taps) on/off does nothing. No logs, no lights, no nothing. If i slow down and just tap it, light turns on and i see a single “on” in the logs. if i pause and tap 2 more times after the light has turns on (.5 - 1sec between taps) double tap fires on and off consistently, but it took 3 taps spaced .5 - 1sec between taps to get it to work. it seams you have to triple tap them like you’re 95 with arthritis to get these switches to send 2 on commands so double tap will fire.

@Brian_Schwartz If you are up to it, can you confirm this for me on your end?


#17

Yep. We live in an analog world. All physical switches bounce. Most switches have some kind of debounce code. Fitting double tap into that is always tricky. Creating a double tap routine that will work when someone just hits “off” really quickly is even harder. (BTW, preserving the quick off is why most double tap routines are based on “on on” not “on off.” )


(Brian Schwartz) #18

I’m not getting any response no matter what combination I try. Although as I type this, I remembered that I bought a new switch at Lowes that I swapped out for the GE one since I thought the switch might have been the issue. Although it is still a GE, but not sure the model number.

I should also note that I’m not really using the double tap app - although support says it is the same thing as the double tap. I created my own app which just listens for an “on” and increments a count whenever it is found.

In case you want to see it, I’ve pared it down here - it used to work fine:

    preferences {
	section("What switch would you like to use") {
		input "master", "capability.switch", title: "Where?"
	} 
}

def installed() {
    state.count=0
	subscribe(master, "switch", switchHandler, [filterEvents: false]) 
}

def updated() {
   unsubscribe()
    state.count=0
	subscribe(master, "switch", switchHandler, [filterEvents: false])
} 

def switchHandler(evt) {
    if (evt.value == "on") {
         state.count = state.count+1
         log.debug "Count is ${state.count}"
         switch (state.count) {
             case 1:
                 log.debug "Case 1"
                 return null
             case 2: 
                 log.debug "Case 2"
                 return null
             case 3:
                 log.debug "Case 3"
                 return null
             default:
                 log.debug "default"
                 state.count=0
                 return null
             }
    } else if (evt.value == "off") {
         state.count = 0
         log.debug "Count is ${state.count}"
    } else {
         log.debug "Not sending on or off"
    }
}

(www.rboyapps.com - Make your home your butler!) #19

The trick I used was actually to slow it down. I found that if I click it too fast the Z-wave commands are not communicated to the hub. So I used it like:

  1. Tap
  2. Wait 2 seconds
  3. Tap

this works for me.


(Ran) #20

This is not working for me…does it still work and I just haven’t figured it out?