Door left unlocked notification (2020)

Yup!

https://thingsthataresmart.wiki/index.php?title=Using_Custom_Code

This probably should be updated to reflect how you get to your SmartApp in the new app. For now, here’s how in the new app:

Tap on the large “+” next to the three vertical dots and then tap on SmartApp and scroll down until you see My SmartApps.
or
You can also tap on the three horizontal bars on the left side of the mobile app and then tap on SmartApps. Then tap on “+” and scroll down until you see My SmartApps.

1 Like

Step by step SmartApp installation instructions.

1 Like

Thank you all! Tremendous help.

3 Likes

This is fantastic! Thank you!!

1 Like

Tried this custom app out, but apparently my Meross garage door opener is not supported. The “Left it open” child SmartApp says that I have no compatible devices. It has the possible statuses: Open, Closed, Opening, Closing, and I think Unknown.

Anything I can do to get it working, or do I need to turn to one of the more complex solutions (SharpTools, etc)?

Thanks

Thanks for the quick response. I actually came from that post originally. This app seems to be the easiest solution.

I believe I found the two problems I am facing:
First, the Meross integration creates a device with some random “type” set. I don’t remember what it was, but I just now changed it to “Garage Door Set” to see if that worked. It did not. It seems like this custom SmartApp is looking specifically for a certain type of device, but I’m not sure what to set the device type to that will allow this SmartApp to leverage my garage door opener. I also tried setting the device type to “Contact Sensor Capability” and this did not work either.

Second, I signed up for SharpTools and connected my SmartThings Hub, but the garage door did not show up in the list of devices to authorize SharpTools to control/view. It seems that for some reason, the garage door is not “shareable” with other service (makes sense, now that I think about it, since it does not show up in Google or Alexa either).

Any recommendations on overcoming one or both of these problems?

Thanks

It should have a device type of “placeholder” since that’s what all the cloud to cloud integrations have on the new platform. You should not change this to any other DTH: they won’t work and they may break the integration. “Placeholder” essentially means “the device manufacturer’s cloud is handling the commands for this device.”

It sounds like you may have to contact Meross support and ask them if there’s a way to have the device identified as a garage door to SmartThings.

I was hoping at a minimum that it would identify itself as a sensor, but it appears that it does not. :disappointed_relieved:

1 Like

Woops! I changed it back to placeholder. It seems these problems stem from Meross not identifying itself correctly, as you suggested on the other thread.

On a side note, I was able to connect it to SharpTools by going into the SmartThings app and adding it as a “refreshable device” (it doesn’t show up in any of the other categories of devices). SharpTools appears to be able to see all of the device attributes and their current status, so I set up a test rule to send me an email if the door is left open for 5 minutes. I’m not sure how frequently it’s polling for status updates, or if the connection is working at all, but we’ll see.

Update: SharpTools working! If Meross fixes their device integration someday, I may look into switching to a more integrated solution like this SmartApp.

3 Likes

Unfortunately, it doesn’t. :frowning:

You can use a Virtual Switch with the Meross Garage Door openers along with IFTTT (or perhaps even the built-in SmartThings Automations) and then use that virtual switch in SharpTools or other SmartApps:

Historically, people also used the IFTTT approach with Virtual Switches because the Meross integration with SmartThings was really flaky. I understand Meross has made some updates to their SmartThings integration, but I haven’t personally tested it so I don’t know if it’s gotten much better. :thinking: :man_shrugging:

2 Likes

Good tip! I’m just now moving away from IFTTT because of their new billing model, but I was finally able to force the device into SharpTools, and it looks like that integration is actually working!

Thanks for the additional info.

I can totally understand that. Hopefully the Meross integration with SmartThings really has improved. Historically it would work well for the first few days after connecting it to SmartThings and then would all of a sudden stop reporting status updates to SmartThings. :open_mouth:

I also sent you a PM to see if we can gather a few more details about what details the device is reporting now. :slight_smile:

1 Like

Yikes… Fingers crossed it doesn’t go downhill. Worst case scenario, I just use the Meross app I guess. But it’s nice to have the flexibility granted by SmartThings.j

I’ll try to check my PMs; I’m happy to supply any information that might be helpful.

They have updated it. You have to sign out of the linked service and then sign into the new service (which has a slightly different name), but the new one is working much better.

Just in time, since Ifttt is now charging once you have more than three applets. :disappointed_relieved:

3 Likes

It may be better than it was, but I’m noticing that it’s still quite unreliable. When I open or close the garage door using a physical button (or using the Meross app), SmartThings does not seem to update the status until I manually do a status refresh in the SmartThings app. The Meross app, on the other hand, updates the status instantly so there seems to be something wrong in the connection still. :thinking:

1 Like

I’m trying to install the “left it open” app and perhaps not doing something right. I’ve published the parent and saved the “left it open” child but am not seeing the smartapp in the ST app.

When you tapped on the “+”, then Smartapp, then scrolled all the way down to Custom, you didn’t see this?

1 Like

Welp, thats the step I was missing (duh!). Thanks for your help!

1 Like

Hi John,
I am using your smart app for something being left open. Thank you.
I have a couple of questions:

  1. I just saved the Child as you suggested. What would have happened if I had published it?
  2. I am wondering if it would be possible to add the capability of turning on a switch or virtual switch if left on more than x minutes?
    Barrie

Quick question John. I have got the alert for a door being left unlocked kind of working, but it sends the alert immediately the door is unlocked and says it been unlocked for the amount of time its supposed to wait. Its Danalock V3 that is usually opened by the use of the device at the door and the alert is obviously a reminder as we have to lift the handle to allow the Danalock to function. I have put the parent/child in and only published the parent. Any ideas? Thanks for what is otherwise a great app.