Domoticz failing regularly recently

I’ve been using the Domoticz / ST integration successfully (damn, never realised how many double letters that word has!) for the past what… 2 years…?

I use said integration to control my somfy blinds and (with help from @dudz40, thanks pal!) a bluetooth presence service…

I’ve been having an issue as of the past month or so where Domoticz will simply not be responding as reported by ST and then immediately will start responding again… all this in the same minute…

All this (obviously, otherwise I wouldn’t be asking for advice) has happened on an untouched installation… so I’m not exactly sure what’s the cause…


Busy with that one…

met vriendelijke groeten,


Oh, it happened to you too?

Seems to happen when there are not too many devices defined. I have it with a test domoticz. The other one with 100 plus devices no issues.

met vriendelijke groeten,


1 Like

13 devices in use, nearly 300 more in the unused list in my case… strange…

@dudz40, @danielccm, I’m also in your club :joy:, I thought it was something on my network or my sd card was on the way out. Just haven’t had enough time to fully investigate.

Just this evening I installed monit on my pi3 figuring that at least I know when domotixz stops a reboot of the pi will get it going again.

1 Like

@KellyDarren I updated the domoticz app thru the github integration just yesterday, and since then I’ve had no connection issues anymore! kudos to @dudz40 for figuring it out! lol!

1 Like

7.26 now on github as well, should fix another issue as well.

1 Like

Should I apply the patch? or just update to 7.26?

No need to do anything with patch. I will be read by the app. Just 7.26

1 Like

@danielccm, @dudz40 I’ve upgraded to the latest version of Domoticz, thanks Martin, but my domoticz still goes down. Again I haven’t troubleshooted this issue, just mentioning it, however monit is doing its job well and restarting my domoticz service which means my light automation now works where as before each time domoticz failed my auotmations stopped.


@Stegho is also having issues with this… My issues began again today… The Domoticz server will randomly stop working, and force me to reboot the entire raspberry… ideas?

Hey guys, I confirm seeing a similar behavior. However, I installed all just recently, so can’t confirm a day, when it started, as for me it always was.
I have 2 mobiles with ST app, and both of them give me these errors simultaneously.

PS: I am not restarting my Domoticz RPi, neither anything else. The thing just comes down and up again by itself.
PPS: @danielccm - how come, U have the github? I don’t. I understand it’s because of the EU IDE/API…

I’m still running into issues with the DZ server… could you help me out installing this and making it run a script as well as starting domoticz? Thanks!

1 Like

I installed it years ago… can’t remember exactly when or how, but it was easy, as well as very handy!

@danielccm give me a little bit, when I’m back near a pc I will be able to assist, no problem.

1 Like

No worries… I’m also thinking of changing my Domoticz server to a Synology DS918+ so I’ve got time…

@Danielccm These are the instructions I used to install Monit, Install Monit

I left pretty much everything the same as the instructions. I didn’t do automatic eMail notification or anything like that.

So basically it was log into the PI and complete the following, I would recommend updating the PI first mind (back up though before you update)

Update PI
sudo apt-get update
sudo apt-get dist-upgrade

Clean up PI and any old files
sudo apt-get autoremove
sudo apt-get autoclean

sudo reboot

Then install monit
sudo apt-get install monit

Edit the monitoring file to add Domoticz
sudo nano /etc/monit/monitrc

I changed the checking from 300 to 120

Then under the webservice part I entered the following
use address IP Addy of PI

Then under the Configuring Monitoring of programs part of the link change the template IP address to your IP Addy of your PI and Port No

Follow the rest of the links commands.

Basically exit the file and save it
sudo monit -t (to ensure the code in the file is ok)
sudo monit start all
sudo service monit start

sudo reboot - habit I do after all configurations.

Check the webserver to see if working, Monit is running its own Run Server on your PI which is accessible from your PI IP Addy:2812

It should look something like this when you load it up


If it does not load up from the PI type

sudo service monit reload

and retest.

See how you get on, any questions, just reply and I’ll see if I can assit more.

1 Like

Monit: the monit HTTP interface is not enabled, please add the ‘set httpd’ statement and use the ‘allow’ option to allow monit to connect


@danielccm it seems to relate to your ip configuration.

I assume when you put the ip Addy of domoticz into your browser it loads correctly?