Dome Water Valve Control

Having jumped in full throttle setting up lights I figured it was time to move onto some other automation: my shower!

A day of plumbing later and I’ve got a Dome valve setup and hooked into SmartThings (showing up as a zwave valve). The problem is that while I can control it from the app on my phone, I can’t through any other interface. Google doesn’t see it in assistant, and neither do my logitech pop switches. While I could survive not being able to turn the shower on with my voice, the fact that I can’t turn it on with a button is a big issue. As it is I am the only person who’d be able to use the shower, and only if my phone was charged. Is there some way to get the valve to register as a switch so it could be controlled by other devices?

Are you just using the default DTH (Device Type Handler) from pairing or did you add @krlaframboise’s from the below thread? If it shows up as z-wave valve, it sounds like you’re just using the default pairing which will be a bit limited in all likelihood.
Check out the below thread for the custom DTH.


So I had tried adding the the handler, but looking at it it doesn’t seem like it is being recognized.

Followed the steps to a T, saved and published, and have tried reconnecting the Dome a number of times.

So this goes on the very short list of times where I’ve posted a question then stumbled into the answer a few minutes later making myself look like a fool. I don’t quite know why, but for some reason the DTH was just not functioning. Followed the exact same steps to make another and everything worked fine.