Dome Water Valve no longer works with Google, Alexa and Home Assistant after firmware update to 047.00010

My Dome Water Valve no longer works with Google, Alexa, or Home Assistant
According to Google, the device now no longer exposes itself as a switch, but rather as a binary sensor. Google, Alexa, or Home Assistant cannot turn on/off binary sensors.
It worked perfectly on the previous version of firmware ( on my Smartthings Wifi .

Does anyone know how to covert this back to a switch so Google, Alexa, or Home Assistant can turn it on/off ?

I just noticed that Alexa no longer see my Dome valve as well. A work around for it would be to create a virtual switch that Alexa can see and use routines to keep it in sync with the valve.

Which Edge driver is it using? You may want to try removing and pairing again.

How would I find that out ? Below is what I see in (

Under Devices > Water Valve

Device Profile - valve-generic
Driver - Z-Wave Valve

I am wondering if removing the device and pairing it again may resolve the issue. Just note: it may or may not. Could it be related to the device being switched from DTH to Edge :man_shrugging: :man_shrugging: :man_shrugging: :man_shrugging: :man_shrugging: unless it was already using an Edge driver before this issue started. Something to try at least. But removing the device would remove it from Google and Alexa and put it back when you pair again. Dome Valves are the hardest devices to add though, IMO, with the 3 rapid button presses.

The driver you posted above is the right one… just wanted to check. You two are the first to post this issue with Dome Valves that I have seen. So many issues have been showing up lately.

Fortunately I have a second Dome valve. I just added it and it appears as a binary_sensor as well.

To me, without the ability to use Google or Alexa to turn on/off the valve is a game ender. If Smartthings doesn’t get this resolved, I’m done with Smartthings…

The standard Groovy DTH for z-wave valves also didn’t have switch (on/off) capability. I’m guessing you were using a customized Groovy DTH that added it. Then the device was migrated to the standard Edge driver, which also doesn’t have switch capability, since you didn’t have a custom Edge driver installed with the same features as the custom groovy dth you were using.

1 Like

I was using the custom Dome Groovy DTH by Kevin LaFramboise

SmartThings/devicetypes/krlaframboise/dome-water-shut-off.src/dome-water-shut-off.groovy at master · krlaframboise/SmartThings (

Any idea where I can get a custom Edge driver that would allow for the valve to act like a switch, like Kevin’s did ?

The only way your going to get back the switch functionality is going to be with a virtual switch and 4 routines to keep it in sync with the dome valve. Use TAustins virtual device generator below.

Create a virtual Alexa switch and name it Water and create 4 routines.

  1. If dome water valve is open then turn Virtual Water switch on
  2. If dome water valve is closed then turn Virtual Water switch off
  3. If Virtual Water switch in on then open dome water valve.
  4. If Virtual Water switch in off then close dome water valve.

Simple, now you can say Alexa turn water off and Alexa turn water on. That’s how I fixed it for me. I don’t have Google home or Home assistant so I’m not sure about those but they should see the virtual switch as well.