[RELEASE] Dome Water Main Shut-Off (Official)

water
dth_plumbing
dth_irrigation

(Kevin) #1

This is the Official device handler for the Dome Water Main Shut-Off (Model: DMWV1)

  • Open the valve with the open command or on command.

  • Close the valve with the close or off command.


      


See the Using the Dome Water Main Shut-Off with SmartThings manual for more information about this device handler and detailed installation instructions.


Water Valve Cycling SmartApp?
Dome Water Shut Off Valve
Dome Water Valve Control
Dome Home Water shut off valve
Dome Water Shut Off Valve
(Chris H) #2

Great stuff here, Kevin - thank you! Your professional attention-to-detail with your DH builds and SmartApps is much appreciated. Donation happily sent :thumbsup:


(Kevin) #3

Thank you, but I can’t take all the credit for the Dome Device Handlers because the Dome team provided a lot of good suggestions.

Thank you for the generous donation.


#4

When I open or close the valve using the SmartThings app, it will say “Opening” or “Closing” indefinitely. If I immediately do a refresh the status is not corrected. However, if I wait an hour or two and do a refresh the status will be updated correctly. This problem just started recently but the device handler obviously hasn’t changed in a while. Is anybody else having this issue?


(Krapohneb) #5

Having similar problem and just started recently. Perhaps with new Smartthings update?


(Kevin) #6

It’s most likely related to the platform bug below that started last week. I was hoping they’d fix it fast enough to avoid having to add a workaround to all my DTHs, but I’ll take a look at this one tomorrow.


(Kevin) #7

I just published a new version that should fix that problem.


#8

Thank you! I tested it out and the workaround for the SmartThings bug works.


#9

Kevin,

I’m now using your handler. Great work, thanks.

Just a minor point that you may want to revisit at some point to update for the color changes ST introduced some time back. I think it’s just the blue that is inconsistent.

Also, I can’t figure out why the icon on the main tile shows the ‘closed’ icon (no drip) when it’s open. the code looks correct.


(Kevin) #10

If I remember correctly, “canChangeIcon: true” in the main tile messes with the ability to change the icon programatically.

When I have a chance I’ll make the color change and see if removing that solves the icon issue.


(Eric Miller) #11

I’ve created the device handler in smarthings and it seemed to connect just fine. I tried to operate the valve via SmartThing, but it doesn’t actually move, the icon changes like it should be tho? How do I get this thing to start responding?


(Kevin) #12

Did you create the device handler before adding the device?

Does the device open and close when you push the physical button on the top of the device?

If you log into the IDE and open live logging and then try activating it through the mobile app it might provide additional information about why it’s not working.


(Eric Miller) #13

I attempted to connect it before I knew you had create the device handler for it, but it did not connect to the network. Then I created the device handler and added it.

The device opens\closes fine when pushing the physical button on the device.

When I check the logs it shows it as follows, but it never actually moves the valve unless I press the physical button(status updates properly when button is physically pressed)
8:07:02 PM: debug Requesting valve position.
8:06:48 PM: debug Valve is Open
8:06:38 PM: debug Closing Valve
8:06:36 PM: debug Valve is Open
8:06:26 PM: debug Opening Valve
8:06:24 PM: debug Valve is Open
8:06:23 PM: debug Requesting valve position.
8:06:21 PM: debug Valve is Open
8:06:12 PM: debug Closing Valve
8:06:06 PM: debug Valve is Open
8:05:57 PM: debug Device Checked In
8:05:56 PM: debug Closing Valve


(Eric Miller) #14

Anyone have a clue as to how to get this thing to respond to zwave command’s? Kinda defeats the purpose of having it when it doesn’t work lol


#15

Sounds like you got a dud. Get a replacement.


(Kevin) #16

Remove the device and then reset it by holding the open/close button for 10 seconds. A flashing light indicates that it was successfully reset.

After doing that, add it back to SmartThings and if it still doesn’t work you’ll need to get a replacement.


Dome Water Shut Off Valve
(Eric Miller) #17

this did the trick for me! it is now working!

*** it did take several attempts of removing/resetting if anyone else reads this and it does not work for them


(Charles) #18

@krlaframboise Thanks for this DTH. I have a problem with the device that is not an issue with the DTH, but I wonder if it’s possible for you to compensate in the DTH?

The arm has no adjustable limit capability and mine tries to swing too far, in both the open and closing cycle. I’ve tried everything that’s been suggested here to solve the physical incompatibility between the motor and the valve arm. The motor tries indefinitely to complete the close (or open) operation. I’ve just accepted that in an emergency I’d prefer to close the valve 99% and probably have the motor burn out.

So, finally, my question: Is there a way for the DTH to recognize that the cycle is running too long and stop the operation after some period? I wouldn’t want it to revert to open, but to just leave it in a mostly-closed state. Thanks!


(Kevin) #19

When you execute the “close” command all the DTH does is send an off command to the device. If I remember correctly the device immediately reports that it’s off so the DTH has no way of knowing if it finished closing the valve.

To prevent burning out the motor you could attach it to a smart switch. When water is detected have one rule that closes the valve and another that waits 1 minute and turns off the switch.


(Charles) #20

Brilliant! Thanks for the idea. Will do.