Dome siren unable to connect to v2 smartthings hub

Hi Guys.
I have a v2 smartthings hub with multiple devices connected.

Recently purchased Dome Sirens to build out my security setup ( multiple motion sensors ).

I have reviewed multiple yourtube videos, and read many posts on connecting this device to my smartthings hub, however, i cannot get the siren connected.

I have installed the Dome siren driver as directed in many tutorials.

My issue is, i cant connect the siren to my hub.

From what i have learned so far, i only need to install the Dome siren driver from here -

Any advice would be most appreciative ( I am pretty new to this, so have only connected devices that did not require any additional drivers )

try excluding it and then add it

Hi jkp

Issue is i cant add the device at all. I did also try to exclude it, however since the hub is not detecting it, is also unable to exclude it.

I have 3 of these sirens, all with same behavior.

I added the driver as instructed in the steps here

You can install the edge driver from Dome’s Edge Driver Channel .


  1. Click the link above
  2. Log in with your Samsung Account
  3. Click the “Enroll” button next to your hub
  4. Click the “Available Drivers” button
  5. Click the “Install” button below Dome Siren
  6. Add the device

Strange. I have since factory reset the hub and unable to find the access code ( Opened a case with support to retrieve the code so i can again access the hub )

Thank you for your response

reset the device next (after you get your hub restored)

Reset to factory default

This device also allows to be reset without any involvement of a Z-Wave controller. This procedure should only be used when the primary controller is inoperable.

To disconnect from the Z-Wave Network and restore factory default settings:1. Open the Back Plate and make sure the Siren is powered.1. Hold the Connect Button for 10 seconds until the LED Ring blinks once, then release the button.Only do this if the controller is missing or otherwise unreachable!

another thought is… you are not properly putting the device into inclusion/exclusion properly.

if you have the Edge driver installed onto your hub:


  • tap the button on the siren 3 times
  • tap Add Device in the ST app
  • tap Scan for nearby devices (Do not use by brand > Dome)


  • tap the button on the siren 3 times
  • open the hub tile in the ST app
  • click on the 3 dots
  • choose Settings from the menu
  • select Z-Wave utilities
  • select Z-Wave exclusion

Hi jkp.

I have obtained the access code from smartthings support, but i also purchased a v3 Aeotec hub, which is also not connecting to either of the 3 Dome sirens.

I suspect i have dome something wrongs, im just not quiet sure what.

To begin with, i added Domes Edge driver following the link provided in this page - [ST EDGE] [RELEASE] Dome Siren (Official 2.0)

Verified the driver was added
Hub → three dots → driver → Dome siren ( And channel hub is registered with is Dome drivers ).

To add the device, as you stated above:
( Siren ) press button 3 times rapidly
( Smartthings app ) Add device → scan for nearby devices

After some time, the process times out, and no devices are found.

I have also tried to exclude them ( No devices are available )

I have reset the siren ( Multiple times ) by holding button for 10 seconds.
Confirmed batteries are 100% ( put them into my motion sensor )

I have 3 of these devices ( sirens ), none of which are visible to my hub.

i have also created a support ticket with Dome for further assistance.

Really appreciate you suggestions, im just not sure what is wrong.

I sounds like you have an exclusion problem. Until you exclude it you can’t pair it.


Factory reset the device again and don’t use the “scan for devices” option when joining the device because it doesn’t aways activate z-wave inclusion.

Scroll down to the “select device” section, change it to “by brand”, and then choose “z-wave”.

You also have to triple-click the button really fast so it the led doesn’t start blinking then it’s not in inclusion mode.

Hi jkp

The siren is 1-2 feet from the hub when trying to pair…
1-2 feet from hub
Batteries are 100%
I have hard reset the HUB and siren
Moved Hub away from router

Still no luck

I will try this tonight.

When i reset the hub a few days ago, i had no issues re-connecting 2 other z wave devices ( Fibraro light switch and central heating switch ).

Thank you for your assistance

Hey Paul.

Would this only be an issue if the device was included first ?

The sirens are new, and have never connected to any hub.

I have reset both hub and siren, tried exclusion, repaired z wave network etc.

all the steps recommended online anywhere i have checked,

Thank you for your help

If the device was never paired with a system there should be NO to exclude it. But even a new device may have been paired for tested in the factory or it may have been a return. In those cases exclusion may be needed.

Some Z-Wave wave devices can be a royal pain to pair. I recently purchased some Monoprice Z-Wave contact sensors that were really cheap on clearance. It took as at least a dozen tries to get them paired. After the first one was paired I thought I had it figured out. But the second one was no easier to pair. Now I know why they were on clearance for so cheap.

I have reset the sirens again. repaired z wave network, ran exclusion etc
Still no joy.

Open a ticket with Dome last week, explained everything i had done, user v2 and v2 hub, reset, exclusions etc etc.

Their response "Have you tried contacting Aeotec? They might have not integrated our siren in their latest hub. "

I did mention v2 hub was also used.

Seems like Dome support are of no use.

Appreciate everyone’s advice. Ill continue to try connect the siren.

The Dome Siren doesn’t support any security protocols which I think might be the reason why it often gets stuck when I attempt to join it using any method other than manually choosing z-wave from the brand list.

When you triple click the siren’s action button while joining the device does the LED start blinking?

HI Keviin,
Thank you for responding.

I have tried the method in which you have suggested, however, i still am unable to pair the dome sirens.

When i press the button 3 times quickly, the LED flashes 5 times as suggested on the manual for inclusion mode.

The strange thing is, i have 3 new sirens, and neither of them have even been identified by my new Aeotec v3 or Smartthings v2 hub ( Selecting z-wave under brands, or Scan for nearby devices ).

I will retry all methods again, reset everything again etc. I dont see anyone else experiencing issues similar to this. I was searching in hope i was doing something wrong, but i believe i have done it correctly.

Thanks again