DNS lookup error for account.samsung.com

I have found that for the last day or so I have not been able to log into my SmartThings account. I noticed that a dns lookup of https://account.samsung.com will fail, not only from my local network but from other dns utilities online, like Dig (DNS lookup). They all fail. I would think no one can login, at least in North America until that’s resolved. Has anyone had trouble logging into their SmartThings account??

Mine is working fine, but I’ve always used the smartthings URL, not the Samsung URL that you listed.


Is the universal login for the ID E.

Both account.samsung and account.smartthings are also working for me.

Do you use anything that may be blocking - such as VPN or DNS services?

Thank you both, I’m not sure what’s happening exactly. For me https://account.smartthings.com redirects to https://us.account.samsung.com, for which I also get a “server not found”. I don’t use any vpn or anything. I appreciate the responses, I opened a ticket and will continue to investigate from my end…


Be sure to type https://account.smartthings.com and https://account.samsung.com and not http

1 Like

People have been reporting issues on Reddit also.

1 Like

As @jkp noted, only https:// will work, http:// has always been blocked as far as I know.

FWIW, the link in my post included the S, but the links in yours do not.

Thanks, yea, I always use the https:// versions, I just didn’t bother to spell out the protocol part when I typed them out here. Even when I directly click on the links you guys posted, I get the same “server not found”. I appreciate the clarification though!

1 Like

the only thing I can think to try is to temporarily change where your DNS points to. I am using which I am able to access the above sites. If it doesn’t work, change DNS back to your original settings.

Thanks! Yea, I see there seem to be lots of users with the same problem… Hopefully it will get picked up by Samsung and fixed ASAP. As of right now, their status site still shows the americas region as “green” I.e., operational.

One of the Reddit posters noted that one or two dns servers still resolved the https://account.smartthings.com host properly. I added both his suggestions (opendns @ and Verizon @ manually on my phone and it worked. I was then able to login to the site and the app, and use things normally. Others who are having this problem, you could give this a try until they all work normally again.


I’m glad you found a workaround.

Meanwhile, whenever you post the URL to the forum, please make sure it always has the “S“ or the link will always be broken for anyone in the future who tries it, and that can be very confusing. :thinking:

1 Like

Fair point. I was really only trying to refer to the hosts (rather than the complete urls) since that’s what dns actually translates, but since the forum turns plain host names into a clickable url, I figured I would take your advice. So I edited my previous posts to add the https part in case someone clicks. Thanks for the feedback.

1 Like

Figured the title was pretty hard to miss, if you went and looked over there. Good to know it worked for you.

1 Like

For me (Norway - Europe) did it work earlier today, but now am I also redirected to https://my.smartthings.com/