Disconnected switch, possibly due to metal cover plate


(Hal) #1

I have a Leviton Z-wave switch that operates a single LED can light above the kitchen sink. The switch has a stainless steel cover plate.

I’m certain it’s functioning as a relay for two Zooz switches that are farther from the hub as those didn’t work until I installed this one.

I can operate the switch manually and via Alexa. In the new SmartThings app, it shows as disconnected.

I can turn it on via either version of the app, but the apps never get feedback showing it as on so I can’t turn it off via the apps.

Any thoughts? Anyone else have switches with decorative metal cover plates?

I tried placing an Aoetec Z-wave relay a couple of feet from the Leviton switch and ran Z-wave repair. No improvement


(Hal) #3

Sending a command from Alexa seems to temporarily cause the problem switch to come online. But the next time it’s pinged by the hub, it fails to respond and gets marked offline again.

Plastic cover plates on order. Also plan to swap this out for a Leviton dimmer. I’m using Leviton here because they have replaceable switch plates so I can have black switch in this location.


#4

Which model and DH? Anything interesting in live logging? Does it work better with the switch plate off?


(Hal) #5

“Leviton DZ15S-1BZ Decora Smart Switch with Z-Wave Plus Technology” using the Z-Wave Switch Generic DH.

Events for the switch showed:

7:50:02.722 PM ping command was sent to [device]
7:50:02.732 PM ping command was sent to [device]
7:51:04.693 PM Your SmartThings device [device] is now offline
7:55:56.670 PM Amazon Alexa sent on command to [device]
7:55:56:675 PM on command was sent to [device]
7:55:57.052 PM Your SmartThings device [device] is now online

The Leviton showed as online and switched off in the new ST app so I tapped the tile to turn it on. The light turned on but the tile did not update to reflect that. So I can’t turn it off via the app. Alexa, however, happily turned it off.

I got the same behavior with the cover plate off. So I guess that isn’t the problem.

In Live Logging, I see “debug Parse returned switch button was pressed” if I tap either the on or off paddle on the Leviton. I do not see that same debug message when I tap the paddles on a Zooz ZEN26 switch I have which is using the same DH.

I see that same debug message in Live Logging if Alexa sends a command to the switch.

I’ve got a routines to turn the Leviton and a Zooz dimmer which controls some other lights in the kitchen both on and off. I have a virtual switch to control both together by running the routines. Using the virtual switch and the routines works perfectly, just like Alexa.

The only thing not working is the tile/button for the Leviton switch in the apps never gets updated to show the Leviton as “on”. And, if the hub sends a ping, it must not be responding because it then gets marked as offline.


(Hal) #6

Searching and finding other threads with Leviton DZ15S-1BZ issues.

One thread mentioned Device Health. I had Device Health on when I added the Leviton but turned it off earlier today. Not really sure when the issues with this switch started.

Tomorrow I’ll also try excluding the switch and re-adding it.


#7

It’s switching in response to a basicSet, but won’t send a report in response to a switchBinaryGet. It being marked offline is because it isn’t responding to the ping, which sends a switchBinaryGet. Meanwhile, it shows online when you use Alexa because it sends that switch was pressed event (which appears to be the Hail command class).

Exclude/include is a good step to try. You might’ve already seen the thread below, but it’s a success story that might work for you. Otherwise, could try to see if it responds to a basicGet.


(Hal) #8

Thanks! I did see that thread.

I need to reset this switch and move it to a different location anyway. Decided I want a dimmer for the sink light.

So I’ll use the procedure in that thread.


(Hal) #9

Followed the process in the thread you referenced and the switch seems to be functioning normally. I now see this in the live log:

I still intend to swap this switch for a dimmer and install the switch in a different location but have other projects to deal with first. We’ll see if the switch drops offline in the next few days.

Thanks much for your help @philh30 . I’m pretty much a noob to SmartThings but with a software development and IT background. Lots to learn!


(Hal) #10

I have three Leviton Z-Wave plus switches, two DZ15S switches and one DZ6HD dimmer.

  • All three of them paired out of the box with no issues.
  • All three worked for some period between one and three days.
  • All three of them suddenly started showing as disconnected in the new ST app.

In all cases, they’d respond to commands from Alexa or from Smart Lighting automations. But the status in the ST apps would not get updated to show the switch as ON.

I’ve used the factory reset and re-add process from the linked thread on all of them and, for the moment, all are working normally.


(Hal) #11

Son of a …

Now the Leviton dimmer is failing to report status. ST apps see it as ON so I can’t turn it off via app.

Found a thread that says Leviton has a firmware update so I guess I’m going to have to invest in a copy of Z-flash and a Z-wave USB stick.

Not buying another Leviton switch!


#12

Ouch. There’s always a chance that this could be solved in the DH, depending on what the device does/doesn’t respond to. There are a few different zwave commands that could potentially get it to report state, and maybe it’ll respond to one of the others. Is the dimmer using the “Z-Wave Dimmer Switch Generic” DH?


(Hal) #13

From what I’m reading on the thread which suggests updating firmware, it’s some sort of sync problem.

I’m using the “Z-Wave Dimmer Switch Generic”. There is a community-written DTH but it seems to not fix this problem. Folks who have gone thru the hassle of a firmware flash seem all end up with working switches.

My two DZ15S switches seem to be fine now. One of them has been perfect from day 1 (leading me to order a couple more Leviton devices), the other one caused me to initiate this thread. Both are now in a double-gang box in the garage.

The dimmer is now in the kitchen behind the metal cover plate.