[Direct-Connected] Issue with Raspberry device

Hi, folks. I’ve just opened Direct Connect using TAustin's RPi solution failing device registration · Issue #110 · SmartThingsCommunity/st-device-sdk-c · GitHub.

In brief, Todd and I are somewhat buffaloed about why my attempts to use his rpi-st-device package on a Raspberry Pi Zero W have been failing. The ST android app keeps reporting error code 04-100 when I try to actually register the device. I’m using Todd’s mastersetup script, so most of what I’m doing should be the same as other users of his package (though I’ve been running some of the stages via ssh rather than from the Pi’s keyboard and display).

Either there’s a mistake I’m making that Todd hasn’t spotted, or there’s a subtle system-code or processor difference on the Pi Zero W, or there’s a timing issue, or … Something. At this point I think we’re both looking for ideas on how to narrow that down. Suggestions more than welcome!

“If it happens, it must be possible…”

(Ultimate goal of all of this is to put a Mitsubishi mini-split HVAC system under SmartThings control, which is something I haven’t seen a canned solution for. But right now I’m just trying to get the switch example running.)

Hi, @keshlam!
Sorry for the delay.

As the direct-connected team hasn’t made a release of the SDK to work with an RPi, we don’t know about common scenarios with it but you could share the logs of the integration.
If you have tried to replicate the error, I can ask the team to check the logs using the error code and timestamp.
There was an issue with RPi a while back, I don’t know if it’s related:

The issue seems to have been that my access point was configured to offer both 5GHz and 2.4GHz using the same SSID, and either the SDK or Todd’s code wasn’t handling that correctly. There also seemed to have been some problems of truncation of an SSID containing a space. Turning off 5GHz in the router, and then selecting the SSID manually during device registration, seems to have worked around the problem.

Is it really necessary to enforce 2.4GHz-only?

If it is, could we figure out why the code didn’t discover the 2.4GHz available for this SSID?

Product devices from other companies were able to connect successfully with both frequencies available, so this is apparently something in either the SDK or in how Todd is using it.