Dimmer control?


(physikal) #1

I made the mistake of buying dimmer switches thinking that’s what I wanted. Now, often times I find that other members of the family don’t get how they work so they will accidentally dim the lights to 80% or so, then shut them off. So lights aren’t always @ 100%. Is there a way I can set it so the lights are always @ 100%, if someone tries to dim, they’ll go back to 100% the next time they are turned on?

Thanks!


#2

You can probably set up an automation to do it, but some model switches have this as a parameter that you can set on the switch itself, and that will be easier because just a one time set up . What is the brand and model of the switches that you have?


(physikal) #3

I have the GE switches found here: https://www.amazon.com/New-Model-Wireless-Lighting-Wall/dp/B01MUCZA1C/ref=sr_1_1?ie=UTF8&qid=1507744816&sr=8-1&keywords=zwave+plus+dimmer


(physikal) #4

Anyone have any ideas?


(Paul) #5

Are you familiar with WebCORE?

I’m sure you could do some simple piston to do that.

The logic would go something like this
When “dimmer” state changes to Off, then with “dimmer” set level to 100%, then turn off.

Check out webcore, there are a lot of people willing to help with this.


(Allan) #6

So what you are saying is when someone turns them on you want them to go to 100%?

If so this should be easy to do using the “Smart Lighting” app. Go into your SmartThings app then to Automation -> SmartApps. If you don’t have Smart Lighting listed click “+ Add a SmartApp” then “Lights and Switches” then “Smart Lights”.

Go into Smart Lighting and create a new Lighting Automation. Select the lights you want to control then for What do you want to do select Turn on and Set Level. Set the dimmer to 100%. For SElect Trigger switch it to “Switch” then for Which Switch pick the same one. For when say Turned On. Uncheck Turn off as well.

This should effectively say when the switch turns on set it to 100%. It still will work like normal beyond that, you can change the level manually or through the app, but when it first turns on it will go to 100%.

Re: webCore. Its fine for things that built in apps like SHM custom routines or Smart Lighting can’t do but it doesn’t make sense to take something that could run 100% locally in your hub and force it over the cloud. Why re-invent the wheel and make things more complicated.


(Ron Talley) #7

Expect a delay with the GE Switches doing it that way.

I found I’d rather deal with the slight Blink when turning Off, set Level and the turn right back Off vs turning On then set Level and wait for light to go to that Level.