Devices offline, no fix in sight. Smartthings has acknowledged the bug

My hub (and all connected devices) has been intermittently “Offline” over the last couple of weeks.

I literally cringe when SmartThings announces that it will be “upgrading” its firmware or mobile app. I can’t think of any other major (or even midlevel) tech company that consistently releases such buggy software.

In my case, the devices that go offline are always query for Refresh too often, almost every minute:

Here are the details from some of them:
Guest Bathroom: 8:12 pm, 8:10pm, 8:07pm, 8:07pm, 8:06pm, 8:06 pm, 8:05pm, 8:03 pm, 8:00pm, 7:55 pm, 7:55 pm
Kitchen Sensor: 8:12 pm, 8:10pm, 8:07pm, 8:07pm, 8:06pm, 8:06 pm, 8:05pm, 8:03pm, 8:00pm, 7:55 pm, 7:55 pm

And the same for any other device that is offline and used as temp sensor in ecobeeSetZoneWithSchedule

In order to test I have modified ecobeeSetZoneWithSchedule to avoid calling Refresh on the sensors.
I will report back in a week with the results to see if any device goes back to offline.

I manage to get some devices back thanks to supports help. these are the steps:

  1. Disable device health, it causes problems.

  2. For each device that are ‘lost’:
    To remove and replace a Z-Wave device using the SmartThings app:

Tap My Home
Tap Things
Tap the failed Z-Wave device
Tap the gear icon
Tap the red Replace button
The Z-Wave protocol will first attempt to communicate with the failed device to confirm unresponsiveness. This process can take several seconds
Once the device is determined to be unresponsive, the Hub will search for the replacement device

When the Hub is searching and indicates the device is ready to be replaced, perform the replacement device’s connection (or “inclusion”) process. This process is specific to the device and is the same process you used to add it to the Hub. For Z-wave switches, it is often just turning the device off and on again. If you’re unsure of what the connection steps are, let me what the model of the device is and I can help look it up.
If your devices don’t fail then double check if they respond after your app says the device is not failed.

I still have at least one device ‘lost’, and hope to get more help.

Progress at least.

Mine came back online after that issue got resolved last week. Back at it again. Dropping offline. what a PITA.

Strangely, there seem to have been two different waves of problems with a similar symptoms.

One started about three weeks ago, and that includes the problems reported in this thread.

The other had a very specific start date of April 20 and immediately broke DTH’s.

The more recent one is definitely associated with refresh () and is being discussed in the developer section of the forum in the following thread:

Your investigations indicated there may be an overlapping cause, it’s just the timing is so strange.

Just doing a 4 day checkpoint.
Good news:
So far i have not seem any motion sensor or water sensor gone offline.

Also. To make perfectly clear: This is not a bug in ecobeeSetTstatWithSchedule.
This is still a platform bug and this is to investigate a possible work around.

Week checkpoint.

All water and motion sensors are still online. Except for one. I had a WaterLeak water sensor that was also used in ecobeeTstatSetSchedule. Becuace this device uses a custom handler it was not reported as offline and i missed a week ago when i reconnet all the offline devices.

There were 3 devices (including the last one) whose battery was dead. (Could had they died because the refresh command too often?)

I also notice that most of my keen vents were also not reporting back and were not responding to commands.

So. I reconnect all my keen vebts and all other sensors.

I still one extenal temp sensor that is offline. I will try to recover it.(This was also used by the app)

Anyway. I will run for another week. But so far i have not seen any device gone offline after recovery. :slight_smile:

A bit of bad news.

I have 2 spruce sensors, one of them was used as an outside temperature sensor.

When trying to make the sensor online again I notice that:

  1. The battery was dead, so this will the be 3rd device with dead batteries
  2. The LED on the device will always steady blue and it was impossible to re join the device to the network. (Spent some time with support to trying to recover the device) I am afraid this device has been damaged.

Interestingly enough the other spruce sensor have had no problems at all, but it has never been used by ecoBeeSetTstatWithSchedule.

One suggestion for others with similar problems:

It seems that SmartThings has recently updated many of the DTHs for devices to add Health Check support. But while these updated devices were (silently) installed over the existing DTH’s, they were not “updated” to register their new support. I suspect, therefore, that some devices are being marked off-line because they haven’t been properly initilized/updated after the DTH was replaced.

At least for me, after opening the preferences for each “disconnected” DTH, then saving it again, the problems have (largely) gone away. I suspect this is because upon save, the (new) updated() function is being called and the DTH is able to properly configure its Health Check support.

So - try opening/saving the preferences on your DTH instead of toggling the switch (or hitting refresh). This MAY give you a more reliable resolution (YMMV, of course).


I will try this even though health check is not supported on v1.

I gave this a shot, worked on a few of my devices. This is happening more and more and getting quite frustrating. Device health makes it a lot easier to trouble shoot, but still. Never used to have this many problems with sensors going offline before.

1 Like

I’m not seeing any updates to this issue here and have 6 multisensors and 5 other bulbs and GE inwall switches now unavailable. The idea of re-making all my CoRE pistons after removing all these devices give me great caution in investing further in this platform if this is the only fix after ample time on this reported problem. I’m not concerned about this because it’s a problem, we can work through problems, but when the support team can’t provide visibility as to what’s wrong and proper bug tracking for those of us affected we basically have to put this into the failed hobby box instead of an innovative home living and control solution.


I replaced batteries and got multi sensors working. Reset hue for lights (hue bulbs seem to be unrelated to other unreachable issues) and still working on exclude and zwave gen exclusion for GE In Wall Paddle Switch. Last battery status on sensors that stopped working we’re all above 50% last reported before becoming unreachable.

I only seem to have this issue with Zigbee devices. My Z-wave devices seem to be rock solid. Is it just me or is this a Zigbee specific problem?

I have about 40 ZigBee devices and have only had 2 go offline, one really was offline and the other has had no issues since I reset it (needed to rerun configure). I’ve had a few Z-Wave devices go offline then come back, but I have a much weaker Z-Wave mesh. Since upgrading it recently that has gone away as well.

Interesting. I believe my z-wave mesh to be much stronger (lots of GE switches and wall outlets all over the house). My zigbee mesh is mostly Lightify bulbs (which have always been a little flaky) and a lot of battery-operated sensors.

Has there been any movement/solution for this issue. Since the last update to the App, I have exactly the same issue (several devices that are offline). However, I have tried to remove them and add them back and the app reports “this device cannot be removed”… Replace just times out. Very frustrating. I have several routines coupled with Alexa/Google Home and IFTTT. HELP!!

As far as I know, this issue still pops up, somewhat randomly for people (As this discussion shows). My own issues were resolved by a support person, but it was painful. I still see some devices sometimes ‘forget’ their smartapps, and I have to open one of the apps and re-save it for the device to work. I still have some devices that are now unreachable, for no apparent reason, and so the platform is STILL unstable and suffering.

It’s odd that Samsung doesn’t just fix these 2 or 3 issues once and for all to eliminate these problems that surely happens to more people than the few commenting here. These are essential issues that severely hampers the usefulness. Although, MOST of my devices works, and when they do it’s still awesome. All my devices are Z-wave as far as I know.

I would keep posting here, call support, and put the load on THEIR team to get this solved. I recommend everyone here opens a ticket for their problem and start talking to their team if you can, and maybe someday they will resolve the core issues.

Also, to recap: DON’T EVER turn on the device health feature (as per my support person), as that seems to trigger a ton of stuff like this.

1 Like

The best part is that I just contacted ST support yesterday and they didn’t even mention anything about an issue or bug. It’s ABSOLUTELY a bug. I had no problems a month ago!! Why are they not saying anything!!

It’s very annoying. I have not tried turning off device health but I really shouldnt have to disable a “feature” to make things work properly.