Device pairing with random DTH instead of Edge Driver

I had a Frient zigbee air quality sensor which was paired using a generic ZIgbee Thing Driver.

Now rBoy developed for Frient a specific driver for this (and other) devices.

I unpaired the sensor and repaired to have it pick up the driver, instead it paired with a DTH “Z-wave Remote”, so I can’t move it to a driver.

I tried several times, resetting the sensor and rebooting the hub, same result.
Is this am issue created by the transition to Edge or am I missing something?


For the future, if the device is already paired, you should be able to choose a driver from the device’s three-dot menu if you install something different you’d like to use.

Is that a custom DTH? It sounds like a stock one but worth asking. If it’s custom, you can edit it and comment out the fingerprint section (if it even has a matching fingerprint to your device); I thought that DTH’s had dropped off the priority list for pairing at this point though, so if it paired with a driver previously and this DTH is completely random then it sounds like something changed in error behind the scenes (@nayelyz ?).

1 Like

yes it’s a stock one

I tried to select the driver I had just installed, but it didn’t show up, that’s why I unpaired.

That’s a fallback handler that seems to do the square root of beggar all apart from exist. It has a fingerprint of deviceId: "0x01" and I don’t think it is the first time lately that it, or one with a similarly terse fingerprint, seems to have been confusing pairing for Zigbee Edge drivers.


See [ST Edge] Device not found with fingerprint defaults to standard DTH for an example of a Zigbee device pairing to a Z-Wave Controller deviceId: "0x02". Both Zigbee and Z-Wave fingerprints can use deviceId in DTHs.

That is odd.

I was also under the impression that Edge drivers took priority over DTH.

Even stranger it’s assigning a zigbee device to a z-wave DTH.

Hi, @sulisenator!

If it is paired to a stock DTH it’s because no compatible driver was found.
@RBoy, does this driver have the exact fingerprint for those devices?

If so, we should check what’s going on, we’ve seen some devices aren’t reporting their fingerprints correctly to the Hub and as they’re incomplete, the closest match is selected.
Once, @RBoy confirms, we’ll need your help @sulisenator by following these steps:

  1. Replicate the issue and take note of the time when you did.
  2. Send your Hub’s logs.
    Note: Do not reboot the Hub during these steps, otherwise, all the logs will be deleted
  1. In the IDE, enter “my hubs”
  2. Enter the corresponding Hub and go to “view utilities”
  3. Click on “send” below “send hub logs”

Also, please share the following info (over DM or to

  1. The fingerprint of the device to know which values are expected from it
  2. Your Hub’s ID (the one that appears in the IDE)

Yes it does. However in his screenshot above I don’t see any fingerprint. Maybe the device hasn’t paired correctly plus it’s using a zwave dth while it’s a ZigBee device. Never seen that happen before. @sulisenator whats the raw description on that page. It’s not showing in the screenshot

Yes I’ll do as soon as I get home (I unpaired it)

I’ve sent the log, 8:11 CET when I performed the pairing

@nayelyz was that helpful? Do I need to do it again?

Still having the same issue. Any chance the firmware update will fix this?

Hello, @sulisenator
Sorry for the delay, please, provide the complete information requested above:

I checked and there’s no DM or email from you, did you send one?

I did it this morning, sent a new log, timing 10:53 CET.